Previous 1 2 3 Next 32 Replies Latest reply: May 24, 2015 1:11 PM by ntsaou Go to original post
  • Miggl Level 1 (75 points)

    While I ended up reinstalling from scratch, I have been looking into permissions issues with my home directory. I believe these may be related to this issue, as they started appearing around the same time. There is an easy way to repair your home directory:


    1. Turn computer off, and on again.
    2. Right after the chime, press the Command key to get available start-up volumes.
    3. Choose Recovery HD and hit Enter.
    4. When the first screen loads up, open a Terminal window using the Utilities menu.
    5. Type resetpassword and hit Enter.
    6. When the window loads, do not enter any information in the text fields. Simply choose your harddrive at the top, then click the Clear or Repair button in the lower section to repair your home directory permissions.


    I'm not sure if this is the definitive solution to this problem, but it may help, and can't hurt.

  • Shara_26 Level 1 (5 points)



    "Unofficially" here's the solution and it doesn't invovle reinstalling anything at all. Everything remained intact upon completetion. If you are uncomfortable and this type of thing is foreign to you, I do not recommend that you follow my directions. I'm 100% certain of the code which is the most important part but it is altogether possible that I'm not remembering a less important step along the way.


    1. Go to Utilities menu and open up Terminal
    2. Copy the following script and paste it exactly as it appears here directly after your name
      sudo chmod -R -a "everyone deny delete" ~
    3. You will know it's working because you will immediately begin to see ACL code running -- note that this could take as much as several minutes
    4. When it stops scrolling, enter your computer's password -- it will not appear that you are typing anything as the cursor will not move and you won't see anything on the screen
    5. Once your password is entered, it will bring up a password screen -- note that if that is not what happens, you may have to hit "Enter"
    6. The new screen will ask for your new password. Don't type a new password but just type in your old / current one.
    7. I'm a bit fuzzy here but I believe that it will bring up yet another screen and I'm  hoping that someone can fill in this blank here. It may be an intuitive step that just escapes me.
    8. Next, you will want to restart your computer and as it's starting up, hold down the "Command" and "P" keys simultaneously.
    9. It will bring you to a screen where you'll have see that English is selected. Click on that if you are speaking English and then hit the arrow key.
    10. I'm foggy after this step most likely due to my excitement but basically I followed whatever prompts I received but I believe that I went up to the menu bar and hit restart.
    11. And voila! No more calendars repeating, no more issues with my dock, no more issues with iTunes.


    I'm hoping that someone with some knowledge will test this out and fill in any blanks that I may have overlooked though I don't know that there are many. Good luck to all and I hope you'll let me know if you had success. If you have questions, please post and I'll try to respond late tomorrow evening.


    Good luck all!

  • cjmurf Level 1 (10 points)

    There's an infinitely easier and safer way to fix this.  The problem is in fact with directory permissions where you lose the rights to write into some key directories, one of them which keeps track of when you've acknowledged an alert.  Assuming you have zero software updates outstanding, go to your home directory in Finder (the one with the House) and right-click and get info.  Unlock using your password on the bottom lock so you can make changes.  Make sure that your account has read and write access (it should show that it does), then simply go down to the gear at the bottom of the info window and select "Apply to all directories" (or whatever it says - I'm not in front of a Mac right now).  It will then go through all your directories under your home and make sure you have read/write.  It takes a bit, but then YOU'RE DONE.  Problem solved.  (Apparently there is an internal Mac bulletin about this permission problem and it can cause other issues as well...)



  • nickfrombexhill-on-sea Level 1 (0 points)

    Hi all, 10.7.4 update has fixed all my problems in Lion!!

    No more permission failures or repeated repairs to db's.

    And iCal no longer repeats warnings, hooray at last.

  • dweller51 Level 1 (0 points)

    cjmurf --


    Thank you.  This worked like a charm.  I was so very frustrated for 7 weeks.  Reinstalled Lion, virus searches, and other fix suggestions. 


    But this - simple and direct.  Most importantly, it worked.  No more repeating reminders, no more repeating iCal events notices, no more "damaged" iPhoto library, no more rejected upgrades.


    Thought I was going to have to copy all data and then do a "clean" reinstall of Lion. 


    Thank you again.


         Dweller 51

  • durion Level 1 (0 points)

    Thanks to Shara_26 - I followed these instructions until #7 and retsarted. I wasn't paying attention and was kind of busy so I just carried on as normal and no more repeats!


    Finally resolved and I have a working calendar again!


    Nice one.

  • Shara_26 Level 1 (5 points)

    So glad to have helped. Would appreciate the "this solved my problem" designation if you have a second to do so.  That would help me and anyone else who might still have an issue. Of course, I realize that cjmurph had a far simpler solution and deserves the plug as well. Thanks for posting.

  • cjmurf Level 1 (10 points)

    {Blush} I can't take the credit for any "smarts" behind the solution I posted.  I only got it after talking with the Apple support folk for a couple of days.  (It took about 4 different people being escalated up the braintree before someone in their shop brought up the internal "memo" about this.)  Thanks for the acknowledgement though...

  • cameronreilly Level 1 (0 points)

    Having the same problem, which only started about a week ago. Tried both cjmurf's and shara_26's solutions but neither worked for me. Anyone else finding the same issue?

  • marydaled Level 1 (0 points)

    I'm having the same problem too - started about the same time as "cameronreilly".  I've tried both solutions given by cjmurf and shara_26.  Nothing is resolving the issue, and my alerts continue until I delete the event or the time period has passed.  HELP PLEASE!

  • serving circles Level 1 (0 points)

    Go directly to iCal app and open info, then set the permissions there as cjmurf described.


    I seems that 'apply to enclosed items' from the home directory does not update all apps.


    I tried setting permissions from the home directory but didn't work, so I when directly to the app to see if its permission did actually apply. My user was not even listed in the permissions there. So:


    I added my user (pressed the + button in the bottom left,


    set myself to Read and write,


    then just for good measure, 'apply to enclosed items' (I don't know if this is necessary).


    Then fixed.


    Hope this works for you. I know how frustrating it is.


    I suppose this might work for other apps too. If there a problem try it.

  • WCWL Level 1 (0 points)

    I am so glad I found this post and its helpful comments.  I am on OSX 10.7.5.  But on 20 Feb, suddenly had these problems:


    a) Iphone would not back-up,


    b) New photos would not transfer from Mac to iPhone,


    c) On opening, iPhoto kept on saying that the Library was corrupted and I had to keep on doing "Repairs" or "Upgrades",


    d) (Worst one) an old appointment from 2009 kept on alerting even though it was deleted long ago.


    I then applied cjmurf's suggestion for my home directory and A was solved.  Following the advice of the most recent posts, I then went individually to iCal (D was solved), then iPhoto, and then Pictures directory (B and C solved).


    I still am not sure I understand what happened . . . . but thank you, thank you, thank you to all!

  • mms1234 Level 1 (0 points)

    Hi Serving Circles - I am trying to figure out how to "get info" from going directly to the calendar.  I have this same issue now too and I tried cjmurf's suggestion and it didn't work.  I chickened out on Shara's suggestion b/c of going to Terminal which I don't like to mess with.  However when I go into calendar the only place I can find "get info" is if I've highlighted an actual event and that doesn't let me do what you've suggested.  Any idea what I might be missing? 


    One thing to add to this post.  I use iCal with and exchange server.  I also use MSFT Office on the Mac (as a back-up) and on my old PC.  I'm getting the same error on those applications and MSFT says I need to clear the memory for the calendar but their steps didn't work either.  I'm not sure if this is an iCal issue or an Outlook one.

  • westcoastgirl31 Level 1 (0 points)

    I have tried all suggested options and nothing has worked....anyone else have any ideas to fix this issue???

  • brit_iriz Level 1 (0 points)

    Hi mms1234,


    If you go to the Applications folder in Finder and right-click on Calendar, there should be an option to "Get Info." From there, follow the same steps as described by serving circles. Click on the lock in the bottom right corner and enter your password so that you can make changes. Click the '+' in the bottom left corner and add yourself to the permissions list. Set your permissions to Read & Write. Then click the lock again to save your changes.


    Good luck!