Previous 1 2 3 4 5 6 Next 85 Replies Latest reply: Jan 3, 2015 9:18 PM by Chibi Alois Go to original post
  • Ngabo Level 1 (0 points)

    I have the same problem, I tried to uninstall it but the problem remains the same. And I don't know how to set

    file://localhost/System/Library/LaunchDaemons/com.apple.usbmuxd.plist. Any one can help me!

  • hotplug Level 1 (5 points)

    GREAT !!

    Brilliant !!

     

    Many thanks

    It is 7 days off brainstorming for me to search the solution and finaly found it here !

     

    Love u all too

     

    :-)

  • jfelipe1985 Level 1 (0 points)

    Well I tried removing iPhone Configuration Utility 3.5, reinstalling iTunes again (No Success), replacing AppleUSBEthernetHost and it still didn't work. So I deleted

    /Library/Preferences/SystemConfiguration

    and the Network Settings got reseted to its Defaults. This got my iPhone recognized again. The problem is that my Network Settings got lost and I will have to configurate everything again (VPN Connections, USB Modems etc). But at least the biggest problem got solved.

     

    I'm using MacBook Pro Early 2011 (OS X Lion 10.7.3) and iPhone 4S (iOS 5.1).

  • DopeyDupe Level 1 (0 points)

    FastGTR's solution works extremely well with The File Fab11 Posted.

     

    Here's what I did. Rather simple.

     

    1: Download

    The File Fab11 Posted

     

     

    2: Go to Finder and press

    cmd + shift + G

    3: Paste in this and hit enter:

    /System/Library/Extensions/AppleUSBEthernetHost.kext/Contents/MacOS/

    4: Replace this file with downloaded one

    AppleUSBEthernetHost.kext

     

     

    5: Search for disk util in spotlight and

    run disk utility > select your root drive (Macintosh HD) > Repair Permissions


    This may take a few minutes.

     

    6:

    Restart and done.

    I did not even reinstall or uninstall anything. Confirmed it works, solved 2 sets with the same issue

     

    All the best. If it doesn't work. try uninstalling iphone config util like they said above.

     

    Ohh right System profile.

    Mac OS X Lion 10.7.3, iPhone 4 16GB White, with my iPhone Configuration Utility 3.5(289) still installed.

     

    Message was edited by: DopeyDupe

  • -semantix- Level 1 (0 points)

    Many thanks to all who worked towards the solution - I just tried tethering for the first time today and had this issue. Worked a treat, thanks!

  • Shi'an Level 1 (0 points)

    After months of having no USB Tethering I finally decided I was sick of turning the wireless on and looked to fix the problem.

    After downloading and installing Fab11's file I did a permissions repair and restarted. Finally I have USB Tethering again.


    Thank you so much for this, my sanity is saved again

  • Chris45 Level 1 (0 points)

    I used this successfully too - many thanks DopeyDupe.  I'm running Snow Leopard, but the same solution, using the file from Fab11, worked.

     

    My variation (for those comfortable with the Unix command line): instead of running Disk Utility and repairing permissions, I just used:

    cd /System/Library/Extensions/AppleUSBEthernetHost.kext/Contents/MacOS/

    sudo chown root AppleUSBEthernetHost

    sudo chgrp wheel AppleUSBEthernetHost

  • nealaus Level 1 (0 points)

    Thanks for perfect solution dopeydupe

    USB tethering is working perfectly with your solution

     

    Thanks again

  • Thor Prichard Level 1 (0 points)

    And, it's those permissions that matter!  :-)

     

    This is the correct, working permissions (from the command line using Terminal.app):

     

    ls -l  /System/Library/Extensions/AppleUSBEthernetHost.kext/Contents/MacOS

    -rwxr-xr-x   1 root  wheel   177K 22 Jan 22:23 AppleUSBEthernetHost

     

    Just adding this for everyone's future reference.

  • Nikolaus Heger Level 1 (25 points)

    muellah - thanks those steps worked for me.

     

    I imagine some subset would probably suffice - as long as you delete the USB kext and re-install iTunes, it should work?!

     

    As soon as iTunes was installed, my iPhone USB tethering started working again - didn't even have to reconnect the USB. Brilliant!

  • Ngabo Level 1 (0 points)

    After a long time without using USB Tethering now it's working! Thank you for your support

  • gurple Level 1 (40 points)

    I don't actually think that the problem is that the binary lacks its executable bits. I see the other binary files in other kext bundles also lack the execute bits. Perhaps the bigger issue is that the file is built only for i386. It lacks that x86_64 architecture that is required to load on systems booted with the 64 bit kernel. I would guess that many of us here are running Lion which boots 64 bit by default.

     

    user@localhost:MacOS # pwd

    /System/Library/Extensions/AppleUSBEthernetHost.kext/Contents/MacOS

    user@localhost:MacOS # file AppleUSBEthernetHost

    AppleUSBEthernetHost: Mach-O object i386

    user@localhost:MacOS # file /System/Library/Extensions/AppleFileSystemDriver.kext/Contents/MacOS/AppleFileS ystemDriver

    /System/Library/Extensions/AppleFileSystemDriver.kext/Contents/MacOS/AppleFileSy stemDriver: Mach-O universal binary with 2 architectures

    /System/Library/Extensions/AppleFileSystemDriver.kext/Contents/MacOS/AppleFileSy stemDriver (for architecture x86_64):          Mach-O 64-bit kext bundle x86_64

    /System/Library/Extensions/AppleFileSystemDriver.kext/Contents/MacOS/AppleFileSy stemDriver (for architecture i386):          Mach-O object i386

    user@localhost:MacOS # ll /System/Library/Extensions/AppleFileSystemDriver.kext/Contents/MacOS/AppleFileS ystemDriver

    -rw-r--r--  1 root  wheel    64K Jun 18  2011 /System/Library/Extensions/AppleFileSystemDriver.kext/Contents/MacOS/AppleFileS ystemDriver

    user@localhost:MacOS #

  • Gran Maestro Level 3 (690 points)

    Didn't go that far as to cancel all my preferences but removing the interfaces preferences did the trick for me.

    It immediately recognized the iPhone network interface.

     

    I am using right now to post this message..

     

    Thanks a lot Felipe and all contributors of this thread!

     

    Pieter

  • jira850 Level 1 (0 points)

    Hi, I had this problem already on Lion and it stayed on my MBP after upgrading to Mountain Lion. Anyway, it is enough just to replace the corrupted file fab11 kindly provided here and reboot.

  • Yuchen Lin Level 1 (0 points)

    Thanks so much. it's simple and did solve my problem which has toubled me for several days .