Previous 1 2 3 4 5 6 Next 85 Replies Latest reply: Jan 3, 2015 9:18 PM by Chibi Alois Go to original post
  • kelvintan Level 1 (0 points)

    thnks for ur very simple n detail instruction very much. i have the same prob n reinstall itune would not help. but ur tips help me solve the issues in blink!! thnks!!

  • SouthLake1 Level 1 (0 points)

    suddenly my iphone 5 with ios6 was not teathering over USB via the lighting cable, to my macbook air. i did exactly what DopeyDupe's post said on page three and everythings back working again. thank you!!

  • chrisfromturner Level 1 (0 points)

    I had this problem too with iPhone 5, IOS6. Would not tether on cable, and couldn't get it to work with bluetooth. These suggestions did NOT work. However, downloading and reinstalling iTunes did work.

  • travellinman2112 Level 1 (0 points)

    I followed DopeyDupe's instructions but had the same problem as LewisClegg, ie -

     

    "System extension cannot be used

    The system extension “/System/Library/Extensions/AppleUSBEthernetHost.kext” was installed improperly and cannot be used. Please try reinstalling it, or contact the product’s vendor for an update."

     

    So then I tried the process again and this time used the same file from my wife's Macbook, and now all is good.

  • CosmicMuse Level 1 (0 points)

    Many Thanks, to Fab 11's file and DopeyDupe's instructions, I'm up and running with tethering (after a month of frustration with paid Apple techs who suggested I take my laptop in to see a Genius.) Looks like the true geniuses are the unsung heroes in these forums.

     

    Best to you all and again, Many Thanks!

  • depomnic Level 1 (0 points)

    iPhone USB Tethering suddenly stopped working

     

    Having compared two machines, (one updated the other not) the update of iTunes to 10.7 and now iTunes 11 installed an AppleUSBEthernetHost.kext version 2.3.6 and in the process messed it up.

     

    You need to replace this kext with a good version or an earlier working version.

     

    To do this, download KextUtility and install it, then drag the old working kext onto the KextUtility icon, it willreplace the broken version and fix any other permission issues in your Syst/Lib/Ext folder.

     

    http://mac.softpedia.com/get/System-Utilities/Kext-Utility.shtml

     

    http://cvad-mac.narod2.ru/Kext_Utility

     

    and the working kexts (if you can't find it on your time machine backup)...

     

    Version 2.2.0 (Working on 10.6.8) http://db.tt/Fahk9VBe

     

    Version 2.3.6 (Working on 10.8 & 10.7) http://db.tt/U674UcOV

     

    Nice one Apple, thanks for wasting a few hours of my life, AGAIN.

     

    It's not acceptable that having identified this issue, Apple haven't made the correction on iTunes 11 !

     

     

     

    Thanks you very much Hibernian56 for this solution.

    https://discussions.apple.com/message/20078819#20078819

     

     

     

    Denis

  • ContingencyPlan Level 1 (15 points)

    So anyone have the magical solution (or correct AppleUSBEthernetHost.kext) to use with iTunes 11.  Link?

     

    Upgrading to iTunes 11 on 10.6.8 is a bust.  Who knew?  No functionality now for USB tethering iPhone 4 running 6.0.1 that worked just fine prior to the iTunes 11 upgrade.  Thanks Apple.

  • cynthiajoanne Level 1 (0 points)

    YES! Thanks to depomnic and Hibernian56 I can now use my USB to tether!

    My info: iPhone 4S on iOS 5.1, Macbook pro 10.6.8

    After updating to iTunes 11 I couldn't tether through USB anymore. I tried restoring the AppleUSBEthernetHost.kext file from my Time Machine backup, but that didn't work. Then I tried copying the file from my boyfriend's mac (he didn't upgrade to iTunes 11) and replacing the file on my computer, then repairing permissions through disk utility. Still didn't work. For reference, the version of the file was 2.3.0, which was the file that worked on my computer previous to updating to iTunes 11.

     

    Then I tried the above solution- downloading ktext utility and installing, then using the provided link to download the 2.2 version of the file, and dragged it to ktext utility. It did it's thing, then I restarted my computer and plugged in my phone. It took a minute but then the connection was made via USB and now it works! Success!

     

    Thanks so much. But not to Apple.

  • o1sound Level 1 (0 points)

    Running 10.6.8 on my MBP and iOS6 on my iPhone.  Could never tether. Followed steps 1 to 6 from DopeyDupe and now tethering flawlessly. Just one thing, in Step 4: Fab11's file is just "AppleUSBEthernetHost" not "AppleUSBEthernetHost.kext". So worry not and just follow the instructions and don't forget to repair permissions (took 22 minutes for me).  Awesome solution. Nice to be tethering again.

  • DopeyDupe Level 1 (0 points)

    Oh. forgot about that.

     

    For those who play around with tweaks and file types like myself, you'll see the file as a .kext file. If you do, yes, that's the file.

     

    For the others with extensions hidden away so your files look prim and proper, "AppleUSBEthernetHost" is what you're looking for as mentioned above, but as long as it's in that directory and you don't see another one of those files with such a similar name then yes, it's that file.

     

    In the case you do have another file, just throw em' all (JUST THOSE WITH AppleUSBEthernetHost in it's name.) in a temporary folder and replace a new one there.

  • verbcrunch Level 1 (35 points)

    Thanks so much for the solutions on the first page of this thread !      I'm now sending this via USB tethering running Mac 10.6.8, iOS 5, iTunes 11.x.      All I did was download AppleUSBEthernetHost from http://www.mediafire.com/?zo22n2u2eml78vc

     

    Found /System/Library/Extensions/AppleUSBEthernetHost.kext

    Clicked "Show package contents" - then found:  Contents/MacOS/AppleUSBEthernetHost

     

    I just replaced AppleUSBEthernetHost with the downloaded one.    I then restarted, repaired permissions, restarted again, and it worked !

     

    Before I repaired the permissions I got an error saying it was improperly installed.   

     

    Thanks again !


  • AndreartC Level 1 (0 points)

    Thanks so much! it worked perfectly for me!

  • o1sound Level 1 (0 points)

    Had to do this again after updating iTunes. At least this time it was super fast as I've been here before. Thanks again.

  • Bonegh Level 1 (0 points)

    Hey DopeyDupe you are dopest apple user ever. Apply should employ you. You've solved one of my biggest problems. thanx man

  • cdhtnt Level 1 (0 points)

    Simply do a reset of NETWORK SETTINGS on your iphone, and the USB portion will work right away again.