Previous 1 2 Next 15 Replies Latest reply: Jun 12, 2012 10:48 AM by -g
-g Level 4 Level 4 (3,205 points)

Every time I open iTunes I get this popup multiple times.

 

How might I disable it from automatically poping up?

 

OSX 10.6.8

iTunes 10.5.3

 

signin.png

  • Kappy Level 10 Level 10 (247,425 points)

    By providing your Apple ID and password.

  • -g Level 4 Level 4 (3,205 points)

    thanks, but i don't want to sign in or use the computer for automatic downloads, i thought that was clear

  • AppleTosh Level 1 Level 1 (10 points)

    -g: yes you were clear the first time around. Kappy is unsuccessfully trying to be funny in a serious fashion!

     

    Try pulling out your playlist file (.p.list) in the itunes folder and put it on the desktop. Theer is no check point to manage this default setting from the front end.

     

    hope this helps

  • Limnos Level 8 Level 8 (40,720 points)

    I don't have a new iTunes.  Isn't there some preference setting somewhere to disable automatic downloads which seems to be what is prompting this window?

  • AppleTosh Level 1 Level 1 (10 points)

    I just deal with it. It only pops up in the beginning stages, besides you may need to sign in if you want to buy something. I would think you need to pull the p.list out regardless of what version you're on.

  • Limnos Level 8 Level 8 (40,720 points)

    Try pulling out your playlist file (.p.list) in the itunes folder and put it on the desktop.

    Playlist file?  Preferences file?

  • AppleTosh Level 1 Level 1 (10 points)

    go into the finder (not in itunes) and open "music" favorites > downloads folder and drag p.list to desktop. (It's where all your itunes system folders are stored.)

     

    You can also "deauthorize this computer" under > Store menu.

  • -g Level 4 Level 4 (3,205 points)

    drag p.list to desktop. (It's where all your itunes system folders are stored.)

     

     

    Thanks, I have some custom playlists, do you happen to know if that move resets my playlists to default?

     

    What else might be affected?

  • AppleTosh Level 1 Level 1 (10 points)

    Just move the parent directory p.list to the desktop and the sign in feature should automatically deactivate. Nothing else should be affected. We used to be able to deactivate this in earlier versions under the preference setting. Apple is getting "storage greedy" with the iTune sharing automation (icloud etc.) and wants you to sign in immediatly.

  • glenra Level 1 Level 1 (0 points)

    This advice is going to sound completely stupid, but try it anyway:

    Launch Safari, select "Preferences..." menu item, click the "Privacy" tab. I'm going to guess that you currently have "Block Cookies" set to "Always" and you occasionally delete cookies (either manually or via some plugin). Change Safari's "Block Cookies" setting to "From third parties and advertisers". Now try running iTunes again.

     

    Bizarrely, iTunes needs to find an Apple.com cookie in Safari (or set a new one if it's not there) in order to log you in. If the Apple.com cookie doesn't exist and can't be created, iTunes login fails - either silently, just giving you the same login prompt over and over again no matter how many times you enter the info - or sometimes with a cryptic empty-string error.

     

    I'm guessing this is your core underlying problem since you mention getting that popup "multiple times" (basically, it keeps coming back until you give up and hit cancel, since logging in always fails). But if you just want to disable that check, do this too: In iTunes, select the "Preferences..." menu item. Click the "Store" tab, and uncheck all the boxes on that panel.

  • -g Level 4 Level 4 (3,205 points)

    AppleTosh >> finder (not in itunes) and open "music" favorites > downloads folder

     

    On your instructions, I never was able to to navigate to the "downloads folder" to drag "p.list" out -- to see if that would work.

     

    If you were pointing me to User> Music> iTunes> iTunes Music> Music -- I don't have a "music favorites" or "downloads folder" there (or anywhere else that I could find)? 10.7.4, latest iTunes.

     

    Where is this music favorites folder located, exactly, anyone?

     

    So I've been living with the two pupups I get everytime I open iTunes.

     

    glenra >> if you just want to disable that check, do this too: In iTunes, select the "Preferences..." menu item. Click the "Store" tab, and uncheck all the boxes on that panel.

     

    I checked, everything was already unchecked in iTunes> Preferences> Store -- still getting the popups.

     

    glenra >> guess that you currently have "Block Cookies" set to "Always" and you occasionally delete cookies (either manually or via some plugin). Change Safari's "Block Cookies" setting to "From third parties and advertisers". Now try running iTunes again.

     

    Not really, I usually block third parties and advertisers cookies settings and manually delete cookies every few days

     

    glenra >> iTunes needs to find an Apple.com cookie in Safari (or set a new one if it's not there) in order to log you in. If the Apple.com cookie doesn't exist and can't be created, iTunes login fails - either silently, just giving you the same login prompt over and over again no matter how many times you enter the info

     

    Interesting theory, sounds like a bug (that's been going on for a long time now).

     

    I will give it a go (log into apple.com, log in, and open iTunes)...

  • -g Level 4 Level 4 (3,205 points)

    glenra >> iTunes needs to find an Apple.com cookie in Safari (or set a new one if it's not there) in order to log you in. If the Apple.com cookie doesn't exist and can't be created, iTunes login fails - either silently, just giving you the same login prompt over and over again no matter how many times you enter the info

     

    Interesting theory, sounds like a bug (that's been going on for a long time now).

     

    I will give it a go (log into apple.com, log in, and open iTunes)...

     

    I can say that isn't it, at least on my three Macs.

     

    This problem is still unresolved...if anyone stumbles upon the solution to disabling the iTunes Login popup, please post it here.

  • -g Level 4 Level 4 (3,205 points)

    10.6.3 appears to have fixed this problem.

  • -g Level 4 Level 4 (3,205 points)

    err, 10.6.3 fixed it on 10.7.4 and 10.6.8 Mac Pros.

     

    a Macbook Pro 10.7.4 still has the problem.

    this is a three-week-old start-from-scratch, ran Cocktail OSX and Repair Permissions after updating, and rebooted

     

    still no joy on this machine...

Previous 1 2 Next