4 Replies Latest reply: Feb 20, 2012 6:00 PM by Momcrna
Ketterz Level 1 (0 points)

Tuesday of this week. My internet stopped working. I have rebooted my router more than 10 times, and reset my computer about 3.


Over the Airport icon it has an exclamation point. It shows a check mark next to the wifi I want to use [I can only assume this means its connected] and HAVE been using since I have bought this thing, yet it says "ALERT: No Internet Connection"


Today I took the machine to a local Apple Store and it worked for them off of their own WiFi, he set up a new location and it still worked for them. I came back home and its doing the same thing. A checkmark but still has an "ALERT". He told me my computer is fine, but now I am getting antsy because I dont know how to fix this.


I would contact my Internet provider BUT my mother & brother [have PCs] and the internet works just fine for them.

Sorry for the long story but if ANYONE can provide me with information on how to fix my problem it would be GREATLY APPRECIATED.



MacBook Pro, Mac OS X (10.6.4)
  • Linc Davis Level 10 (184,365 points)

    Select System Preferences Network. The WiFi connection should be at the top of the list on the left, and selected. Click the button labeled Assist me and select Assistant. Follow the prompts. How far do you get?

  • Ketterz Level 1 (0 points)

    I get to where it allows me to type me the WEP Key. It says "you're now ready to try connecting to [my network]."

    I click continue and it says "Unable to establish a network connection. Your computer could not connect to the Internet. Click OK to go back and change your network settings, and try again"


    There is someone sitting right next to me, on their separate computer, using my WiFi and it works just fine.

  • Linc Davis Level 10 (184,365 points)

    WEP is all but useless for security. Unless you have a compelling reason to use it, switch to WPA2 and select a new password.


    If you must use WEP, see below:


    AirPort: Joining an encrypted WEP or WPA Wi-Fi network

  • Momcrna Level 1 (5 points)

    POSSIBLE SOLUTION!  OK. I had this problem on my sister's macbook pro when I was beside her connected to my macbook!  The problem was the WAN network, but there is a simple solution, you might just have to play around with it.  Try the following. Just one will work. If you try the first and it doesn't work continue down the list.


    1. Enter a dollar sign before you enter the password to the wifi network (i.e. $abcd1234)

    2. Enter a zero-x before the password (i.e. 0xabcd1234   OR  0Xabcd1234) The x may be lower case or capital. 

    3. Put the password in quotation marks (i.e. "abcd1234").


    Hope this helps. I just spent 30 min on the phone with apple care (that she paid for!) and the guy told me there was nothing I could do but call my internet provider and have them change the WEP to WPA2. While this might not be a bad idea, it was not ideal and did not help with the online work she needed to do tonight for her job as it was after hours for my internet company. The guy from apple care who was surprisingly rude said it was just a know issue that macs had and nothing could be done. Funny how my daughter and I were both on the same network on our MACs! And have always used that network on our MACs! Sorry just had to vent but the above worked for me!