Previous 1 2 3 4 Next 45 Replies Latest reply: May 27, 2014 8:48 PM by Leilani O Go to original post
  • Steve Lacey Level 1 Level 1

    I was having the same problem.  I am running 10.6.8.  Using Safari 5.1.5 , when I want to see a PDF on a website page, first I make sure that when I click on the link, I can see that the progress bar is working and is showing a download for the pdf.  For awhile the Safari page that contains the pdf was a dark grey ( almost black ).  Control clicking didn't help with any of the options and there was no "Save As" with it.  There is a "Save As" under File in the menu bar and when trying that, I get a dialog box saying I can't save this file ( even when I tried renaming it). 


    So, I followed some other advice to go to the folder with the Adobe plugin in root/Library/Internet Plug-Ins and put into the trash the 2 Adobe pdf plug-ins.  You will need your admin password to do this.  Then I downloaded a fresh version from Adobe and installed it from here:

    After installing, I refreshed the same page for the pdf with the black screen and it downloaded again.  This time the page was a medium grey and when the download was finished the actual pdf opening up.  I could then save it using the "Save as..." from the menu bar.


    For awhile I copied the url for the pdf and pasted it into Firefox and the same thing was happening. I went to Preferences under Firefox in the menu bar then to the Applications tab.  Under "Content Type" near the top was Adobe PDF document -- to the right under Action I used the default at first "Use Adobe Acrobat NPAPI plug-in..." & the DL just had a white page with nothing there.  I changed the action to "Save File" and then the DL worked-- I could see that the file was being downloaded when the Downloads window opened.  The file was then in my Downloads folder in the Dock.  Now after downloaded the new Adobe PDF reader, I wasn't sure if the PDF file was downloaded because the Firefox page was white ( blank ) but I could go to the File menu as "Save Page as", I picked the desktop for saving and the PDF downloaded and I could open it without any problems with Adobe Reader.  It worked with any of the "Action" choices in preferences from this point on.


    My only conclusion is that the original Adobe Reader plug-in files - there are 2 - one or both became corrupted and downloading the new version fixed getting any PDF in Safari or Firefox.

  • lawrence5M Level 1 Level 1

    MikeLV describes my situation exactly (except I'm running Safari v5.1.5). Clicking a (pdf) link in Safari gives me a black screen, but nothing downloads or opens. This is a relatively recent problem with Safari, appearing after one of the updates. I'm not having this problem with Firefox 11.0, but I prefer Safari. Can I set Safari to always open pdfs in Preview rather than in the browser? Other suggestions? I, too, feel MikeLV's pain.

  • alanfromnsw Level 1 Level 1



    Had the same problem. I'm sure it happened in the last Adobe update. I was getting a blank white screen in a new window whenever I tried to open a PDF. I'm Using Lion and Firefox as a web browser. I fixed it by following these instructions.


    1. Open Firefox>Preferences>Applications

    2. Search in list for - Preview Document (application/pdf)

    3. Change the Action to - Use Adobe Reader


    Mine was set at always ask for some reason.


    Hope this helps.

  • corradoricci1 Level 1 Level 1

    I cannot see Pdf documents on web by using Safari (my browser) or Firefox

    I did'nt find any way to save the document I can't see.

    The only way I've to see these documents, when I need it, it's to use Crome as a browser to do it. even if I don't like Crome very much.

  • lawrence5M Level 1 Level 1

    I gave up (see earlier post) and took my MBP to a genius at the Apple Store. After a few things that did not work, he threw out these two files: AdobePDFViewer.plugin and AdobePDFViewerNPAPI.plugin. He said these plugins were "taking precedence" over Safari's PDF viewer and preventing the downloading and display of PDF web links. I had updated Adobe Reader a few weeks ago for a special situation, but since I use normally use Preview to open PDF files, I don't need these Adobe plugins which broke Safari. Safari displays web-linked PDFs just fine now.

  • Jaygyver Level 3 Level 3

    For any one interested...HD/ Library/ Internet Plug-ins........


    And to get the version # and list of plug-ins.....Safari menu/ Help/ Installed Plug-ins

    (My version number of the NPAPI plug-in that works in Snow Leopard is:10.1.3)


    I remember there was an issue with one of Adobes update that broke Safari but couldn't remember which one or find a link to it but I'm pretty sure it started in Leopard and it did have something to do with the NPAPI plugin.

    I think Adobe even had mentioned it at one time on their web site on it.


    Thank you for coming back and let every one know at least this worked for you....

  • MikeLV Level 1 Level 1

    As reported in an earlier post, by me, I too was having this problem.  I found this article on Adobe's website:


    Here's what I did and it worked for me:

    1) I discovered I had two versions of Adobe Reader in my applications.  I trashed them both.

    2) As Jaygyver and lawrence5M indicated, I went to HD/library/Internet Plug-ins and trashed the two AdobePDF plugins that were there.  Viewer and ViewerNPAPI

    3) Went to Adobe's website, downloaded and installed a fresh version of Reader X.


    Lo and behold - it worked!!!  Now pdf's open in Safari just like you would expect them to.

  • Chandrashekhar Patel Level 1 Level 1

    Thanks a bunch. I dumped the two files and my problem is solved

  • Klahane Level 1 Level 1

    I have recently seen this same problem.

    I'm using Safari 5.1.7 in 10.7.4.

    In trying to track this down, I deleted Adobe Reader 9 and downloaded and installed Adobe Reader 10.1.3.

    I then quit Adobe Reader and trashed the two files cited above. Restarted.


    Still no pdf I've tried will display in Safari. They all download automatically. (And yes, I've looked carefully at the URLs to make sure it's just a raw pdf file in a folder.)


    MikeLV below appears to have installed Adobe Reader 10. That automatically makes it the default pdf viewer. Then he left it that way. That's not what I'm after here. I want Safari to display the pdfs natively.

  • mcbuffy Level 4 Level 4

    Hello Klahane, (and the other affected by that problem)


    If you want to see the PDF inside Safari's window again :

    1. Go to the folder : Your Hard Drive / Library / Internet Plug-ins.
    2. If you see a file (or more) with PDF in its name drag it to the trash.
    3. Quit and restart Safari to test with a PDF.
    4. If it works you can empty the trash.


    Hope this will help.

  • Klahane Level 1 Level 1

    As I wrote above, I did delete those two plugins, immediately after installing Reader 10.1.3. I also checked for any other copies of the files. There were none.


    Just to doublecheck, I reinstalled Reader 10.1.3 and left the files in place. Safari displays pdfs in the browser using the Adobe plugins, as expected.


    But if I then delete the plugins again, Safari returns to only downloading pdfs (the same ones it will happily display using the Adobe Reader plugins). So far, I have no luck at getting Safari to use its built-in pdf display.

  • Klahane Level 1 Level 1

    So this is embarrassing. But there's a moral at the end of the story.



    I was obsessing about this problem. It didn't feel like a bug. It felt like a setting. I recalled that I used to prefer Safari to always download pdfs.



    Then it began to dawn on me that there might be a Terminal command that affects Safari's ability to display pdfs inline.

    Some minutes of googling produced this Terminal command, which forces Safari to always download pdfs:



    defaults write WebKitOmitPDFSupport -bool YES [Disables native pdf viewing in Safari.]



    Some of the sites noting this were pretty old, but others were newer. So, I guessed that I'd applied this Terminal command in the past. With Safari off, I entered the following in Terminal



    defaults write WebKitOmitPDFSupport -bool NO [Enables native pdf viewing in Safari.]



    Worked like a charm in Safari 5.1.7, Lion 10.7.4.



    BTW, Safari's native pdf support has improved so much that it's a better way to deal with pdfs, unless you always want to save the pdf.



    Oh, and that moral I promised? Pay attention when you use "secret" settings using Terminal. Some, at least, persist even when the software is updated. It might even be worthwhile to keep notes.

  • David Mineo Level 1 Level 1

    Thanks this worked for me! Appreciate the help.

  • Judithvita Level 1 Level 1

    Thank you all so very much!  Deleted those two pesky plug-ins, and I'm good to go!  Cheers!

  • Klahane Level 1 Level 1

    Note, however, that if you update Adobe Reader or Adobe Acrobat, the installer will replace those files. This just happened to me last week.


    Interestingly, Adobe has set the default on their in-browser viewer to a setting that looks quite like Safari's native viewer.