Previous 1 2 3 4 Next 227 Replies Latest reply: Mar 21, 2014 1:39 PM by IIIMOODIII Go to original post
  • Jonathan216 Level 1 Level 1 (10 points)

    I have found one or two threads where people seem to be having similar problems with Apple TV and general sleep issues but not this exact problem.   But they contain no answers - or at least nothing I haven't tried (which includes the stuff I tried at the top of this thread and also deleting the wifi access account and starting again).

     

    And yes, I'm now showing 11D50b, so at least my 10.7.3 update is the latest build now.

     

    I'd still be interested to hear whether anyone on Lion has this working properly or not (although the chances of someone without the problem visiting this page are admittedly pretty slim)

     

    Obvioulsy my main concern is whether this is a bug or a configuration issue with my set up (although I haven't changed anything other than upgrading to Lion and updating the TC firmware).  If I can get confirmation that others have the issue as well then I'll just relax and wait for Apple to push out the fix in due course.  If it's my setup then I really don't know what else to try.

  • Tony T1 Level 6 Level 6 (8,780 points)

    I can confirm that since the 7.6.1 to my AirPort Extreme, my when my Mac mini server 'sleeps' it will 'drop' from my Shared Devices on my MBA, and I cannot "wake" the mini from the MBA  (at times, but not always)

  • Jonathan216 Level 1 Level 1 (10 points)

    Thanks Tony, I wonder if it's the TC firmware update that's causing the problem? (I installed it same day as I installed Lion).  But it's all fairly quiet on the TC sub forum.....

  • Tony T1 Level 6 Level 6 (8,780 points)

    I was also on 11D50, and just updated to 11D50b, so maybe it will help my problem, but as it's intermittent for me, I won't know immediately

  • LexSchellings Level 5 Level 5 (6,705 points)

    ===I am not sure what it is. I do not think it is a"bug" in Lion.

    What you can do is taking out the power cable out of the TC, wait for 15 secs, put the power cable in again (I know it restarted after the FW update).

    ===Another thing: turn your Bluetooth off and try again.

    ===There is a (very small) possibility that the wake-up takes too long to succeed: set the hibernatemode to zero (this means that no "sleepimage" file is written nor read, this file has the size of your ram):

    in Terminal copy/paste this command:

    sudo pmset -a hibernatemode 0

    you can then put the following command to free the space of the sleepimage file:

    sudo rm /var/vm/sleepimage

    type Exit

    and quit the Terminal

    (ofcourse <enter> after each command)

    you can test the hibernatemode in Terminal:

    sudo pmset -g | grep hibernatemode

    and it will return the hibernatemode (now 0)

    ========

    The other thing is drag Energy Saver computersleep slider to "never".

    Sofar I could not find the perfect solution.

     

     

     

     



  • Tony T1 Level 6 Level 6 (8,780 points)

    Worked for a day, now my mini is in a coma again, needing me to touch the power button to wake up (so

    11D50b didn't work for me)

  • Jonathan216 Level 1 Level 1 (10 points)

    Thanks Lex I appreciate your help but I'm reluctant to start sudoing stuff in the terminal when I don't exactly understand what I'm doing, whether it can be reversed and how it might affect other parts of the system.  To add to the fun, since yesterday my bluetooth keyboard, trackpad and magic mouse are now taking two minutes to reconnect from boot or sleep, and sometimes not connecting at all (batteries are OK)

     

    I don't think Lion OS is working properly - after googling I've now found dozens of people with similar sleep related problems, many of them on this site, and all of them on 10.7.3.  I have all Apple kit and the only thing that's changed is that I've, ahem, 'upgraded' to Lion.  My theory is that Lion wake on demand and auto reconnect from sleep is 'broken for many' and my fervent hope is that Apple are working on a fix.

  • LexSchellings Level 5 Level 5 (6,705 points)

    Jonathan, good point about Terminal, but it is a powerful "tool". To inform you in general about the hibernatemode read this interesting article:

    http://tidbits.com/article/9090

  • IIIMOODIII Level 1 Level 1 (0 points)

    Ok I'm having the exact same problem, I'm also trying to wake my MacPro using either the apple remote on my iphone or the a VPN app on my iphone to enable access to my content on an AppleTV with home share. All of which worked with no problems in Lion before the update to 10.7.3 and the airport extreme update to 7.6.1.

     

    Things I've tried:

     

    Reset the SMC on my MacPro, restart and test.

     

    Restarted my Airbase Extreme, both via the airport utility (6 and 5.6) and by removing the power cable for 30 seconds.

     

    Reverted to firmware 7.6 on the airport extreme. Restart and test

     

    Turning of and on Wifi.

     

    Moved my preferred network to the top of the list in the network preferences, restart and test.

     

    Add new Network Location and renew the DHCP lease. Restart and test.

     

    Turned off "Wake on Network activity", restart, then turned on "Wake on Network activity" restart and test.

     

    The only thing I haven't tried yet is to use the Combo 10.7.3 update to give me 11D50b, but since Johnathan216 has done the same and still no joy, along with all the other test I have done. I agree that it must be a 10.7.3 problem with the Airport Extreme keeping a connection with the MacPro.

     

    I'm also reluctant to do sudo commands as a fix.

     

    The only reason I changed my network router to Airport Extreme was for this function.

     

    If anyone has any further ideas on what's wrong or has anything else I can try, then I'm all ears.

  • Tony T1 Level 6 Level 6 (8,780 points)

    I have a wired connection from my mini to the Airport.  I've now also turned on the WiFi to see if that resolves my problem.

  • keg55 Level 5 Level 5 (6,980 points)

    WiFi won't wake it up, Tony. I've tried myself. I have a Linksys router and as long as I keep my Mini plugged in with ethernet, it shows up in Shared and I'm able to wake it without using the Mini's keyboard.

  • Tony T1 Level 6 Level 6 (8,780 points)

    keg55 wrote:

     

    WiFi won't wake it up, Tony. I've tried myself. I have a Linksys router and as long as I keep my Mini plugged in with ethernet, it shows up in Shared and I'm able to wake it without using the Mini's keyboard.

     

    That was my set-up (Mini plugged in with ethernet), but since 7.6.1, when the mini goes to sleep, it will frequently (but not always) drop from Shared.  The strange thing is, I have other devices (Squeezebox Radio) that will always wake the mini, but not my MBA.

  • IIIMOODIII Level 1 Level 1 (0 points)

    Ok guy's, may be early days but I have discovered what I think may be the solution.

     

    In system settings, network. On the left hand side there is all your connections (wifi, ethernet, firewire and so on)

     

    Select every connection that you are not using, one at a time. Go to the options cog a the bottom and select "Make Service Inactive" so that the only connection left is the one you use to wake your mac up.

     

    Save and close.

     

    After that, everything should work as desired.

     

    I have only tested this a couple of times this evening, once putting my mac to sleep for 30mins, then again for a further hour. Each time the Mac woke using the Apple remote to enable me to home share. This is still early days but seeing as my mac wouldn't wake after about 10mins every time last night I'm hopeful this is going to work.

     

    I'll keep testing it for longer periods of time but so far it has worked for me.

     

    Let me know if this helps you too.

  • Jonathan216 Level 1 Level 1 (10 points)

    Hi IIIMOODIII, I hope this turns out to be a permanent solution for you, but I fear it won't.  I've tried this approach with both wifi only and Ethernet only and it didnt work.  Like you, I have had one or two occasions when I've managed to wake the mac after it's been sleeping for 30 minutes, but usually I just get the iPad spinning wheel as it tries to wake the mac to use iTunes homeshare.  Like I say, I hope it's permanent for you, but if not then maybe a song to keep our spirits up..

     

    "In the jungle, the mighty jungle, the Lion sleeps tonight"

    Oh, wait.....

     

    Jon

  • Tony T1 Level 6 Level 6 (8,780 points)

    Let me know if this helps you too.

     

    Didn't work

Previous 1 2 3 4 Next