2 Replies Latest reply: Feb 13, 2012 8:49 PM by Robert Stoeber
Robert Stoeber Level 1 Level 1 (0 points)

My office is in a building with a restaurant about 50 feet, and several brick walls away.  The restaurant has a free/open Wi-Fi network.  I frequently have lunch there and read the news on my iPad.

 

My office Wi-Fi router is about 10 feet from my desk.  The office network uses WPA2.

 

Almost every time I grab my iPad in the office it connects to the very weak, not really working from here, unsecure restaurant network.  It doesn't matter if I was last using the secure office Wi-Fi.  "Forgetting" the open network doesn't help since it's immediately found again.

 

I have the same problem at home where my own home (preferred) network is secure, but several neighbors have open/unsecure networks.

 

Why does the iPad always prefer open/unsecure networks that I never want to use, over my own secure networks?  Is there a way to stop that behavior?

 

It seems like there should be a switch called "ALWAYS USE KNOWN, LOCKED WI-FI NETWORKS IF AVAILABLE" or something like that.

 

The iPad status bar only shows the signal strength, not the network name, so every time I turn on the iPad I have to go into the Settings page to make sure I'm on the proper network.

 

This also seems like a real security problem since any apps that are running when I turn on the iPad probably try to connect to the Internet as soon as the open/unsecure network is available.

 

iPad2

iOS 5.0.1


iPad 2, iOS 5.0.1