Previous 1 2 Next 29 Replies Latest reply: Jul 14, 2012 3:56 AM by Detlev Tesch
chesrockwell Level 1 Level 1 (0 points)

Hello, this is my first post.

 

Recently I have been experiencing a problem with running youtube videos in the Safari browser. It started to happen spontaneously about 1-2 weeks ago, and so far has not changed.

 

If I click a video to play (embedded like in faecbook or on another website or directly from the youtube page), the video tries to load but it never does. Usually, the page reloads (like if I had clicked the refresh button) a few times, then times-out. All other tabs currently opened in Safari are affected as well, just like I have clicked refresh on each tab. When I click on a tab to open it, it refreshes and I have to load each page separately.

 

The youtube video never loads at all, and usually i have to close the browser completely...

 

I thought this might have been a problem on the youtube page, but no one else is experiencing these problems...

 

I also tried to update Abode flash player, but this made no difference. My software on the mac are also up-to-date.

 

So far I havent found a solution to this problem so any help is appreciated. I think the problem is with Safari, so I was thinking to reinstall it, but so far have seen on these forums that this is not so easy to do.

 

Please help!


MacBook Pro, Mac OS X (10.6.8), Safari Version 5.1.2 (6534.52.7)
  • Carolyn Samit Level 10 Level 10 (98,515 points)

    Hi and welcome to Apple Support Communities ...

     

     

    It's not the Flash player but a plugin.

     

    Uninstall your current copy of the Flash plugin then reinstall new > Troubleshoot Flash Player | Mac OS

     

    Quit then relaunch Safari. From the menu bar click Safari > Empty Cache

     

    Now try a video on Facebook or Youtube.

     

    If you still have problems with videos, go to Safari > Preferences then select the Extensions tab. If you have any installed, turn that OFF, quit then relaunch Safari to test.

     

    Also, if you have ClickToFlash installed, that will prevent Flash content from loading. Check ~/Library/Internet Plug-Ins

     

     

    BTW... For Snow Leopard, Safari is very easy to reinstall > Safari 5.1.2

  • chesrockwell Level 1 Level 1 (0 points)

    Hi Carolyn,

     

    Thanks for the reply.

     

    Yes sorry I meant flash plugin. I tried up-dating that, reinstalling it. It is running and works, version 11.1.102.55 of flash plugin is currently installed.

     

    Also tried emptying the Cache.. no difference..

     

    I also read in another forum to up-date Flip4mac and Silverlight, which I just tried, all are the most current version. Still this didn't help...

     

    All other videos work, for instance something from Dailymotion, or streaming websites, etc... only youtube videos seem to cause this problem..

     

    So do you suggest I try to reinstall Safari? Thanks for your advice..

  • Carolyn Samit Level 10 Level 10 (98,515 points)

    I tried up-dating that, reinstalling it. It is running and works

     

    I'm confused... Flash is working or not?

  • chesrockwell Level 1 Level 1 (0 points)

    Yes Flash seems to work. The flash page where you can test the Flash plugin shows me it is working.

     

    Still, the youtube videos do not run...

     

    sorry for any confusion..

  • Carolyn Samit Level 10 Level 10 (98,515 points)

    No problem ..

     

     

    Ok, just so you are aware, most YouTube content requires the Flash plugin.

     

    Can you post a link  to a particular video that's not working please?

  • chesrockwell Level 1 Level 1 (0 points)

    All videos checked so far give the same problem . For instance i just tried to open this random video and it caused the problem:

     

    http://www.youtube.com/watch?v=o3Kbc-LSGvI&feature=g-vrec&context=G26f1034RVAAAA AAAABg

  • Carolyn Samit Level 10 Level 10 (98,515 points)

    It should work..

     

    Do you have ClickToFlash installed? 

     

    Check  ~/Library/Internet Plug-Ins

  • chesrockwell Level 1 Level 1 (0 points)

    No I just checked, I do not have that plugin installed...

  • Carolyn Samit Level 10 Level 10 (98,515 points)

    Ok..

     

    Try reinstalling Safari 5.1.2 from the link I posted previously on this thread.

     

    And try using a different browser. Firefox or Chrome should work.

     

    Google Chrome - The web is what you make of it

    Mozilla Firefox Web Browser — Free Download

     

    As for ClickToFlash.. If you clicked Help > Installed Plug-Ins from the Safari menu bar, ClickToFlash won't show there. Only in ~/Library/Internet Plug-Ins

  • chesrockwell Level 1 Level 1 (0 points)

    ok just went in under ~/Library/Internet Plug-Ins and its not there either.

     

    So I will try reinstalling the browser and see if that works, will update after that.

     

    Thanks for the help!

  • chesrockwell Level 1 Level 1 (0 points)

    So I tried installing ClickToFlash, that didn't stop the problem.

     

    Then I tried deleting Safari  by dragging the icon in the applications folder to the trash, then reinstalling it from the downloaded copy from the link you gave me. It seemed to me that it wasn't really deleted since when I reinstalled it, all my preferences were still there (ie. bookmarks, sites, history, etc), so I am not sure I deleted it properly... anyways after I did this (tried it twice), I still had the same problem....

     

    Finally, I tried Firefox, and I have no problems with viewing videos from this browser...

     

    So it seems the problem is with Safari only..

  • Linc Davis Level 10 Level 10 (169,155 points)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up a guest account” (without the quotes) in the search box.

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    As Guest, launch the application(s) and test. Same problem(s)?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. The instructions provided by Apple are as follows:

     

    • Be sure your Mac is shut down.
    • Press the power button.
    • Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
    • Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on some Macs.

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem(s)?

     

    After testing, reboot as usual (i.e., not in safe mode.) Post the results of steps 1 and 2.

  • chesrockwell Level 1 Level 1 (0 points)

    Hi Linc, thanks for writing.

     

    Part 1: Guest account

     

    I followed your instructions and logged in as a guest. When I used Safari in this mode I experienced no problems with youtube videos.

     

    Part 2: Safe Mode

     

    I logged in under safe mode as you instructed. Unfortunately, I was unable to connect to the internet in this mode since I must login with a VPN Cisco client as I am at work, and this never worked in this mode. I can try again to do this when I am home using my own network...

  • chesrockwell Level 1 Level 1 (0 points)

    Continued...

     

    Part 2: Safe Mode

     

    So now I was able to login under the safe mode and access the internet. Youtube videos seemed to load at first, but the video was blank. The video progress bar was moving as normal but i couldnt see or hear anything. I clicked around on a few random video links, was the same until the 3rd link where I experienced the same problem as before, the video reloaded 3-4 times, then the browser timed out and I had to quit the Safari browser.

Previous 1 2 Next