1 2 Previous Next 26 Replies Latest reply: Apr 4, 2006 7:47 AM by doclittle
Don MacIver Level 2 Level 2 (250 points)
I have not been able to get video to play without the stuttering. This includes newly downloaded music videos from ITMS and existing videos I've had for years. Also, this includes the .mov, .DV, MPEG2, and other formats. I know it occurs during a write to the disk, but my searching these forums hasn't found a resolution. This also occurs in iTunes. But I assume iTunes uses Quicktime to play it's videos.

I have tried the suggestions using BatChmod, and that didn't help. This is really annoying that I have to use my old G4 running Panther in order to view any kind of videos. Panther also wrote to the disk during video playback, but apparently in Panther, there is some kind of (or enough) cache that prevented the stuttering.

If a resolution has been posted, could someone please point me to that posting. Thank you for any help with this.

G5 2.0 Dual, 2.5Gb RAM, Mac OS X (10.4.5), ATI Radeon 9600 (OEM)
  • 1. Re: Any Fix For Video Stuttering?
    Linc Davis Level 10 Level 10 (118,140 points)
    Does the problem occur when you safe-boot? (Hold down the shift key at startup.)

    Dual G5 2.5   Mac OS X (10.4.5)  
  • 2. Re: Any Fix For Video Stuttering?
    Don MacIver Level 2 Level 2 (250 points)
    Yowser... Safe boot makes the situation much worse. It's like it cuts out many frames and slows the videos way down.

    During normal boot the stutter occurs randomly throughout video play. It doesn't occure in the same places at the same time.

    I also should add that this occurs when I play videos in larger than formated size, such as double size, full screen, etc. It occurs, but less often, (or maybe not as noticable) at the small size (for downloaded ITMS paid for videos)
  • 3. Re: Any Fix For Video Stuttering?
    Linc Davis Level 10 Level 10 (118,140 points)
    I'm having a similar problem, but it goes away on safe boot. I suggest you go through a troubleshooting procedure. Start by switching to another user account (create one if necessary.) If you have the same problem in that account, you know it's something in the system; if not, it's something in your account. If it's the system, repair permissions and check your boot volume for directory damage. If that doesn't work, boot in single-user mode or from another volume and delete everything in /System/Library/Caches and /Library/Caches. If none of that helps, run Apple Hardware Test. If that's negative, you're probably looking at an archive & install. Before I did that, I'd do a clean install on an external drive, boot from that and see if the problem persists. If it does, it's definitely hardware.

    If it's just your account, move ~/Library/Preferences/com.apple.* out of the way. Hold down the shift key when you log in to disable your login items, and try the playback with no other processes running.

    Do all this carefully and you'll eventually come up with the answer, but it may take a long time.

    Dual G5 2.5   Mac OS X (10.4.5)  
  • 4. Re: Any Fix For Video Stuttering?
    QuickTimeKirk Level 8 Level 8 (48,120 points)
    Have you tried the Audio MIDI Setup app (Utilities folder)?
    Set the default audio output format to 44100Hz and try the files again.
  • 5. Re: Any Fix For Video Stuttering?
    Don MacIver Level 2 Level 2 (250 points)
    Thank you for the comments so far.

    The Audio MIDI Setup is (and has been) set for 44100, 2channel, 16 bit.

    I've found that it apparently has to do with Quicktime 7 (I'm using 7.0.4, now) When I use QT 6 (which is what came with the install disk, and after an archive and install) The problem is not there--no stuttering of the video at all. Also, there seems to be no writing to the disk during playback in QT 6. When I upgraded to QT 7, because it's apparently needed for iLife, 06, the writing to the disk occurs during video playback. It stutters exactly when this occurs.

    So, it seems to be a situation with not having enough cache to handle disk writes during playback. Does anyone know what is causing either the disk writes during playback, or, if there's a way to increase the player's cache for video playback from an internal drive?. Oh, and I am using QT Pro.

    It seems I have a choice of going back to an earlier version of QT, and an earlier version of iTunes, or coming up with a way to stop the disk writing during playback. Could it be caused by the serial disk interface rather than the old standard ATA parallel interface that used to be used? Does anyone know a way to increase the QT cache (for video playback from internal drives)?

    So far, I've tried:
    Archive and Install of Tiger, then update to 10.4.5,
    Reinstall of QT 7.0.4 from 6
    Turned off Spotlight (using Terminal)
    Set processor to not nap (which doesn't hold through a reboot)
    Set processor to Maximum processing
    Tried using only single processor

    No resolution yet.



    G5 2.0 Dual, 2.5Gb RAM Mac OS X (10.4.5) ATI Radeon 9600 (OEM)
  • 6. Re: Any Fix For Video Stuttering?
    Mick Mueck1 Level 1 Level 1 (25 points)
    Just bumping the awareness here. I too have had all manner of problems since 10.4.5 pertaining to stuttering quicktime content or safari unexpectedly quitting while viewing a movie trailer from Apple's site. It's really frustrating.
  • 7. Re: Any Fix For Video Stuttering?
    Don MacIver Level 2 Level 2 (250 points)
    Now I've tried using batchmod to to fix the permissions on the music files in the music folder. No Resolution.

    Also tried reinstalling the combo updater for 10.4.5. No Resolution.

    I did try downloading a HD Movie Trailer (Firewall) at maximim size. As it streamed, there was no stuttering at all. It played perfectly. I downloaded the cached file to the desktop, and when I play it back, it stutters badly. To me, that means there is a lack of sufficient cache on QT playback of videos from the local HD, but it's sufficient for when the video is streamed into the cache. There was plenty of writing to the drive during the streaming/download. But, it didn't affect the video play.

    Is there any way to increase the playback cache in QT so it will continue without stutter when there is a disk write?

    G5 2.0 Dual, 2.5Gb RAM Mac OS X (10.4.5) ATI Radeon 9600 (OEM)

    G5 2.0 Dual, 2.5Gb RAM Mac OS X (10.4.5) ATI Radeon 9600 (OEM)
  • 8. Re: Any Fix For Video Stuttering?
    Joseph Thomasson Level 1 Level 1 (25 points)
    I too am having the same problems with all manners of quicktime media. No solution on my end, sad to say I'm only posting with the hope that Apple well become aware of the problem and send us a fix.

    anyone know of an effective way to get the word to the right hands?
  • 9. Re: Any Fix For Video Stuttering?
    Don MacIver Level 2 Level 2 (250 points)
    So, I guess that no one that reads these forums is aware of any fix (other than using a non-Apple app) that will allow the playing of simple video on a dual G5? I guess that means I have to go back to QT 6. But, that also means I can't use iLife 06 because it requires QT 7.

    Other people I've talked to say it's the Serial ATA that apparently can't handle both the read/write fast enough for video. I don't know if this is true. But, they've had good luck with adding a standard Parallel ATA drive to the optical drive bus (2 ch, ATA100) on their G5, and placing their video files on that drive. I may try that when my warranty expires in a few months.

    In the mean time, I hope Apple addresses this serious restriction on their video application--especially since they're selling the videos that you can supposedly play on your computer. In my case, the play is unacceptable.
  • 10. Re: Any Fix For Video Stuttering?
    Kevin Daniels1 Level 1 Level 1 (15 points)
    I'm having a similar problem since upgrading to Tiger and Quicktime 7.
    But I'm only having movie playback issues with .avi files. Everything else seems to be working.

    Still frustrating though. Kind of makes you wonder sometimes why you upgrade.
  • 11. Re: Any Fix For Video Stuttering?
    Linc Davis Level 10 Level 10 (118,140 points)
    I have a Dual 2.5 with two internal SATA drives configured as a striped RAID. I can play video normally in my admin account, but not in any other account, including a completely pristine test account. I can also play video normally in any account when running in safe mode, or when running in unsafe mode from a clean install on another volume. So hardware is NOT the problem. The only thing I can't do is play video the way I need to: from a staff account when booted in the usual way.

    I've also noticed that I can temporarily unfreeze video playback by moving the cursor over the Dock or over the DVD controller. As soon as the cursor stops moving, video playback drops out within a few seconds. Audio playback is not affected.

    I've ruled out permissions and just about everything else as a cause of this problem. The only thing I can come up with is that one more kernel extension is loaded when DVD Player is running in a staff account than when it's running in the admin account: the AOAHAL plugin in IOAudioFamily.kext. I have no idea why. However, when I boot with this plugin removed, the problem still occurs.

    So for me, all video playback is broken except in my admin account, which I use only for administrative tasks. Apple is going to have to come up with a fix for this.

    Dual G5 2.5   Mac OS X (10.4.5)  

    Dual G5 2.5   Mac OS X (10.4.5)  
  • 12. Re: Any Fix For Video Stuttering?
    QuickTimeKirk Level 8 Level 8 (48,120 points)
    Videos encoded with H.264 will nearly always stutter when viewed on a G3. The processor just can't keep up.
    The original poster's troubles may be caused by third party software or components. My machine is less that half of his and yet I have no troubles with any QT content.
    I wonder if he has tested using a different user account?
  • 13. Re: Any Fix For Video Stuttering?
    Kevin Daniels1 Level 1 Level 1 (15 points)
    These movies worked fine with Panther and an earlier version of quicktime, so I'm dubious about the comment that they don't work with G3s. I did't have any playback problems before.

    The point is, the very same movies won't play since an upgrade to Tiger. Apple obviously changed something, and it has caused a problem that needs fixing.

       
  • 14. Re: Any Fix For Video Stuttering?
    QuickTimeKirk Level 8 Level 8 (48,120 points)
    QuickTime 7 was a major rewrite. Many new features (things you'll never see on a G3) are part of its duties. Things that used to get passed off to the graphics card are now handle directly with the processor(s).
    If the files worked properly prior to your install of Tiger using QT 6 they should work the same using version 7. I have no trouble with any older files on my G3 but it spits back and stutters on H2.64. It can't keep up.
1 2 Previous Next