10 Replies Latest reply: Dec 5, 2012 12:39 PM by VR84
djc225 Level 1 (0 points)

Hi Guys,

 

I'm trying to import a .wav file that i have in itunes.  In the garageband media browser i can see the file and i can even play/preview it.  i try to drag it to the left and it appears that it is importing, however the file never shows up under tracks.  I dont get any error messages.  what could be happening and how do i fix it?

 

thanks


GarageBand (Mac) '11, Mac OS X (10.6.8)
  • Christoph Drösser Level 6 (11,275 points)

    It should work ... what you can try: convert the file to AIFF in iTunes (by setting the import preferences accordingly) and try again. Or try dragging your wav file into GB from the Finder - maybe that helps.

  • djc225 Level 1 (0 points)

    i've tried ALL different import conversion preferences.  also tried dragging directly from finder.  No luck.  Maybe I should clarify this only happens for 1 specific file, but i cant tell what's different about it.  It's simply a .wav file that i created using a voice recording app so it shouldnt have any protections on it.

  • djc225 Level 1 (0 points)

    for testing purposes i used a different app for the recording and the file that it reproduces imports nicely to garageband, so clearly there is some issue with the format of the file that the first app is producing.  Since the first recording app is my app of choice id like to be able to solve the problem, and sounds like i need to be able to compare exactly how or why the files are different or convert them to another format before sending to garageband (the itunes convert when import preferences didnt seem to make a difference).  what are my options?

     

    thanks

  • HangTime Level 9 (50,490 points)

    djc225 wrote:

     

    (the itunes convert when import preferences didnt seem to make a difference).

     

    i think you are misunderstanding how the conversion process works. read the "convert" faq entry:

     

    http://www.bulletsandbones.com/GB/GBFAQ.html#neverfail

    (Let the page FULLY load. The link to your answer is at the top of your screen)

  • Christoph Drösser Level 6 (11,275 points)

    One more idea: is the file extension of your audio file .wav or .WAV? With mp3, GB insists on having the extension in lowercase letters.

  • VR84 Level 1 (0 points)

    Hi everyone, I am having the same problem. I am unable to import .WAV files into iTunes 11.0

     

    Cmd+O doesn't work at all, same for drag and drop.

     

    Any news about the issue?

  • léonie Level 10 (91,186 points)

    Cmd+O doesn't work at all, same for drag and drop.

    I can import .wav without problems into iTunes. Have you tried the iTunes "File" menu for import?

    File > Add to Library

     

    And make sure you have "Music" selected in the Sidebar of the iTunes window, when you try to import, not one of the playlists.

    Also I'd change the filename extension to the default "wav", not ".WAV".  My iTunes imports also ".WAV", but you want to share the file to GarageBand.

  • VR84 Level 1 (0 points)

    Hi thanks for your reply.

     

    I could import everything with iTunes 9 as well.

     

    iTunes 11 is just giving me new weird troubles. I followed your suggestions (it was working with iTuned 9) but now it doesn't work at all...simply nothing happens.

     

    I had to use compressor to convert .wav files to .aif and that takes much more time.

     

    If you come out with some more ideas please let me know.

     

     

    Best

  • léonie Level 10 (91,186 points)

    iTunes '11 is new for me too. You might ask in the iTunes forum.

     

    all...simply nothing happens.

    That is very typical for trying to import an audio file that is already in the library. Have you used the search  field to check, if a similar file already has been imported? In that case you will simply get no reaction at all. Since iTunes 10 it is nearly impossible to import duplicates.

  • VR84 Level 1 (0 points)

    Yeah I checked, I thought the same thing but is not in the library