Previous 1 2 3 Next 43 Replies Latest reply: Nov 6, 2015 5:52 AM by Nekoma Go to original post
  • GregX Level 1 (0 points)

    Using OSX 10.8.2 iMac 27 inch. Printer Samsung ML 2510.

     

    I have had the same problem after moving to Lion 10.7  and I have been looking to buy a new laser printer.  I gave it one more go before purchasing online line tonight and this seems to have worked for me.   I read the above thread first, then unplugged the USB and the power cord for a minute. Threw out the old printer in the preference panel print & scan.  It showed the name ML 2510  series and kind USB selected that  then  three fields below  activated.  Name, Location, and Use.  In the Use field you see,  Choose a driver or printer model.  Clicked on that to reveal Auto Select ( grayed out ) and Selected printer software.  Clicked on  Selected printer software. Then filtered the search to  ML 2240 series like others in this thread suggested.   Selected the ML 2240 series driver  and saved and closed the preferences pane.   I replugged in the USB and the power cord turned on the unit and printed and random readme.txt file no problem. Then I ran out of paper .

    Hope this helps someone out there thinking of buying a new printer before they do.

  • GregX Level 1 (0 points)

    control click that file and you can tell mountain to open that file and continue to notify you if something is not apple approved in the future.

  • FJ9999 Level 1 (0 points)

    aleballa72's solution worked for me.  Thanks!

  • brucefromnewglasgow Level 1 (0 points)

    Here is what I got when I reported this to Samsung.

     

    Thank you for contacting Samsung Customer Care.

    We understand that Printer is not working in Apple Mac OS Lion.

    We are sorry to hear that.

    We are sorry to inform you that as of now drivers for this Printer are available for Mac OS 10.3 ~ 10.7 only.

    When the new drivers are released for this Printer, then they will posted on the website so that they can be downloaded.

  • wefunkster Level 1 (0 points)

    Dear aleballa72, thank you very very much!!!

    Your solution has worked for me and my ML-1915 printer.
    I had these issues from 10.7.3 - 10.8.2

    I was close to trash my printer though it really did it's job very well before.

    Thank you again!

    I will now point people from a similar discussion to your solution.

  • scackalacka Level 1 (0 points)

    Someone mentioned using drivers for ML 2240 by Samsung.  Worked for me on Mountain Lion with my Samsung ML 2510.

  • BeachWatcher Level 1 (0 points)

    Various solutions posted here have worked for me for a while and then stopped working.   My latest work-around is the following:

     

    1. After pressing "file, print" on the tool bar quickly go to the icon for ther printer in the dock.                      2. Press the "pause" button on the printer.

    3. Printer prints out your document.

     

    Fairly easy to check out on your setup.   Has worked each time so far (two days) although once I got the first 3 pages printed twice.

  • bluedakar Level 1 (0 points)

    Thanks aleballa72!

  • fotomon Level 1 (0 points)

    I have the 10.8.3 OS X version on my MacBook Pro and the ML-2240 driver worked for me for the ML-2010 as well, but BeachWatcher's work around was necessary to get it to print. The only other way was to power off printer and then on again. But it would only print one job, then nothing. At least doing the "pause" thing made it work, even when the print cue for that job went away. Will try later on a 2510 and see if it will work. Hopefully, Samsung will update these drivers. It's a real pain.

  • turbocat68 Level 1 (0 points)

    Thumbs up for aleballa72!!1

  • Janet Friedel Level 1 (5 points)

    This was the only solution that solved my printer problem with the ML-2510 Samsung printer. Thank you, as I've been dealing with this issue for months since upgrading to the Mavrick OS.

  • FUZZY DUNL0P Level 1 (0 points)

    Thanks alebella72!! That solved my problem I've had for years with my Samsung ML-1640. It used to print the first time only then I had to unplug und replug the USB to print again.

     

    I've only installed the usbtb package (http://sourceforge.net/projects/gimp-print/files/usbtb%20-%20Mac%20OS%20X%20ONLY %20usb/) and added the newly appearing printer via system prefs.

  • FUZZY DUNL0P Level 1 (0 points)

    Ok, I'm very sorry … it still doesn't work. Strangely it got a little bit better and worked for my first three prints. But now I still have to un- and replug most of the time.

  • Nekoma Level 1 (0 points)

    Hi To Everyone. I have the SAME problem to my small SAMSUNG ML1665 Serial Z4ZFBKCZ403819N.

    It happen with OSX El Capitan that works perfect under My MACMini 2010 .

    It is incredible I was looking to solve this problem just installing the ML1665 Firmware, but I really do not know how to do !

    Probably the problem is not Driver but Printer Firmware ???

     

    Best regards to all !!!

Previous 1 2 3 Next