Previous 1 2 3 4 Next 121 Replies Latest reply: Jul 19, 2015 8:43 PM by kimberlysuesow Go to original post Branched to a new discussion.
  • eww Level 9 Level 9 (52,975 points)

    Anthony, did the SMC reset change anything?


    Courcoul has sensibly reminded the assembled multitude following this thread that the built-in keyboard, trackpad, camera, SD card reader, and possibly other internal things I'm forgetting (because I'm posting from my iPad and not my MBP) are all USB devices, and if one of those is malfunctioning it could be drawing excessive power. The culprit need not be external.

  • Jimmu Level 1 Level 1 (0 points)

    Same problem! 


    Plug my iPhone in my 24" iMac and up pops the error. To check I then plugged it in to my 27" iMac and the same error pops up! I then tried a different lead (cable) with the same results). I conclude therefore, (correct me if I'm wrong) that it must be a fault with my phone! But what?


    Any views out there?



  • bb555 Level 1 Level 1 (0 points)

    I also just started having the same problem. I've had my macbook pro less just less than a year and about 2 weeks ago started getting this message when I plug anything in. All I ever plug in are my iphone or ipad to sync or recharge them, and never both at the same time. I even get this message now if just the cable is plugged in but there's no iphone on the end of it. Also, it DOES disable the usb port because my iphone stops charging then. Surely an iphone should not be drawing "too much power"...?

  • galaxyprovideo Level 1 Level 1 (0 points)

    I fixed it.  I had the exact same problem, rebooted several times, no Joy.  Just swapped my USB (white) lead and hey presto it works fine again.  Interstingly the plug on the white lead also felt hot.


    Good luck

  • Timothy Elliott1 Level 1 Level 1 (125 points)

    I solved my problem (see earlier post) by checking all the USB cables going into a D-Link powered hub. One of the USB cables going to an external hard drive was just slightly unseated. I haven't had any further warnings or shutdowns. The problem wasn't a lack of power despite the warning - it was simply a loose connection.

  • edwardtheconfessor Level 1 Level 1 (0 points)

    I'm getting the same message with my iphone. I tried a bunch of stuff mentioned here, then I borrowed a friends phone, plugged it in and it worked fine. So my problem seems to be with the phone. I restarted it and still is acting the same.

  • Jimmu Level 1 Level 1 (0 points)

    I came to the conclusion that having exhausted all possibilities, i.e. cables, connections and so forth that it had to be a software problem. On trying a restore on iTunes, which hung halfway giving an error message, I headed off to my phone supplier (True Move Thailand). The operative on the service desk who upon hearing my sorry tale simply laughed, connected it to his computer, fiddled with his keyboard, then after eight minutes or so, handed me my phone saying that should be it.  It was!  My phone has worked flawlessly since.


    I hope this is of some help!

  • philly2857 Level 1 Level 1 (0 points)

    My wife's Mac pro is doing the same thing when she hooks up our canon camera. She has downloaded 1000's of pictures without problems before and now that message pops up  . Also the SD card reader isn't working. When the card is plugged in nothing happens and we can't find the card in iphoto. So now she has no way to get the pictures on iphoto. It's not the cord or the card because I can download them without any problem on my windows computer. I also have seen a bunch of other post about this problem. Any help would be great. Thanks.

  • bbritton Level 1 Level 1 (0 points)

    I don't have anything big to add to this, except my MacBook gets the same message when booting up. There is nothing plugged into the two usb ports and they don't work even with a powered hub plugged in. I do have an external, powered, 2.5" hard drive that works, but nothing else works. The internal camera, the keyboard, and the trackpad work, which are all usb. I figure it must be some problem on the logic board. This is a well travelled MacBook, so it looks like it is time to buy a new MacBook Pro after I see what happens on June 11, 2012.


    Message was edited by: bbritton

  • minimejh Level 1 Level 1 (0 points)

    I have a 24 inch iMac Mid-2007.  And I have been getting the same message for some time.  I have my keyboard conntected; my mouse connected to the keyboard.  And a white connector usually not connected to anything; but available for my iPhone or iPod to synch.  I also have a hub that was a freebee from a conference.  It has 4 ports avaialble; but I get the message when nothing is connected to it.  Can these cause a problem even if nothing is connected.   I have no Apple Store near me.   And I am obviously past warranty. 

    What should I try?

  • Anthony Acock Level 1 Level 1 (105 points)

    hi everyone, sorry for abandoning this thread.


    what it turned out for me, was to simply get a new iphone charger cable. evidently, that was the culprit. i sort of figured that out on accident, when at work i needed to charge my phone, and didn't have my cable.


    i borrowed one from a coworker, and the error never popped up.


    so then when i got home, i tried my sons ipad cable, and it worked fine. so i tossed my old iphone cable, got a new one, and never looked back.


    currently posting from the same computer. keyboard, an external harddrive currently backing up everything, and a fan, all plugged in, and working in harmony.


    for you, minimejh, i'm not sure. if not hing is plugged in, and youre still getting the error, maybe it's time to start resetting stuff as mentioned earlier in the thread?


    best of luck, mate.

  • edwardtheconfessor Level 1 Level 1 (0 points)

    I ended up having a little bit of foil that had slipped into the jack that was shorting it out. They got it out at the apple store.

  • minimejh Level 1 Level 1 (0 points)

    Thanks for replying so quickly.  I am going to start with ruling out stuff and keeping it simple.  So I have unplugged the hub as the only change even though nothing plugge in and monitor what happens.  If I can make 1 change a time with the USB cables perhaps I will be able to isolate the issue.

  • BM6 Level 1 Level 1 (0 points)

    PS: I don't have a single usb connection plugged in any more, and still get the message!

  • 2sidedaviary Level 1 Level 1 (0 points)

    I just had the same problem with my Imac while downloading photos to iphoto.  Got the "usb drawing too much power" message and I too had a white iphone cable with nothing attached, a backup hard drive and the camera.  But the screen then went black and would not power off or power on until I unplugged for 15 seconds.  It restarted fine, but I am wondering if I need to do anything else besides get a new white cable for my iphone.

Previous 1 2 3 4 Next