Previous 1 2 3 4 5 Next 127 Replies Latest reply: Jan 31, 2016 1:41 PM by Lou_295 Go to original post Branched to a new discussion.
  • minimejh Level 1 (0 points)

    I stopped using my white cable and I don't get the problem any more.  Cause and effect?  Not sure.  But the message has stopped.  I also stopped using a 4:1 usb extender hub.  That could have been it too. 

  • 2sidedaviary Level 1 (0 points)

    well hopefully  it is just the white cable.  I don't have a hub, mouse & keyboard are wireless.

  • clittle56 Level 1 (0 points)

    I am having this same problem but no USB devices plugged into either of my two USB ports. I know some people said it was the "white cable"? I'm not sure what that is. Could someone explain it to me? I've tried SMC reset, PRAM reset, rebooting. Nothing seems to work.


    I'm having this problem on a Late 2008 MacBook Pro Unibody.

  • clittle56 Level 1 (0 points)

    Edit: Some posts also mentioned a power hub, does it allow you to use the USB when the MacBook has disabled them?

  • Matt2.0 Level 1 (10 points)

    Just bumping this issue. This message comes up every time I reboot my 13'' 2009 MacBook Pro. I have nothing plugged in to my USB ports. The left USB is not working if I try to connect stuff.


    Resetting stuff (PRAM etc) doesn't work. Hardware test OK. Haven't tried reinstalling everything from scratch.


    Has anyone in this situation been able to fix it? Very grateful for any advice.

  • HNelson1991 Level 1 (0 points)

    Bumping Issue. I'm having a problem with my Wacom Bamboo Fun Tablet Cable. I bought a new one, and my Macbook Pro 13 inch (Mid 2009) gave me the message. It's the same cable model as the old one, but the message only pops up when I plug in the new cable.

    I've tried resetting and the hardware test, but everything came out OK

  • henry.rdr Level 1 (0 points)

    How the problem was fixed for me:


    I had the same exact problem. My new iPhone 5 when plugged into my macbook gave a message, "Because a USB device was drawing too much power..." It did not charge. When I plugged my iPhone 5 to an outlet it using the same usb cord, it still did not charge.


    I switched with using a friend's USB cord (lightning) and it worked: it charged from my macbook and outlet. I think it's the cord's problem.

  • Kjell Level 1 (0 points)

    I have a number of iPhones and then also a bunch of USB cords. I have one cord that came with a 4s that causes this problem. Outlet won't charge, Excesive power errors on the different macs. Also gone thru with phones 2g 3gs 4g 4s all the same problem with this cable. I havn't taken it back to the store, but I guess I should. This is defenatly a cable issue.


    As for other issues causing this problem it is usually something that draws to much power. Sometimes this can be solved with a separete powered hub.

  • vv.doc Level 1 (0 points)

    I started recently to have the same pop up window, "USB draining too much power....", I have no any different peripheral I have no used in the past. I did resett  SMC,  no changes.

    I have external monitor attached. and USB microphone with included mouse control. The system report showed this devices required 100 mA and has available 132 mA each.

    It seems to be random.

    I have used this mic with external monitor for hours and everything works fine, no warnings.

    I have sometimes attached USB 3.0 express card.

    I really do not see why now this is happening. Is it the last Lion update bug?


    Any solutions  outhere?

    Buying and external powered USB hub for now?

  • midget1999 Level 1 (15 points)

    hi guys, just fixed it. im guessing you have more than one iDevice lying round the house, obvioulsy all coming with a sync cable. Try using a different one because you might for example, be using an iPad cable and getting too much power (because its a larger device). Hope this helps!!

  • dub_47 Level 1 (0 points)

    I have been getting the error message constantly now.  My Razer Deathadder mouse keeps cutting out and was convinced it was just that as everything else I have plugged in stays active, but I continued to get the message with NOTHING plugged in.  Apparently having no USB device plugged in can still have a USB device draining too much power.

  • amber0209 Level 1 (0 points)

    I just recently started having this problem so naturally I googled it. I found this thread that's almost a year old but it helped me tremendously. I've been through countless USB cords, whether they were authentic Apple products or cheapy $5 ones. I read a response saying that it happened even when the USB cord was plugged in with no iPhone or etc connected, so I tried it and same for me. After digging through my parents' computer room, I found an authentic Apple USB cord and I tried that, and viola! It worked. My cheapy $5 cord was the problem. It works to charge my iPhone but if I want to sync it whatsoever, no luck. I was actually scared it was my MacBook Pro or my iPhone 4S... but it wasn't! Good luck to everyone else, because this is obviously still a problem!

  • deanmyra95 Level 1 (0 points)

    Its most likely a damaged USB cord.  Replace the cord.  I had the same problem and was able to narrow it down directly to that.

  • mariskt Level 1 (0 points)

    T'was aluminium foil in my case (from medicine pack) - it had slipped into the wide end of the cable.

  • DwayneForde Level 1 (0 points)

    I tried a PRAM reset while I had external montiors and a hub still plugged in and the error persisted.


    I got rid of this error by doing a PRAM reset while everything non-essential was unplugged from the machine (including external monitors) and waiting for it to startup up completely before plugging things back in.

Previous 1 2 3 4 5 Next