Previous 1 4 5 6 7 8 9 Next 128 Replies Latest reply: Mar 8, 2016 11:44 AM by helenabarbara Go to original post Branched to a new discussion.
  • Csound1 Level 8 Level 8

    rogerh2 wrote:


    Csound1 wrote:

    BM6 wrote:


    , WITHOUT any usb attached.

    Once again, that condition is impossible regardless of whether anything is plugged into the external USB connectors, read my previous post.


    Your comments really aren't helping anyone.

    At least they are accurate, unlike your sweeping generalization that "nothing is connected"


    Good luck with your problems.

  • GoldMiner Level 1 Level 1

    It's the first time it happens to me.

    I just connected my iPod touch 4G to my 7 yr old MBP and got this message.

    This time the only thing different was that I used a white Apple USB cord that I never used before (a bit different from what I always used, I think it came with one of my older daughter's iPods- perhaps a Classic or so).

    After some min of syncing got the "astonishing power drawing message", took the cord to my wife's 3 yr old MBP, disconnected the "regular" cord that she was using to charge/sync her iPod touch 4G and... sure enough, same message.

    Disconnected the "different" cord, reconnected the "regular"... business as usual...

    Connected my IT to my MBP with the "regular" from my wife's... working as always.

    Don't know how many others had this problem, just adding my 2 cents...


  • Jenily Level 1 Level 1

    I've been having this same problem for the last several months on my MBP-13" mid-2010.  I get the error message consistently on start-up with nothing plugged in.  Seems like a lot of people are reporting this issue on the same computer model.  I have reset the SMC and my firmware is up-to-date.  I would appreciate some help from Apple even if I am out of warranty.  Thanks.

  • Csound1 Level 8 Level 8

    Jenily wrote:


      I would appreciate some help from Apple even if I am out of warranty.  Thanks.

    This is an Apple users forum, it is not Apple. Take your MBP to an Apple Store.

  • PaulLakeTahoe Level 1 Level 1

    Its a bad power cord.  Switch cords and all works great!

  • Jennie VH Level 1 Level 1

    I think you mean "It's a bad USB cord."


    Swapping USB cords did the trick for me! What an odd situation.

  • kkasr Level 1 Level 1

    I bought a Macbook Pro on 09/05/2011. The other day my son left a flash drive (2 GB) in one of the USB ports in the night and left the macbook in sleep mode. Next morning, when switched on inserted flash drive in USB Port get this message "" To prevent damaging your computer, the USB device drawing too much power has been disabled. Other devices may have also been disabled. When you disconnect the device drawing too much power, your other USB devices will be enabled again.".

    I tried SMC reset and PRAM Reset as suggested in this forum. Nothing worked. Apple Hardware test shows no issue.

    Went to Apple Store,  to get it fixed. They say the Logical Board has to be replaced and said it would cost $400 and then they said it would cost $280.  For leaving a flash drive, that does not draw too much power, system disabled both ports and not recognizing any device - printer or flash drive when connected.

    Why should we pay for a faulty design of macbook, which is a simple enable USB Ports on a Windows operated Laptop?  For leaving flash drive (2GB) in a port and keeping macbook in sleep mode.

    Any help would be appreciated. 

  • daneod Level 1 Level 1

    im getting this problem ever since i plugged in a d link hub now no usb is working and the curser keeps freezing every couple of seconds help?? tried every solution ats next

  • jatuttle Level 1 Level 1

    daneod, it sounds like you have an issue with one of the internal components connected to the usb bus or perhaps your usb bus itself. You can attempt disabling and re-enabling each device and then the entire bus but it sounds like this may be a warranty/component issue.


    I encounter the same error message : "Because a USB device was drawing too much power from your computer, one or more of your USB devices have been disabled..." after using a, new to me and my mbp @least, Apple Pro Mouse purchased second hand. The funny thing is that I was using the mouse fine for several minutes when I first encountered the error/warning message however I didn't loose mouse functionality from the external mounse but the trackpad ceased to respond. I unplugged the Pro Mouse and viola the trackpad worked.


    To verify I had a bunk mouse I tried inserting it to the usb once again and got the error message almost immediately but this time the trackpad continued to function fine and the Pro Mouse was disabled. After examining the pro mouse for any defects I did notice the cord was a bit wonky and could have been compromised in some unseen way.

  • daneod Level 1 Level 1

    ya there isnt a soloution i havnt tried tried reinstalling lion and os x  but still  get the mgs and nothing will plug in or is plugged in im thinkin the board must be fried i also had and x ternal hard drive plugged in when i plugged in the d link and now thats dead tried it on other comps will have to take it to apple, cracking up i am!

  • Freddy Johansen Level 2 Level 2

    Having exactly the same problem. Nothing plugged into my USB ports, and this message pops up every 10 minutes or so. Getting on my nerves.


    This is an MBA purchased in February 2013. I did not pay this much to have this happen all the time.

  • daneod Level 1 Level 1

    are your usbs working? found out my problem fried logic board due to power surge fkin joke has to be replaced costing 650! crazy and no choice but to go ahead with it

  • Csound1 Level 8 Level 8

    I doubt that your logic board was fried by a peripheral device, especially one connected via USB.


    How do you know what happened, or is this just a guess?

  • daneod Level 1 Level 1

    it was a usb hub i was using but i plugged in the wrong power lead for the hub (clown i no) but i tried every solotion and had to bring it to apple  they tested it and said i need a new logic board  and maby new keyboard and track pad everything is fine bar usbs and it was freezing now and then the curser but when i reinstalled lion no freezing but still no hubs working so my keyboard and trackpad should be fine hopefully  ill no all by friday! all from a wrong lead sick i am!

  • Csound1 Level 8 Level 8

    What is this hub that can destroy a Mac by using the wrong cord, and which cord, AC or USB?

Previous 1 4 5 6 7 8 9 Next