Previous 1 5 6 7 8 9 Next 128 Replies Latest reply: Mar 8, 2016 11:44 AM by helenabarbara Go to original post Branched to a new discussion.
  • daneod Level 1 Level 1

    it was a D-link powered usb hub i used wrong AC, i also had a ex hardrive plugged in to hub  now no more good another 100 quid!

  • Csound1 Level 8 Level 8

    Did it have an external transformer (wallwart) and you replaced that cord with a standard cord?

  • daneod Level 1 Level 1

    ya i lost it and found which i tought was it but turned out to be two powerfull i guess.

  • Csound1 Level 8 Level 8

    FYI, what you did was (a) dangerous) and (b) unforgivable on the part of D.Link.


    You plugged a cable carrying 110 or 220 volts into a socket designed for 5 or 10 volts. You're lucky you're OK.


    I don't know where in the world you are but I would report this dangerously poor design to the relevant authorities.


    Don't buy D.Link again, and never change cords unless they are just a piece of wire, no wallwart.

  • TyBo Level 1 Level 1

    I simply don't understand what could be going wrong.


    I have tried all of the resets and even completely reinstalled my OS after wiping my computer. However, it has to be some kind of software issue. I plugged in my external speakers into one of my usbs and it worked. The other one isn't working. And when I plug in my mouse, I get nothing.


    What in the world?!? I need my usb ports to make music this week!

  • converse3 Level 1 Level 1

    I saw this error attempting to charge my Kindle.  It worked very recently, and then suddenly the kindle was failing to charge on any USB power source so I was sure it was not my mac.  I peeled open the USB charging cable because it seemed like the only common piece.  Much to my surprise, I found a piece of broken pencil lead inside the USB plug, shorting out the 4 conductors.  I turns out I'm happy to have the curcuit breaker on the mac shutdown the USB port.  Of course I need a new cable now...


  • the_keys Level 1 Level 1

    I had this problem yesterday on stage with a midi controller keyboard.   Today through trial ad error i have locatd the problem to be with the usb cable and not hardware.   Gig was fun though!

  • chelsea4life Level 1 Level 1

    Hi Guys,

    I have read the entire thread but am unable to find a solution that would get my MBP's USB drives back again. The only thing that I connected to my USB drive was my iphone and that too with the original charger cable. This was 1 month ago. It gave me the "drawing too much power error" and has stopped working since then.


    Now I have nothing connected to my USB drive. I have tried resetting the PRAM (or whateve its called) as recommended on this thread, tried removing all attachments, restarting, etc etc.. However nothing seems to work.


    Now when I try and connect a 2GB/4GB or an 8GB "pen drive" (portable USB drive), it does not seem to work. I have even tried connecting an original apple keyboard, a mouse, iphone/ipod/ipad, yet nothing works.


    I did a hardware test today. The test says all is in order.


    Can someone recommend a solution apart from the ones mentioned here (and please dont say that I need to take this to the apple store, coz I can figure that out for sure)


    Thank you

  • rogerh2 Level 1 Level 1

    I didn't find a definitive solution – it just eventually resolved itself. Have you tried disconnecting everything, shutting the Mac down, removing the battery, unplugging it from the wall and leaving it for a while rather than just re-starting? Worth a try (if you haven't already).

  • madoublet Level 1 Level 1

    This happened to me today for the first time too. And the only hting I have plugged in is my iPhone as well. With the original cable. Very odd and would liek to have a real solution.

  • Britneylee Level 1 Level 1

    This JUST happened to me. I used my sisters cable and VIOLA lol. it worked.

    My cable was also quite old and it had a twist in the plastic tubing  so maybe that had something to do with it. I say just get another cable to use.

  • elastic Level 1 Level 1
    Mac OS X

    This problem is bizarre.


    Basically - I have an audio interface connected via USB, then one day i get the message 'usb device disabled drawing to much power....'


    So i tried a few different cables, and 1 cable worked fine.


    Now all of a sudden, the problem is back - the cable that was working fine is now not working fine.


    I've tried 8 USB leads, reset the SMC, reset PRAM, etc etc......


    All the 8 USB leads i have work fine with other stuff, but as soon as i plug this audio interface in, it doesnt see it. The interface is fine because i've tried it in another computer.


    I've lost a lot of faith in apple products over the last year or 2. It seems like theres always some sort of bug/problem. This will be the end of the line for me now. I just can't trust the quality or reliability of their products anymore.

  • Jan Anderson Level 1 Level 1

    Losing patience too a bit.

    I guess the jury is still out, but both mavericks and ios7 have had some problems that I was used to with Apple back in the day but that we have been largely free of for many years now.

    No statistic evidence really. But the rotating lock bug in ios7 and this one is something I am not used to seeing

    on all my Apple stuff. Ah well, material world.

  • macosaurus49 Level 1 Level 1

    Yes, this was aggravating. It did finally shut down the port I have my keyboard plugged in to. The USB Port Hub worked for me. Buy one that has its own power source, of course. I plugged a hub with its own power source into one of my working USB ports and voila! No more error message. Thanks for that advice. I just bought a "Belkin" brand for @ $29.00. It has its own power source and seven USB ports. Again, thanks for the help.

  • Unknown_newb Level 1 Level 1

    If your charger does do this, u can go to a genius bar and tell them that your charger has an error when you plug it in. and they shooulg give you a new one

Previous 1 5 6 7 8 9 Next