Previous 1 2 Next 19 Replies Latest reply: May 27, 2014 2:36 AM by Denniknak Go to original post
  • Van_ Level 1 Level 1 (0 points)

    Hi Michel:


    Thanks, for the response. 


    Correct on the PRAM, but it was a suggestion in a thread that had some merit.  The issue in my case occurred after a power outage.  The MacMini Lion is the main iCal which syncs to iCloud and backs up via TimeMachine.  I had been updating the events from my iPhone on the light rail on my way home, maybe 5 of them (since iCloud / iPhone / iCal updates are so slow), and a few of them were repeating events, and these were the only ones causing the 500 server error on iCloud.


    What likely happened is these events were in the midst of an update when the power went out, and just got out of sync with the iCloud.


    I contacted Apple Support and got through to an engineer, and after logging into a different profile on the MacMini, subscribing to iCloud, and syncing, the issue with the select events throwing 500 server errors when modifying them persisted.  The Apple agent recommended I Archive iCal in the main profile and delete all events and re-import from the Archive.  Did so, and it got a bit more bizarre. 


    After deleting the calendars from iCloud and re-importing, I would see the calendars and events in iCal on the MacMini for a few seconds (2-3), then they'd disappear.  :-)  I did this several times until I realized the iCloud had authority and any re-imports of the archive were going to continue to have the calendars / events deleted immediately after iCloud saw them and sent back to the client these calendars were deleted.


    So, I did the following:

    I launced Terminal, I did the following to tar up the iCal Library created during the subscription to iCloud via the other MacMini profile:

    sudo su -

    cd /Users/other-profile-user/Library/

    tar czvf /Users/main-profile-user/Desktop/other-profile-user.ical.20120510.tgz Calendars/



    cd /Users/main-profile-user/Library/Calendars/

    tar xzvf ~/Desktop/bond.ical.20120510.tgz && find ./Calendars -type f -exec chmod 400 {} \;




    [Process completed]


    What that terminal business did was created a complete archive of the unsync-ed Calendars directory in the main user profile and the double ampersand ( && ) in Unix tells the bash shell (which is the api in terminal, unless the shell is changed) to process the first command and immediately execute the next command without delay.  In this case the find command instructs the shell to find all files in the Calendars folder and make them read-only (chmod 400).  This prevented iCloud from writing it's empty calendar version of the iCal store to the local cached version, thus retaining the calendars and events in iCal.

    After restoring my calendars in a read-only state, I went back into iCal and exported each calendar individually which only exports the events, not the iCloud profile and credentials, which Archive does, so I could remove the Calendars in iCal (after chmod -R 644 * /Users/main-profile-user/Library/Calendars/ to make the calendar items / events writeable again in terminal), then re-subscribe to iCloud, and import these exported calendars individually back into iCal, and sync with the iCloud.


    Very complicated, to be sure, but I'd have lost 8 years of calendars without following this procedure.

    If I had just exported the individual calendars, rather than archiving them before deleting them from the iCloud, this procedure would have not required Terminal.


    Best Regards,


  • Michel Colman Level 1 Level 1 (15 points)



    When I said that iCloud/MobileMe settings could have nothing to do with it, I was assuming that people were having trouble with Google Calendar (like the original question said). Obviously, if you were having these error messages for an iCloud calendar, it's a different story. Interesting that you had to apply such a complicated procedure, iCloud definitely does not appear to be very robust yet if it can't recover from a simple power outage on your computer. No user should ever be forced to use the command line for such a problem.

  • rockerston Level 1 Level 1 (0 points)

    This post is a bit late, but for weeks I had the same problem as the OP.  I tried deleting / re-adding the google account and many other things, but nothing worked.  Finally, I went into my google calendar in a web browser and clicked settings, then calendars. 


    I found that I had created a new calendar a few months earlier.  Then, a few weeks earlier, I had chosen not to display it in the web version of the calendar.  This seemed to have caused the problem.  Deselecting this calendar in iCal didn't help, and it was still giving me the 500 error.  So, I just deleted the calendar in the web browser (since I didn't need it anymore). 


    I then went to the "Mail, Contacts, and Calendars" area in the System Preferences and unchecked and rechecked the "calendars" box for my google account.  I don't know if that was actually necessary or not.


    Now, when I click the "calendars" button in iCal, it only shows my main calendar and no more 500 errors.

  • Genjoke_ Level 1 Level 1 (0 points)

    I had the same problem using Calendar/iCloud only calendars.


    I googled the solution and found this


    • Go to system setttings and switch off “Calendar” in the iCloud Settings.

    • Open “iCal” and close it on your Mac.

    • Then switch on “Calendar” in the iCloud and open iCal again.


    Problem solved.

  • Denniknak Level 1 Level 1 (0 points)

    I had similar/same problem and after a lot of searching - found the answer on another thread:


    Re: iCal cache is corrupted


    Sep 7, 2012 9:40 PM (in response to LMM50)

    Quit iCal. In Finder, from the Go menu select 'Go to Folder...'. Enter the path   ~/Library/Calendars/   . A new Finder window should open. From that window move the file Calendar Cache to your Desktop. Re-open iCal.


    If you try and manually find the folder you can't find it - so you have to copy and past the path from above.

    It worked for me and now no error messages popping up every 30 seconds!

    If it works, then you can delete the calendar cache file you've just put on the desktop as it will have already made a new uncorrupted one as you reopen ical again.


    Hope that helps - John's answer certainly solved my problem.

Previous 1 2 Next