9 Replies Latest reply: Mar 22, 2014 4:15 AM by mac10_4fan
grenadier Level 1 Level 1 (0 points)

Ok guys, I know, this is REALLY long, but I want to Thoroughly explain Everything that I did and the results of what happened so I can get the most accurate help and answers possible! Thank you for taking the time to read this and help me! I need my laptop for school and work (but mostly school), and can't afford to buy a whole new laptop right now. So Thank you in advance!

 

So Basically, my MacBook won't recognize my newly installed 750 GB internal hard drive, but Does recognize it when it is connected externally through a SATA to USB cable. Though my old hard drive is recognized both internally And externally. So here's the chain of events....

 

Ok, so I've read some other posts on this site and on other sites,but nothing that solves this problem. I haven 2006 13" MacBook and the original hard drive started to fail, so I bought a 750GB seagate SATA hard drive, 16MB, 7600RPM. I backed up all my information from my original (old) hard drive, and while I was waiting for my new drive to come in the mail, I Zeroed the data on the Old Hard Drive, then partitioned it with 1 volume, GUID scheme, Mac OS X Extended (journaled). Then I re-installed OS X 10.4 on the old HD from the install disc, then upgraded all the way to Lion 10.7. Everything installed successfully  and went smoothly, so I thought that I now have an extra hard drive, Great!

 

Well, Once my new hard drive arrived in the mail, I installed it inside my Mac, popped in the install disc, and attempted to ready the HD for the OS X 10.4 installation by erasing then partitioning, but when I went into the disk utility (from the install disc) to erase and partition the new hard drive, the specs on it were all wrong! It stated that the total capacity of the drive was 5.5 TB, when its actual size is 750GB! So it wouldn't complete the partition because of an "Input/Output error" (I tried to partition it with 1 volume with GUID Scheme, with Mac OS X extended (journaled). I couldn't even zero out the disk because of the same Input/Output error.

 

I was pretty boggled by the situation, so I took out my new HD and put back my old HD. You should also know that I have a SATA to USB connector, so I decided to connect my new HD through USB and try partitioning it using the disk utility running on the Lion OS on my old HD. When I selected my new HD in disk utility, all the specs were fine and everything was in working order while it was mounted as an External hard drive (Even the disk's total capacity was correct at 750GB!). So I booted up the Mac using the install disc and created a new bootable image of Lion 10.7 from my old HD and saved it on a separate external storage device to I an install it on my new HD. Then I restored that newly created image onto my new 750GB HD (from the separate external storage device using the Install disc's Disk Utility) and everything was successful, meaning I now had an EXACT copy of my old HD (which was fully bootable and worked flawlessly) onto my new HD (with the only exception to Exact, that the new HD holds more data).

 

So before I re-installed my new Hard Drive back in to the internal port in my MacBook, I decided to try to boot from it as an External Hard Drive. And... It worked!!! I was able to boot up and everything looked exactly the same as my old HD!!! The disk itself was successfully Verified in disk utility along with all the permissions on the disk AND on the volume. So to my assumption, I though everything was good to go and my new HD was ready for use as an internal HD. WELL... After I re-installed the new HD in my Mac and tried to boot from it (thinking it would boot just like it did when it as connected externally), but again it Was Not recognized!!! So I again popped in the install disc and opened up the disk utility and all the specs of the new HD were still in check and perfect, except that it WENT BACK to stating that the total capacity was of the new HD was 5.5TB!! yet it stated the the VOLUME's total capacity was 697.8GB (this is still with the image from the old HD restored on it).

 

So I plugged in my old HD through the SATA to  USB connector and tried to boot from the OLD one as an External HD (to rule out that it wasn't something besides the internal aspect or the Hard Drive Cable), and everything booted up fine from the external old HD!! It seems that I can only boot from/use my new 750GB HD if it is connected as an EXTERNAL Hard Drive through USB. So again I rebooted (because i wanted to try installing OS X 10.4 on the new HD One more time), I held down the Option key to select the volume to boot from, and selected the install disc to try to install OS X 10.4 on the new HD (mind that it is still internal), and the volume of the new HD appeared on the list along with my old HD's volume (which was still connected through USB)!! But when I went to select the new HD's volume, It stated, "You cannot install Mac OS X on this volume. An error was encountered while running the the VolumeCheck tool for Mac OS X" [and yes there are actually 2 "the" words in the error description]. The only thing that I can think of that could be causing this error is the wrongly recognized disk capacity of the New HD from 750GB to 5.5TB. (To note, I tried zeroing out the new HD all over again and tried, and tried Everything all over again, but without restoring the old HD's image on the new HD, and I still got that same "VolumeCheck" error. So yet again I zeroed the new HD, but I this time I DID retore the old HD's image on it again, and I STILL got the same VolumeCheck error...).

 

SO I removed the new HD from the internal port of the MacBook (it still had the restored image on it with the Disk, Volume, and Pemission successfully Verified). (Mind again, in the detailed disk INFO selection of disk utility, ALL of the information, with the exception of "disk number" [on new HD the disk number = 0; On the old HD the disk number = 6. I'm not sure if that makes a difference or not], is EXACTLY the same same on both Hard Drives!

 

So the overall conclusion: I can only boot and use my new HD if it is connected Externally through my SATA to USB cable, yet I am boot and use my old HD regardless if it's connected internally or externallly.

 

SO, Does anyone know a solution to this? so I can either get rid of that VolumeCheck error and install OS X 10.4, then Snow Leapord, then Lion on my new HD, OR somehow get the new HD to be recognized as bootable when it is installed internally? I guess It is possible to keep my old HD installed and just use that alone, but I need more data capacity than 120GB, and I don't want to have to lug around the new HD with the laptop everywhere I go!

 

I just need Any possible solution so I can Solely use my new HD as an internal, bootable Hard Drive. Can anyone help me?? I really need it!!

 

And again, Thank you in advance for helping me!!!


macbook, Mac OS X (10.4.10)
  • grenadier Level 1 Level 1 (0 points)

    One other thing to add:'it is impossible to partition my new HD while using the tiger install disc. If I select the partition tab while the disk has the old HD image loaded on it, the Disk Utility shows a pop-up that states, "Disk Utility Internal Error- Disk utility has lost its connection with the disk management tool and cannot continue. Please quit and relaunch Disk Utility." and that will forever repeat. Epi am allowed to zero the HD through the install disc's disk utility, but once it's zeroed and I try to partition it, that's when I get the "Input/Output Error". The only way I can partition or restore is either through Lion 10.7 Disk Utility, or its recovery volumes's Disk Utility. It's kind of like a catch 22, because I think I can't boot from the new HD with the Tiger instal disk Because it was partitioned with Lion OS, and then trying to install and boot from Tiger OS. A Conflict of OS versions.

  • BDAqua Level 10 Level 10 (119,850 points)

    Hello,

     

    I think there are 2 or 3 things at play here.

     

    Newer drives use Advanced Format, 4096 Byte sectors compared to the old 512 Byte sectors, 8 times larger, (8*750=6,000). I'e read that Tiger/10.4 can handle those, but I suspect that it requires 10.4.11 & the Tiger Install Disc is less than 10.4.11.

     

    http://en.wikipedia.org/wiki/Advanced_Format

     

    I don't know if any 2.5" inch drives have jumpers, but many 3.5" drives need jumpers set to accommodate older/slower SATA speeds, nor do I know what SATA speed your MacBook has, but see this Seagate SATA Jumper settings for an idea on the 3.5" drives anyway...

     

    http://seagate.custkb.com/seagate/crm/selfservice/search.jsp?DocId=193991

  • nrg adjusta Level 1 Level 1 (0 points)

    Hi Grenadier,

    How did you go? I have the exact same problem after accidently overwriting my Mac HD during attempted bootcamp install. Now I have restored to an external HD and Lion recognises the HD which i was then able to reformat and partition, but i am unable to reinstall Tiger from the install disk via holding down C at start up. As it wont regognise it and says its 7TB in size and wont alow me to reformat it.

    Help!

  • grenadier Level 1 Level 1 (0 points)

    nrg adjusta,

     

    Sorry it took me a while to repsond, Ive been pretty busy with school and work. But for my hard drive problem, I did hours and hours of more research and trying countless ways of installing and tweaking things in my laptop and absolutely nothing worked that I could do. It was very irritating because I felt like I was so close to fixing it and I was just missing a step somewhere. Though It still boggles me why the disk utility shows a different capacity for the HD's. One thing I'm going to try next is replacing the hard drive cable that goes from the internal HD to the macbook. I read somewhere that sometimes those can go bad over time, and also if you get a new, modern hard drive, sometimes the old cable (for some odd reason) might not be compatible with the new HD. So i want to test it out for myself to see it that is the actual culprit.

     

    http://www.ifixit.com/MacBook-Parts/MacBook-Hard-Drive-Cable/IF186-018

     

    Once I get the cable and install it I'll let you know the results and if it helped at all.

    Have you made any progress on your hard drive at all? If worst comes worst for you, you can probably get a SATA to USB cable and try to reformat it that way (this is the way that worked for me, but the only problem was it wouldn't be recognized when I installed it internally. Thats why i want to try getting the new cable), and if it still wont recognize it after that, you can just leave it outside of your mac, and just boot from that. The only thing that ***** about that is you have this big hard drive handing off the side of your mac when ever you need to use it.

    Heres a link for a SATA to USB. this one is good because is compact and protects the HD from damage and most static electricity.

     

    http://www.thinkgeek.com/computing/usb-gadgets/e6d9/?srp=3

     

    Im still continuing my search for the answer and once i find it (if ever!) I'll post it.

  • DoktorP Level 1 Level 1 (0 points)

    Hi,

    i have the same problem with a macbook late 2008 and os x tiger 10.4.10

    i bought a new 500gb WD hard drive with this advanced format and all i get is this input/output error and the information that it is 3tb large...

     

     

    at first i thought it was a broken hard drive cable that causes the "input/output error", so i bought a new one at ifixit. i replaced it today, but nothing changed. i wouldnt buy it...

     

    then i read about "advanced format" and booted from a leopard upgrade disc. my new hard drive is now recognized with the right size, but i cant install from an upgrade disc, because it needs tiger to be there.

     

    so the problem is, that we need an os x install disc higher than 10.4.10 to install osx on a new hard drive with advanced format.

     

    i've been searching for hours and the only way i see is to buy os x 10.6 snow leopard, because they say it's a full version that doesnt need earlier versions to be installed.

    http://hints.macworld.com/article.php?story=20090926175114867

     

    can anyone affirm this?

     

    EDIT: I just ordered snow leopard 10.6.3 and i'll tell you if my plan worked..

  • DoktorP Level 1 Level 1 (0 points)

    hi,

    this guy had the same problem and solved it with snow leopard..

    https://discussions.apple.com/thread/3827225?start=0&tstart=0

  • BDAqua Level 10 Level 10 (119,850 points)

    Thanks, actually any OSX 10.4.11 & up should work, it's just that 10.4.11 never came on an Install Disc.

  • BDAqua Level 10 Level 10 (119,850 points)

    Yes, any Install Disc above 10.4.10 should work, just 10.4.11 never came on an Install Disc, so 10.5 & up should work.