1 Reply Latest reply: Jul 23, 2012 12:35 AM by AmitabhSF
KB22 Level 1 Level 1

So I've been digging around but have yet to find an answer so I guess I'll just post my question.  My iCloud, like a lot of people's, is full.  I have turned off all the individual app data including the camera roll, but my backup size continues to grow by about 100 mb a week.  I tried deleting text messages that included videos but the future backup size has not been effected.  I tried deleting my history and safari cache, but no change.  I don't have any voice memos or use the icloud mail.  Any thoughts on what is causing it to grow?  Its to the point where my phone is now not backed up, so I'm thinking I need to go back to the computer based backups. 

MacBook Air, Mac OS X (10.7)
  • AmitabhSF Level 1 Level 1

    After dealing with the same problem for months, I think I've finally cracked it: What's the app you use really often, but isn't listed among the individual backup options in the iCloud settings? Yup, Messages. Chances are that over time you have been sending and receiving photos and -- an even bigger culprit -- videos. These have been piling up locally on your device and getting backed up to iCloud each night.


    Today I manually went through each of my iMessage threads on my iPhone and iPad and deleted all videos that I sent to/received from friends and family (I'm leaving photos for now, since they're much smaller files). Then I deleted both iCloud backups and then turned the iCloud backup fuctionality back on. Like a charm, hundreds of megabytes of backup size had been shaved off of both devices. If you're not too attached to your various iMessage discussions, you can just clear them altogether and save yourself the painful exercise I undertook. From now on, I'm going to delete a video from Messages as soon as I send it; if I'm receiving, I'll save to Camera Roll and delete from Messages.


    I hear that Voice Memos on your iPhone is another app that can pile up big files but not show up in the individual iCloud backup settings.


    Hope this helps. If so, please indicate that it solved your problem. Thank you.