11 Replies Latest reply: May 17, 2012 1:21 AM by Motorized Citrull
Sergej Müller Level 1 Level 1 (0 points)

Since the Samsung Printer Drivers v2.3 update i can not use my Samsung scanner (Samsung SCX-4500).

What is the download link for Samsung Printer Drivers v2.2?

 

 

Thanks.


Mac OS X (10.7.3)
  • 1. Re: Download for Samsung Printer Drivers v2.2
    msweney Level 1 Level 1 (10 points)

    I have this same problem, and downloading the scanner driver from the Samsung support center did not fix it.

  • 2. Re: Download for Samsung Printer Drivers v2.2
    The_Ben Level 1 Level 1 (0 points)

    I have the same printer as well, and updated to both 10.7.3 & v2.3 Samsung printer drivers and now can't scan using my machine. Obviously that on a nearby Windows machine the printer works, so it's not a hardware issue.

    Afrer some searching I found the v2.2 download link (Samsung drivers), but after installing it the situation is the same - prints just fine, can't scan (the scanner does appear in Image Capture, but upon selecting it all I see is this screen: link).

    Here's the link to the v2.2 drivers, just in case you want to try it yourself: link.

  • 3. Re: Download for Samsung Printer Drivers v2.2
    Michele Tumminelli Level 1 Level 1 (0 points)

    Hi guys, I have the same problem.

    The downloading scanner driver from the Samsung support center did not fix it, and the problem is caused from Samsung Printer Drivers v2.3 update befor scanner work well.

     

    I view that when show the Image Capture as The_Ben told the system consol show this error:

     

    PrinterProxy[901]: *** -[__NSArrayM objectAtIndex:]: index 0 beyond bounds for empty array

    PrinterProxy[901]: (

                        0   CoreFoundation                      0x0000000101a26fc6 __exceptionPreprocess + 198

                        1   libobjc.A.dylib                     0x0000000101897d5e objc_exception_throw + 43

                        2   CoreFoundation                      0x00000001019b4582 -[__NSArrayM objectAtIndex:] + 274

                        3   ImageCaptureCore                    0x00000001035e1135 -[ICScannerDevice handleScanParameters:] + 2839

                        4   Foundation                          0x0000000101cb41aa __NSFireDelayedPerform + 392

                        5   CoreFoundation                      0x00000001019dbc24 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__ + 20

                        6   CoreFoundation                      0x00000001019db776 __CFRunLoopDoTimer + 534

                        7   CoreFoundation                      0x00000001019bc001 __CFRunLoopRun + 1617

                        8   CoreFoundation                      0x00000001019bb676 CFRunLoopRunSpecific + 230

                        9   HIToolbox                           0x0000000107ead31f RunCurrentEventLoopInMode + 277

                        10  HIToolbox                           0x0000000107eb45c9 ReceiveNextEventCommon + 355

                        11  HIToolbox                           0x0000000107eb4456 BlockUntilNextEventMatchingListInMode + 62

                        12  AppKit                              0x00000001021b0f5d _DPSNextEvent + 659

                        13  AppKit                              0x00000001021b0861 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135

                        14  AppKit                              0x00000001021ad19d -[NSApplication run] + 470

                        15  AppKit                              0x000000010242bb88 NSApplicationMain + 867

                        16  PrinterProxy                        0x00000001017d9b48 PrinterProxy + 6984

                        17  ???                                 0x0000000000000002 0x0 + 2

              )

     

    any ideas?

  • 4. Re: Download for Samsung Printer Drivers v2.2
    msweney Level 1 Level 1 (10 points)

    If you go to the discussion with the similar SCX-4300

     

    https://discussions.apple.com/message/17684743#17684743

     

    you will see that mazomat has solved it:

     

    Same Problem here (after installing 10.7.3 and samsung printer software 2.3 via system update). I restored "Samsung Scanner.app" in /Library/Image Capture/Devices from a time machine backup i run before doing the updates (if you tried scanning you can´t replace the app because it´s in use. Then do a restart before restoring). Now my scx-4500 scans again. Let´s wait for samsung printer update 2.3.1 ...

     

    I don't know if it is Apple (Apple installed the 'upgrade') or Samsung to blame, but regardless, I hope they forget their differences and start helping us, the end-users, who put the money in both their coffers.

  • 5. Re: Download for Samsung Printer Drivers v2.2
    Sergej Müller Level 1 Level 1 (0 points)

    Yes, it works. Thank you.

  • 6. Re: Download for Samsung Printer Drivers v2.2
    vikd Level 1 Level 1 (0 points)

    Have someone maybe the Samsung Scanner.app file for me?

    I have the same problem with my Samsung SCX 4500 and i don't have the Backup file

    in my Time machine (my oldest backup is 2 weeks old).

  • 7. Re: Download for Samsung Printer Drivers v2.2
    Michele Tumminelli Level 1 Level 1 (0 points)

    It would require too

  • 8. Re: Download for Samsung Printer Drivers v2.2
    Sergej Müller Level 1 Level 1 (0 points)

    Samsung Scanner.app: http://d.pr/DhE8

  • 9. Re: Download for Samsung Printer Drivers v2.2
    vikd Level 1 Level 1 (0 points)

    Thanx to Sergej! Now it works again! :-)

    My Mac want's to reinstall the 2.3 Update again but i just uncheck it.

    I hope Apple will bring a new update.

  • 10. Re: Download for Samsung Printer Drivers v2.2
    hessix Level 1 Level 1 (0 points)

    Hi,

    the drop of Samsung Scanner .app has been deleted.

    I have trouble finding it elsewhere.

    Any chance you could post it again please ?

    Thank you.

  • 11. Re: Download for Samsung Printer Drivers v2.2
    Motorized Citrull Level 1 Level 1 (0 points)

    Hi, I have the same problem. OS X 10.7.4 and Samsung Scanner.app 2.3 don't work together.

     

    I don't have a backup of Samsung Scanner.app 2.2, then I downloaded the original driver from the Samsung support site (italian) here:

    http://www.samsung.com/it/support/model/SCX-4300/SEE-downloads

     

    After a reboot, Samsung Scanner.app version is now reported 2.00.89 by the Finder.

     

    I just scanned a couple of pages and it works!

     

    Ciao

    Marco