Previous 1 2 3 Next 30 Replies Latest reply: Jan 28, 2013 7:42 PM by Skoda21
76543 Level 1 (0 points)



Person A: Logged into iMessage on OS X Lion with same account as synced with iPhone


Person A sends iMessage from app to Person B.  Person B responds


Conversation is not synced to iPhone.  Person A sends another message to Person B from iPhone this time.  It appears to Person B as a different message thread.  However the same contact is seen for both.

iPhone 4, iOS 5
  • JTSteel Level 1 (0 points)

    I notcied this at first but after sometime it seemed to be fixed and my iPhone appears to show the messages sent and recieved via OS X Lion. Might have been a server problem?

  • NikoGW Level 1 (0 points)

    Thought I would solve it by changing the iPhone settings under Settings/Messages/Receive At, from phone number to Apple ID on both Person's A and B iPhones... But nope, nothing... No Sync at all to Lion. Person B has 2 message threads.





    iPhone 3GS

  • TomRivers Level 1 (0 points)

    Same problem here. interested in finding a solution.


    I've sent iMessages from my Mac to Person B, and from my 4S to Person B.


    Shows up as two threads, one from my email address (Mac), and the other from my contact card (iPhone).

  • robs89 Level 1 (10 points)

    Have you stored your phone number in your Apple-ID?


    Login here and look in the "Numbers" field: ?wosid=qa71GKsAsqObhGn0rjXIr0&localang=en_US

  • jgarbers2 Level 1 (0 points)

    Try taking a look at your "Caller ID" setting on your iPhone:


    Settings > Messages > Receive At > Caller ID


    My iPhone was using my phone number as Caller ID.  When I switched it over to using my email address, I was able to consolidate message threads across my iPhone, iPad, and Mac.


    Then the problem becomes having the iPhone and iPad beeping at my desk whenever I get a message in the middle of a Messages chat on my Mac...

  • robs89 Level 1 (10 points)

    The "Caller ID" on my iPhone is my phone number. Altough it works fine for me.

  • AUSTOOO! Level 1 (0 points)

    Make sure your caller ID settings in Messages on OS X are the same as your iPhone. Once I switched that, the conversation syncs to my iPhone. First it only showed what I had typed to the recipient, and then about 5 minutes later the recipient's replies synced to my phone all at once.


    Cheers to Beta.



    EDIT: I checked my Caller ID on my phone and my phone number is selected, not my email. Sounds like the system is just a little slow. I mean, it is day one.

  • Rob Wheatley Level 1 (15 points)

    Yeah, it looks like there are a number of problems to me.


    I've been trying a number of things, but I can't get it to work as advertised. Replies come back to the wrong device, nothing is synchronised and sometimes messages fail to send. I assume it's teething problems, but Facetime is still totally unreliable (and therefore unusable) so I hope Apple dont make a hash of this too.


    I've ensured that I am using the same Apple IDs everywhere (which is hard as I have one for my iTunes account and another for iCloud). I assume it's the iCloud one that needs to be the same one the iphone, but to be sure I created an iTunes account with the same ID so I'm logged on as one now. I realise this will create problems for me in the future as I already have 2 iTunes accounts (1 UK and 1 US) so updating apps on the phone is a total pain.


    Things I'm finding:


    1) Messages aren't syncing between devices.


    2) If I send a message from OS X to person B, the replies are going to my iphone. If I send them to person C, the replies come back to the desktop. Never both (like it should) but always consistent.


    3) Messages sometimes fail to send


    4) iOS messenger app 'forgets' my Apple ID


    5) When I tell the iOS app about my Apple ID again, I have to add the additional email addresses again


    6) OS X app doesnt give me the ability to set my phone number as the caller ID

  • karlossus Level 1 (0 points)

    Same problem here, iMessage has never sync'd for me across iPhone and iPad and now it doesn't sync across my Mac either. I have my email set up on all three devices and set as the preferred option on the iPhone (the other two don't have the option to choose a phone number). I've also added my mobile phone number to to the iCloud settings. I think that covers all the advice here. I currently have no messages on my Mac and different sets on the iPad and my iPhone.


    I'd like it to work mind.

  • sgillet3 Level 1 (0 points)

    I'm just trying to add to this thread, I'm having the same issues as all of you.  nothing seems to have worked so far in trying to get my Mac, Iphone, and Ipad to sync messages

  • DWhites3 Level 1 (10 points)

    Hi all!


    I think I have found a solution to the problem.  I don't mean to been too basic if everyone already knows this, but I'm sure some people out there are having trouble understanding.


    The disconnect arises from the ways in which iMessage can send messages.  It can either send it via your phone number or your email address.  Most peoples' iPhones are probably set up to use their phone numbr while your Mac, iPad, or iPod touch can only use your email address.  When this is the case, iMessage will interpret a message coming from each device as a distinct user.  This leads it to create two message threads for the recepient.  This is why the conversations will not sync.


    The solution is, in fact, quite simple; You must configure your iPhone to send iMessages via your email account.  The steps to do so are shown below.


    1. Sign into iMessage using your Apple ID: Settings > Messages > Receive At > Use your Apple ID for iMessage > Input Account Information > Next

    2. Ensure that Caller ID is set to your email address, not your phone number: Settings > Messages > Receive At > Caller ID


    I hope this helps!



  • 76543 Level 1 (0 points)

    Thank You!  That did it for me!

  • karlossus Level 1 (0 points)

    Have had all that set up but it hasn't seemed to help the iPad or the mac receive messages sent from the phone. One message sent from the mac has appeared on the phone and then subsequently disappeared from the mac. It never appeared on the iPad. Beta software I know.

  • Dolderer Level 1 (0 points)

    You must delete your previous conversations in order for this to work.

Previous 1 2 3 Next