Previous 1 2 3 Next 30 Replies Latest reply: Jan 28, 2013 7:42 PM by Skoda21 Go to original post
  • karlossus Level 1 Level 1 (0 points)

    Really? It only works if I delete every text & message I've ever sent? Ach well, that's not a solution I'm going to be able to use!

  • KPDover Level 1 Level 1 (5 points)

    Maybe this is a stupid question, but does switching your CallerID from your phone number to your AppleID have any negative side effects? Would a person who only knows my phone number but not my email address have any difficulty reaching me or recognizing me as a sender?

  • octothorpe Level 1 Level 1 (20 points)

    I had OS X Messages Beta and my iPhone go out of sync too. A few messages showed up ONLY on my Mac. Discovered that the Caller ID setting on my Mac had somehow been set to an alternate email address I have (not the one I have set on my phone). I think I'd texted someone from my Mac, and when they responded, it was channeled to that alternate address.

     

    For now, I've just deleted any extra email addresses from both phone and Mac and I'll see if that fixes it.

  • djDeimos Level 1 Level 1 (0 points)

    Just wanted to reiterate that you need to DELETE all your previous conversations* in your mac and in your phone, and wait a few minutes. Then, the messages will start coming correctly... (I even went ahead an extra step and deleted the chat conversation folder).

     

    The only mayor thing I did to fix this issue it was to add my iPhone number and Email to the iMessage settings (on the iphone), so it says:

    ' Receive At 2 addresses > '

     

    - I didn't change the caller ID, it stayed the same on the iphone (as my phone number).

    - Make sure the +1 sign is added to your ID and all the contacts with an iPhone/iMessage (seems to help).

    - After making this changes, I turned off the phone and restarted it, (not sure if that had something to do, but I did it).

    - Deleted the prior conversations on the computer and the iphone... waited a few minutes, and voilá! it works now.

     

    * Thx to Dolderer.

  • Pinkfeet Level 1 Level 1 (0 points)

    I had problems, but after waiting a bit the messages started to sync OK into the same conversation no matter whether it was sent to my friend's iPhone number or email.    Perhaps it is important to have all of a friends details in 'Contacts'/Address book up to date so the iMessage could be linked to that individual?  Just an idea.

  • codydeal Level 1 Level 1 (0 points)

    Okay, I literally did all of these steps, and regardless if they were all necessary or not, by following it, everything worked and lined up! It took a second: a few messages didn't initially go through (Just Mine) and then BAM! the other person's messages started populating on both my iPhone and Mac. Booyah!

     

     

     

    Just wanted to reiterate that you need to DELETE all your previous conversations* in your mac and in your phone, and wait a few minutes. Then, the messages will start coming correctly... (I even went ahead an extra step and deleted the chat conversation folder).

     

    The only mayor thing I did to fix this issue it was to add my iPhone number and Email to the iMessage settings (on the iphone), so it says:

    ' Receive At 2 addresses > '

     

    - I didn't change the caller ID, it stayed the same on the iphone (as my phone number).

    - Make sure the +1 sign is added to your ID and all the contacts with an iPhone/iMessage (seems to help).

    - After making this changes, I turned off the phone and restarted it, (not sure if that had something to do, but I did it).

    - Deleted the prior conversations on the computer and the iphone... waited a few minutes, and voilá! it works now.

     

    * Thx to Dolderer.

  • afsimola Level 1 Level 1 (0 points)

    So everything is set up correctly but for me to get it to sync properly I need to delete any previous convos on my iphone first.  This is a huge problem...

  • Ralph Johns (UK) Level 9 Level 9 (69,740 points)

    Hi,

     

    You should not need to delete any previous conversations on the iPhone. 

    However they will not sync.

     

    One of the Biggest issues is that on the Mac end the Messages Beta does not truly delete messages.

    Another fact is if you have a long conversation between two iPhones the Messages Beta can take a long time to Sync the messages involved.

     

     


    7:52 PM      Sunday; April 29, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • ben.s567 Level 1 Level 1 (0 points)

    I'm on os mountain lion and I have pretty much the same problem. If an iMessage is sent to my iPhone number it only goes to my iPhone. If it is sent to my email it goes to my mac and iPhone.

         I can't see this problem being resolved, and iMessage working as flawlessly as it was advertised to, until I can recieve iMessages from my phone number to my mac. Please sort this out apple, how hard can it be!?

  • Ralph Johns (UK) Level 9 Level 9 (69,740 points)

    HI,

     

    In Messages beta and iOS 5.1.1 is seemed that the iOS device had to be cleared of all Messages before iPhone Number messages would sync to the Mac or other iOS devices.

     

     


    9:45 PM      Thursday; July 26, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • robs89 Level 1 Level 1 (10 points)

    Apple said it will be possible to receive Messages on the Mac, that were send to the iPhone number. It will come with iOS 6.

  • ben.s567 Level 1 Level 1 (0 points)

    Thanks,

    I've done some searching and it turns out, like robs89 said, Apple plan to 'unify' your phone number with your apple ID when iOS6 comes out. So this should sort out the (I'm not going to say problem) inconvenience.

  • mikeindc Level 1 Level 1 (15 points)

    Deleting all message does NOT resolve the problem.  Everything seems to always show on my phone, but getting the conversation to show consistently on my laptop is hit and miss.  I seem to receive most message, but if I send a message from my iphone it usually never appears on my laptop.  If it was always it would make more sense, but its only sometimes that it does not appear.  It is not related to if the laptop is on at the time the message is sent.  Its annoying enough that I seldom bother using messages on the laptop, just not worth the hassle.  I am not too impressed with the way this is "working".  Apple seems to be having problems with syncing.  Itunes match does not sync anywhere close to 100% either.  All of this syncing is great idea, but if its not 100% Iits pretty much worthless.

  • Evan in Manhattan Level 1 Level 1 (0 points)

    This solved my problem too.  I could not get iMessages (both mine and other people's replies) to sync on my iPhone and iMac.  Sometimes they would and sometimes they would not.  And I once missed an important iMessage from my wife because it showed up on my Mac, but I was out and using my iPhone.  And now everthing -- both in and out -- sync perfectly.  The fix was to change my iPhone Caller ID to my e-mail, and not my phone number.  And everything now works!      I just hope that all of my contacts who know me more by phone number than work e-mail know that it's me the first time that I text them!  

  • Rob Wheatley Level 1 Level 1 (15 points)

    I *think* I have it solved. I've had loads of problems with iMessages and I've contributed to 3 threads on the subject. I'm going to post this 'solution' to all 3. Forgive the size of this post, but I think the story is important to help others.

     

    First the back-story:

    iMessages was hopeless. Messages not sending unless I 'woke' it up. Messages not syncing and messages addressed to my phone number only sometimes showing up on my Mac even though I had iOS6.

     

    As a note, I was an iMessages beta user. Also, you will need iOS6 on your phone (I think).

     

    Now, this is what I did and everything is now working. Don't worry about the fact I did a fresh Mountain Lion install as I think that is a step you dont need. However, here is the full story as some of it may help. I'll try and extract the things you need to do at the end.

     

    During a fresh install of Mountain Lion on my Mac Pro (I have that and a MBA) the Mac asked for my AppleID. I gave it. About 15 mins into the install (with another 15 to go) my iPhone beeped with a pop-up message "Mac Pro is now using xxxxx for Messages" where xxxxx was a list of my mail addresses AND my mobile number. It was like the Mac and the iPhone had a conversation and decided it was OK. So I looked to see if I could add my number to messages on the MBA. There's no option to do this (that I could see). To check what Messages is using on a Mac, open Messages, go to Preferences, then Accounts, click on the iMessages one and you get a list. My mobile number wasnt there.

     

    So, I signed out of that account and tried to sign back in again. It didn't work (sign in failed with no error message). I tried 2 more times. On the 3rd try a 2nd iMessages account was created (the first said it was inactive). A few seconds later a message poped up on my iPhone telling me that the MBA was now using the same list of email addresses for iMessages my Mac Pro was AND crucially, my phone number. At this point I deleted the inactive iMessages account.

     

    I then had to restart Messages

     

    Now everything syncs perfectly.

     

    So, my tip. Make sure you have iOS 6. Delete your iMessages account in Messages on your Mac and then add it back (effectively signing in again). This forces OS and iOS to re-sync and I think that everything is fine after that.

     

     

    Rob.