7 Replies Latest reply: Jul 11, 2012 5:49 AM by Geer23Mac
Kathleen Theisen-Remaud Level 1 Level 1 (5 points)

I have read a lot of threads about deleting a sparse bundle, but none of them seem to work in this case. 

 

Here's what's going on:

I have a 2TB Time Capsule. Both an iMac and an older MacBook back up to this disk.  I would like to delete the sparse bundle for the iMac and start over, but want to retain the MacBook sparse bundle and other data that is on the Time Capsule.  Therefore, deleting the TC and starting over is sort of a last resort.

 

I tried simply deleting the sparse bundle, but it just sat there on the deleting status window, with '0' items to delete, but no blue status bar, and never any change or resolution.  I had to stop the delete process. 

 

I see from previous threads that I theoretically could use the Terminal to delete the file, but unfortunately, the sparse bundle is no longer mountable, since I tried to delete it twice.  So, terminal can't mount it or delete it.  Short of archiving the TC disk and then erasing the TC, is there something I am missing here?  Should I try something else? 

 

Apple Care wasn't really able to help with this.

 

FYI... I am running the latest firmware on the TC (updated today) and both MACs are running the last release of Snow Leopard.

 

Thanks much!

Kat

  • Kathleen Theisen-Remaud Level 1 Level 1 (5 points)

    I forgot to mention that the sparse bundle is 680GB in size. 

  • austinfromlenexa Level 1 Level 1 (0 points)

    I am in the same situation.

    so far i have tried rm -rf /Volumes/<path> via drag and dropping the bundle to the terminal window which sits there forever doing nothing

     

    I attempted to shrink the file to nothing to make removal easier with

    cp /dev/null <path>

     

    I have attempted to delete the file via linux with same commands, nothing seems to let me kill this file

    I do understand that since it is a 1.3TB bundle it will take a bit of time to delete, but nothing seems to have any progress at all.

     

    Problem started with backing up 2 MBPs on a 2TB time capsule, one took too much room because i forgot to limit the bundle size.

     

    anything that can be done short of backing up the bundle I plan to keep, creating a backup of settings, and being forced to wipe the TC drive? sounds a bit excessive for such a simple request

  • Kathleen Theisen Level 1 Level 1 (30 points)

    Thanks for your reply.  It's amazing that we can't delete it, isn't it? Apple Care told me the only solution is to wipe the TC completely and start over.  My solution so far has been to just buy ANOTHER external drive and use that as a TC for the iMAC, leaving the other computer to continue to back up to the TC. Eventually, I guess I will have to erase the TC.  They have left us no other options.

  • austinfromlenexa Level 1 Level 1 (0 points)

    after some reading I found that if you right click on the bundle, view contents, select bands, inside here it will take a long time to show all contents as there are probably an enormous number, then delete groups of them rather than trying to do it all in 1 shot. some people had better luck with this method.

    personally, i tried this and it was taking hours just to display this folders contents so i gave up and re-formatted the drive, created new bundles, and limited their sizes to 930gb each so they dont fight each other. creating new bundles now

  • austinfromlenexa Level 1 Level 1 (0 points)

    I had posted this on a social network just incase any friends ran into the same problems I was, so i thought I would copy paste it here just incase you were wanting to know how to limit the size of your bundles:

     

    the problem of having 1 time capsule with multiple computers is that the sparse bundles eventually will fill the disk and fight each other for space (yes i understand they should start to delete their older data, however sometimes problems still occur, and depending on what computer has more data that changes more often, odds of an even 50/50 are somewhat low; on my network at least), or even if you have 1 system to back up, you may wish to use the free space as a NAS. i have been fighting the bundles wanting to grow for a long time since theres no way to partition a time capsule short of removing the drive that I have found. I think i found a solution:

    hdiutil resize -size <size in GB that u want>g -shrinkonly /Volumes/<path to sparsebundle>
    keep in mind that after -shrinkonly you simply can browse you way to the sparsebundle that is already created by time machine and drag and drop the bundle to terminal, which will type out the path for you.

     

    For example, mine looks like:
    hdiutil resize -size 931g -shrinkonly /Volumes/TimeCapsule/Austin’s\ MacBook\ Pro.sparsebundle
    now it should limit the max size to 931GB on a 2TB drive, limit the other mac to 931GB and they shouldnt fight, i think 2TB is 1863.02GB, so devide by 2 = 931.51 for a 50/50 split, round off the last .5GB from each for a 1GB buffer (maybe should leave more of a buffer?)

  • fane_j Level 4 Level 4 (3,660 points)

    austinfromlenexa wrote:

     

    so far i have tried rm -rf /Volumes/<path> via drag and dropping the bundle to the terminal window which sits there forever doing nothing

    Check ACLs.

     

    $ ls -ael

  • Geer23Mac Level 1 Level 1 (0 points)

    Solved the problem! after a hint by 'nick_harambee', dated Feb 21, 2009 (see at the bottom of: https://discussions.apple.com/message/9036656#9036656) in which he suggested to enable 'guest access' in the Airport Utility tab on the Time Machine..!

    Instead of all failed attempts to change the permissions with 'chflags' (for which you don't have the permission ;-)..

    So, now the whole -unneeded- sparse.bundle can be erased and Time Capsule disk space recovered..

     

    Thanks 'nick_harambee'! for the simple hint,

     

    Gerard