7 Replies Latest reply: Aug 24, 2013 12:42 PM by j3schwartz
gregfromdeep river Level 1 Level 1 (0 points)

I submitted the following on another forum and no one has replied. So, I am giving this forum a shot

 

===========

 

I had been, for years, happily listening to music streamed through four Airport Expresses networked through my iMac and my Airport Extreme. Recently I upgraded Airport Utilities to 6.0 (and lost a lot of functionality in the process) and I upgraged iTunes to 10.5.3. The Airport Extreme and all Airport Expresses were upgraded to firmware 7.6.1. Everything worked fine until one of the Airport Expresses was taken off line (it is on a switched circuit).

 

I tried, in vain, to get iTunes to stream music to the Express once I brought it back on line. Airport Utility reported it was working fine and reception was excellent.

 

So, I unplugged another Airport Express and swapped it with the problematic one. Well, I now had the same problem with a second Airport Express. Airport Utilities reported it working fine but every time I tried to stream music to it with iTunes I got the following message:

 

An error occurred while connecting to the AirPlay device "Downstairs Family Room". An unknown error occurred (-15000)

 

Well, wanting to see if I could repeat the above, I swapped yet another Airport Express. Since it had to go off line for a little while, I now have three Airport Expresses that iTunes cannot stream music to and all give the same error when I select them in "multiple speakers" with iTunes. However, if I unplug the speakers from any of the now problematic Airport Expresses, I get the message that there are no speakers attached. I plug in the speakers and I get the "unknown error" message again.

 

I have no problem streaming music to my Apple TV (I am listening to musing through my Sony TV as I write this).

 

So, in summary, after upgrading the firmware on my Extreme and Expresses, after upgrading to iTunes 10.5.3 and after upgrading to Airport Utilities 6.0, I lose the ability to stream music to an Airport Express once it is turned off for any length of time. Currently, I can only stream music to one Airport Express, the only one that has not gone off line for a while.

 

I am not very upset about the glitch, because I anticipate a solution. However, I miss walking room to room and have my music streamed in 6 different rooms at the same time.

 

Anyone have ANY idea how to get this problem resolved?


AirPort Express 802.11n (1st Gen)
  • luckymotherpucker Level 1 Level 1 (0 points)

    Having the same problem. Hopefully someone has an answer.

  • Joseph Kriz Level 5 Level 5 (5,050 points)

    I am not having the problems you are experincing with the new updates.

     

    I would suggest downloading the 5.6 Airport Utility and trying to setup your Airport Express units.

    http://support.apple.com/kb/DL1482?viewlocale=en_US&locale=en_US

     

    I am not sure how you have your Express untis setup so I would suggest this first.

    Plug in one Express and set it up to "Join" the network.

    Enable Airplay.....

    See if that Express will work...

    If so, configure the rest to "Join" the network and enable Airplay....

     

    Let us know what yoy find out trying this....

  • gregfromdeep river Level 1 Level 1 (0 points)

    I reset one of the Airport Express units and went through set up using Utilities 6.0. All settings were retained after reset. I changed the name of the unit, because I had changed its location. I did a save, the unit restarted and once again I could access with iTunes and stream music.

     

    With another unit that I could not stream music to, I simply renamed it in set up and saved. I could access it as well (I did not have to reset it).

     

    During this reset, the four Expresses took turns going off line and on line, along with the Airport Extreme (the network route diagram showed the going on/off line and changing positions in the network diagram. I started getting worried that the on/off would never end and I would lose everything. After some 5 minutes all Expresses and the Extreme showed they were on line and working normally and lo and behold, I can stream to all 4 Expresses from iTunes. I have NO idea what happened or why units went off/on line repeatedly and why the network diagram shifted. All I know is that everything is working now.

     

    For anyone with the same problem, try clicking on an Express unit, click Edit, rename the unit (just to change something) and save. Maybe your units will again be streamable via iTunes. If I truly knew how I got things working I would explain it. I simply do not know.

  • Joele25 Level 1 Level 1 (0 points)

    I really think Apple needs to start listening to the user again.  The upgrade to 6.0 is a joke.  Now users have even less control of their wireless networks than before.  Not to mention after I upgraded the firmware on two airport express' they vanished from my network.  I had to go physically bring both upstairs to the computer room, manually reset and reconfigure each one from scratch.  They worked fine until the suggested firmware upgrade. 

     

    Also I have noticed if I switch from my Guest Network to my 5Ghz network, sometimes my Airport Extreme is missing saying It used to be part of my network but is now misssing, check to make sure the power cord is connected or its connected to your network.  REALLY???? This version is VERY unstable. If you click back and forth between wireless networks its a crapshoot on what is going to be there and what isn't. 

     

    Seriously, Apple, if your going to tie our hands together and take away all advanced features in the GUI, at least give the optoin to add them back for the IT guys that know what they are doing.  This is terrible.  I wasted over an hour today trying to figure out and fix your screw up.  Thanks.

  • macodnarc Level 1 Level 1 (0 points)

    "I simply renamed it in set up and saved."   Thanks - this simple action also worked for me.  I was starting to get more than a little peeved and had searched several other posts to no avail. 

  • Lane Mcdonough Level 1 Level 1 (0 points)

    This same situation has happened to me on several occasions. I just power off and then on my router. That has worked the last several times.

  • j3schwartz Level 1 Level 1 (0 points)

    I don't know any of you have found a fix, but I've found something that works for me and "may" work for you. On this forum underanother topic (https://discussions.apple.com/thread/5116284?start=0&tstart=0) I posted this:

     

    This solution is provided without warranty and you use it at your own risk! It does require some basic Unix/Linux commandline skills.

     

    Do the following on the system hosting/running iTunes:

     

    Open a terminal and at the prompt type: ifconfig (you may have to type sudo ifconfig)

     

    You should see output similar to this:

     

    system:~$ ifconfig

    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384

              options=3<RXCSUM,TXCSUM>

              inet6 [removed be me for security]lo0 prefixlen 64 scopeid 0x1

              inet 127.0.0.1 netmask 0xff000000

              inet6 ::1 prefixlen 128

    gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280

    stf0: flags=0<> mtu 1280

    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500

              options=2b<RXCSUM,TXCSUM,VLAN_HWTAGGING,TSO4>

              ether [removed be me for security]

              inet6 [removed be me for security]en0 prefixlen 64 scopeid 0x4

              inet [removed be me for security] netmask 0xffffff00 broadcast [removed be me for security]

              media: autoselect (1000baseT <full-duplex,flow-control>)

              status: active

    en1: flags=8823<UP,BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500

              ether [removed be me for security]

              media: autoselect (<unknown type>)

              status: inactive

    fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 4078

              lladdr [removed be me for security]

              media: autoselect <full-duplex>

              status: inactive

    p2p0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> mtu 2304

              ether [removed be me for security]

              media: autoselect

              status: inactive

    utun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1380

              inet6 [removed be me for security]utun0 prefixlen 64 scopeid 0x8

              inet6 [removed be me for security] prefixlen 64

     

    Your first active network interface should be en0. If you have more than one network interface configured you might also have an en1, etc. Basically anything that has an IP address is an active interface.

     

    In my case I have one active interface en0. I fixed the problem by running the following command "sudo ifconfig en0 down" - this will shut down the interface and effectively KILL ALL active and stale connection associated with it.

     

    next I did a "sudo ifconfig en0 up" - turns the interface back on - if your using DHCP you will aquire an IP address or you pick up the a statis IP address if that is how you've configured your network preferences.

     

    You can run the commands on each configured network interface to "reset" it; this procedure should work. I'd love to hear about your (or anybody elses) experience using this solution.

     

    --Jonathan

     

    PS: the links to Apple Support Articles

     

    Error -3256 or -15000 when streaming to AirPort Express base stations using iTunes

    http://support.apple.com/kb/ts2278

     

    although still active, are no longer updated by Apple. I have found that these particular articles were not helpful.