Previous 1 2 Next 17 Replies Latest reply: Dec 9, 2014 7:37 PM by djfromtoledo
kevinfromhunt Level 1 (0 points)

I am getting message that says "Error Reading Settings" when I try to open the File Sharing on Server.app.


Mac mini, Mac OS X (10.7.3), Lion Server
  • td234 Level 1 (0 points)

    Same issue here. Updarted to 10.7.3, stopped File Services to update Drobo, Server crashed, now File Services cannot read settings.

  • thepod7 Level 1 (0 points)

    Did either of you find a fix for this, mine started doing this tonight

  • diffuseuk Level 1 (0 points)

    Ever since I upgraded to 10.7.3 I've had this same problem, no matter what I try I can't solve it.

     

    I've tried everything I've read through the forums, including deleting the com.apple.AppleFileServer.plist file, but nothing seems to work.

     

    If anyone has any ideas on how to fix it, I'd be very grateful. At the moment, I'm using SSH and SFTP to access files off the server, but it's much slower than over AFP/SMB.

     

    Gavin

  • td234 Level 1 (0 points)

    I restarted the computer and my started working.

  • diffuseuk Level 1 (0 points)

    No, sadly that doesn't do anything. I still have "Error Reading Settings" when I go back in to Server.app, with the spinner in the bottom right of the app spinning away saying "Starting File Sharing service", but nothing ever happens.

  • Beno 44 Level 1 (15 points)

    Hi kevinfromhunt,

     

    Try sudo launchctl unload /System/Library/LaunchDaemons/com.apple.AppleFileServer.plist

     

    sudo serveradmin start afp

     

    Suppose it would work with other services as well.

     

    It worked for FileSharing for me.

     

    It appears that 10.7 Lion doesn't unload properly and as it fails loading it cause it's already loaded it fails.

     

    Good luck.

    Beno

  • SergeD Level 1 (0 points)

    Benno44, you saved my day. Many thanks for your post, it solved my problem perfectly.

  • Beno 44 Level 1 (15 points)

    Serge, Might be worth having this post marked as solved. Helps other users.

     

    Beno

  • Interface Level 1 (5 points)

    Thank You Beno 44... Right answer.

  • paulfromburwood Level 1 (90 points)

    Thank Beno, I had this after a 10.7.4 combo update. Solved my problem.

  • RoseValley Level 1 (10 points)

    YEA!!! Bemo 44 you are the MAN!! (or woman as the case may be. <g>)

     

    I had this happen last ngiht and your fix got me running in just a few moments!!! This is going in my book of fixes to remember!!

     

    Thanks,

    Kevin

  • Eric Barbosa Level 1 (120 points)

    I had this exact same issue updating from OS X 10.8 to 10.8.1. Thank you, Beno 44!

     

    Hoping others that have this issue with 10.8.1 find this post.

  • mistersquid Level 3 (795 points)

    Super simple, super sweet. Thank you Beno 44!

     

    After dismounting a volume from my AFP server, I was unable to reconnect to the AFP server and unable to restart the AFP server (w/o reboot). Beno 44's tip seems to have gotten things back in working order.

  • wheezito Level 1 (0 points)

    Beno 44 also resolved my particular issue. Killing and restarting afp seems to do the trick.

     

    I use network based Time Machine to back up several workstations in our lab. File Sharing failed, thus Time Machine failed. I was also getting the "Error Reading Settings" message in Server and the "getConnectedUsers in plug-in servermgr_afp" error message.

     

    One word of caution, however; all was working quite smoothly, until eventually File Sharing failed again, with the same error messages. The second major failure must have occurred about a month later. It is unclear to me what may have triggered it. If anyone has any ideas, please post.

     

    Kudos to Beno.

Previous 1 2 Next