8 Replies Latest reply: Feb 24, 2012 2:16 AM by BDAqua
TigersRog Level 1 (0 points)

I have a 1GHz emac upgraded to 10.5.8 in order to sync with current iTunes. Since the update, the CD tray no longer opens using the key on the keyboard. Neither will it eject using the symbol at the top of screen. It works if I hold down the mouse button on restart and discs in the tray work fine?

 

Any ideas?


eMac (ATI Graphics), Mac OS X (10.5.8)
  • BDAqua Level 10 (122,227 points)

    They increased the time you have to hold the eject or F12 button down before it takes note, did you try longer?

     

    Does iTunes>Controls>Eject Disc work?

  • TigersRog Level 1 (0 points)

    I haven't tried within iTunes but I suspect it will work that way. Certainly, dragging a CD to the trash causes the tray to open. The problem is opening the empty tray in the first place. The only way to do that is to hold down the mouse button during startup.

    Looking through the archive it seems this problem was discussed a couple of years ago and at the time the only 'cure' was not to update an eMac past 10.5.6. I was rather hoping somebody had come up with a more satisfactory solution.

  • TigersRog Level 1 (0 points)

    By the way, under the eject symbol at teh top of the screen it says 'No Disc'. The problem is opening the empty tray.

  • BDAqua Level 10 (122,227 points)

    My eMac 1.42GHz is at 10.5.8 & ejects/opens empty fine, so does my eMac 800MHz with 10.5.8.

     

    Let's see if Terminal commands can do it then, open Terminal and try these 2 commands with ENTER after them...

     

    drutil tray open

     

    drutil eject

     

    Oh, does Does Utility work to open it?

  • Matthew Knice Level 1 (70 points)

    Does the Drive show up in System Profiler? (I had this problem when the original ComboDrive failed in my 700MHz (now 900MHz) eMac first generation—In fact the ATA bus didnt even show up. But this is common I take it as my G5 Tower if there is no drive in the secondary bay, (second HDD slot) the SATA bus doesnt show up in System Profiler. So if the Drive is dead, the ATA bus may not even show.

  • TigersRog Level 1 (0 points)

    Tried that with no success. BTW, I might be thick but should I have actually typed the word 'ENTER'? I didn't.

  • TigersRog Level 1 (0 points)

    Yes, the drive shows up in system profiler.

     

    Looking at some archived discussions about the same issue, I think the 'solution' is only to upgrade to 10.5.6. The problem seems to occur with 10.5.7 and 10.5.8!

  • BDAqua Level 10 (122,227 points)

    Sorry for any confusion, not type ENTER, just git the ENTER/RETURN key.