9 Replies Latest reply: Jan 26, 2013 4:06 PM by Vitor42
AndrewG7862 Level 1 (10 points)

Hi,

 

Does anyone know how to change the default sorting method for all items in iTunes?  I use the third option for organizing the library as a whole (the one that has a list of icons for bands that you double click to show only that band's songs).  The only sorting method I use is to sort by Album by Year (ascending), this makes the most sense to me.  I can tell that iTunes is attempting to remember when I do this for certain artists, but it epically fails at maintaining this sorting pattern.

 

To be clear, say I open Radiohead and click through to have it sort with the above method.  Everything works great, but when I return a few days later to play Radiohead again, the sorting is not maintained.  It could be as simple as sorting in a descending direction, or could even be trying to sort by the number it was added in my library.

 

I'd really appreciate it if someone knew of a way (maybe even through scripts if possible / the only solution) to eliminate this problem and have every (NOT just the artists who I've told iTunes to sort a specific way) artist sort that way.

 

I don't know if my copy is just corrupt?  It may be, since for some artists it's started playing them in the above mentioned order they were added to my library even if I force a sort by album by year (i.e. it will go from playing a 2007 album to a 2002 album and not the 2008 album).

 

Thanks!


MacBook Pro, Mac OS X (10.7.3), 2.2 i7, 4GB RAM
  • AndrewG7862 Level 1 (10 points)

    To add more details:

     

    I have the latest version of all software, and this problem has been occuring since the beginning of that song sort method (where you can sort by artist album covers).  This has been the case on my current MBP (purchased in August) and previous MB (1st gen., purchased August 2006).

  • sanjampet Level 5 (7,760 points)

    you can go to iTunes, view, and see if there might be something that works better for you

  • AndrewG7862 Level 1 (10 points)

    Thanks for the reply.  Unfortunately there is nothing under the View menu option that comes close to setting a default sorting.

  • sanjampet Level 5 (7,760 points)

    Andrew, Go Itunes, click on file>library>organize library.

    Them go to view and check album art.

     

    Maybe this might be of some help.

     

     

    Goog Luck

  • AndrewG7862 Level 1 (10 points)

    Hey sanjampet,

     

    Thanks for the suggestion.  iTunes has always had the "Keep iTunes Media Folder Organized" option selected in the "Advanced" preferences pane.  I'm not sure I want to tell it to organize again at the risk of having data duplicated.

  • sanjampet Level 5 (7,760 points)

    Andrew,

     

    If it does duplicate, you can always clck find duplictaes and delete them, or buy tune up, which works ok.

     

    Yes the mp3 files do sound lousy. If you have any commecial CD's, load them into garage band, and you can burn them at 48K/196K which is higher than commercial CD's of 44.1k.

     

    Best of luck, just trying to help,

    Peter

  • UMjams Level 1 (0 points)

    Andrew, I know I am extremely late to the party but I too use Grid View.  I had the same problem that you had but have found this to work for me.  I used it and it is still holding as my default sorting even after switching between the Artist page and Grid View.

     

    Once you are inside of the Artist page continue to click on the Album column until it shows Album by Artist/Year.

    That will give you each album sorted by the year instead of it randomly sorting it for you each time you leave an Artist's page and then back again.

     

    Hope this helps.

  • lunat1k Level 1 (0 points)

    Thanks! That really helped.

  • Vitor42 Level 1 (0 points)

    On artist page, I go "View > View Options" then I choose "album by year" and that's it, it never gets out of this sorting unless I choose another option.