Previous 1 2 3 4 Next 58 Replies Latest reply: Nov 21, 2015 1:51 PM by rfdsteve Go to original post
  • spma3 Level 1 Level 1

    Just an update. I did reinstate my routers firewall with it not affecting the connection to Home Sharing. This was expected as that is the point to enabling port forwarding.


    After two and a half weeks using this configuration I have not had anymore issues with Home Sharing. It just didn't create a work around for Apple TV but also Home Sharing overall. I can see the shared library on my wireless iPad and iPhone from the iMac.


    Hopefully this has created a work around for you as well.

  • spma3 Level 1 Level 1



    Were you able to get your wireless connection functioning with the work around initated? Interested in knowing.

  • BigN Level 1 Level 1


    Many thanks for your follow up enquiry. As things stand, all my router port forwarding settings have just been restored to defaults for the time being! This for several reasons:-

    1. I believe the ATV3 higher resolution Apple TV model is due for imminent release. I think I'll maybe go for broke and upgrade as soon as it is available here. Hardly a high cost item.
    2. I remain forever optimistic that given the high level of Home Sharing problems reported by the user community, surely Apple must introduce a fix at some point? Or am I being naive?
    3. But the main reason here is that I now have all the equipment and cabling to completely rework my entire home theatre and Sonos audio installation downstairs. Time spent frigging around with the finer points of ATV2/Home Sharing is just an activity trap. It is detracting from the serious and somewhat unpleasant task of crawling under the floors to install the many cables, a key part of this big project.

    So in a nutshell, my router changes are on hold right now. I remain very positive though that your own experience over some weeks now suggests you have a viable workaround. With hindsight, and since I had rebooted the RVS4000 after the port forwarding tweaks, I think that had I also simply rebooted both WAPs at that stage, all would probably have been fine.


    But I was short of time, and simply restored settings and rebooted both the router and WAPs, whereupon everything reverted to its pre-tweak state. I'll try again ASAP, but you will understand that this is now well down my priority list until my new installation is all wired in and fully operational. Should be OK, as most of it has been mocked up here in my Computer Room, with all network settings etc configured, AV Receiver settings selected and so on. Basically it's now just a big task to run in the wires, dismantle the TV Equipment and Audio Equipment Stacks, relocate everything downstairs to its final resting place, and hook it back up to the new cables.


    I will advise once I have spent time on this again. Meantime your continued interest and advice is much appreciated.



  • spma3 Level 1 Level 1



    Yesterday, Friday March 9th, 2012 Apple released a software update. Prior to this update the settings I have shown in this thread worked flawlessly. Once I received the notification that an update was available, my Apple TV went back to giving me problems. Even without implementing the software update, Apple changed something. Since It wouldn't hurt, i implemented the software update. To my surprise and relief, my Apple TV went back to working flawlessly again.

  • DrewInTheUK Level 1 Level 1

    The latest update (iOS 5.1?) fixed my longstanding issue with home sharing not working over Ethernet. Thank god.

  • BigN Level 1 Level 1

    FWIW I upgraded my ATV2 firmware on the day of its release. A very quick, and I admit unscientific, test suggested my Home Sharing problem remains! I have not implemented spma3's fix at this time. But I am encouraged by his finding that this fix still worked with his upgraded box. Did you update your iTunes first to cause your problem to reappear?


    DrewInThEUK says for him the upgrade alone was enough, but I don't think he was meaning with an ATV box.


    I have just spent most of the weekend under the floors here, a most unpleasant task. I was pulling out the old and running in all the new A/V, network, aerial feeds and speaker cables needed for my new home theatre + Sonos installation. All now in place, there is no way I am going to waste any time on Home Sharing right now. Want to get everything else up and running ASAP. But I do now think I will go for broke and just buy an ATV3 to get 1080p. Will help to keep SWMBO happy! Will continue to monitor this thread for developments!

  • BigN Level 1 Level 1

    OK spma3. After a successful day with my A/V cables yesterday, I had a bit of spare time today. Decided to try out your fix, this time in a more controlled fashion. Changed my Cisco RVS4000 Single Port Forwarding settings exactly as per our earlier discussion.


    Rebooted the router, and both access points. WiFi access restored, no problem.


    PC1. Turned off Home Sharing on iTunes, and then reactivated it, using the same User ID & Password as on my ATV2. Shared Computer now shows as expected under Computers on the ATV2. And I can start music playing off PC1's library. It ran for about one and a half tracks. Then just stopped.


    PC2. Repeated the above. This time I was able to play a different album off PC2's library. Ran for one track (4'10") plus part only of a second track (41"). and then just stopped.


    Repeated this exercise several times. At no time was I able to get Home Sharing to stay on for as long as 5 minutes.


    CONCLUSION Your fix has not changed anything for me, unfortunately! The ATV2 does everything as it should, but just not for very long at a stretch, and it needs messing with Home Sharing On/Off to restart it each time. Not impressive, but consistent with the problems I had with my previous Airport Express boxes. And with countless other unhappy users it would seem judging by the countless posts.


    I really belive that Apple needs to get a grip with this and fix it once and for all IMHO!

  • SeanHen Level 1 Level 1

    smma3 - this is awesome as I was on the phone with Apple and Comcast today trying to explain to them the issue.  Needless to say... neither had a clue.


    My ideal setup for my house is:

    MacBook - ethernet connection

    iMac - ethernet connection

    ATV2 - wireless (I can't get a cord there)


    The iMac is in a place in the house that doesn't get good wireless signal and more important than the homesharing was connecting to the wirless printer in the office. Your prt forwarding fixed that as well as the homesharing.


    I would like to put the MacBook on ethernet because I can and when I went in to the setup to add the port forwarding rules in addition to the (iMac) rules I got the following error:


    Add/Edit Port Forwarding Alert:

    Duplicated WAN Port Range!


    Does this mean that I can't add the same prt forwarding rules for another device connected via ethernet?


    I am a bit confused and please note that this is a bit different with the ATV2 on wireless and the two computers on ethernet.



  • spma3 Level 1 Level 1



    Well, sorry it didn't work out for you. Sounds like possible DNS issue. With all the time you have put into trying different settings, it's unfortunate that it doesn't work. Hopefully there will be some setting that comes along that clears it up. Good luck.

  • spma3 Level 1 Level 1



    I was thinking I can't be the only one with Xfinity and an Apple TV2. Yeah, that's what it means. You shouldn't have to port forward the MacBook or the iMac.


    For your AppleTV2, why not use devices like NETGEAR 85 MBps Powerline EN Switch Kit which uses your homes electrical wires as Ethernet cables? That's what I use for the connection to my iMac and it works great. Look it up, not too expensive either.

  • SeanHen Level 1 Level 1

    spma3 -

    Two thoughts... one is a question: Can I use one of those devices with a device similar that I'm using to transmit the phone line throughout the house?


    2. Regardless of the ATV2 I need port forwarding on the iMac that is out of wireless range because as soon as I put it on ethernet it can't 'see' anything else on the network, most importantly my wireless printer. 


    There seems to be an issue with the Xfinity device and mixing ethernet and wirless connections... yes?


    Any thoughts? 



  • spma3 Level 1 Level 1



    I haven't heard of a device that uses the phone lines for transmission. These devices are sold in pairs, plug it in to a power outlet, use a CAT-5 or CAT-6 ethernet patch cable from the device to your Apple TV and one to your router and thats it.


    You should be able to see your wireless devices if they are on the same network. Maybe try setting up the printer with a fixed IP address instead of allowing it to get an IP address from DHCP. That way you can always point your iMac to that specific printer address. You would also have to set up the printer with the same ip address. Also, I know my iMac can have both a fixed IP address AND have Airport on using wireless at the same time. I wouldn't recommend it as there will ultimately be issues but its worth a try.


    At first glance I thought there was an issue with the Xfinity router and mixing ethernet and wireless but since I configured my settings this way, I haven't had any issues with it.

  • BigN Level 1 Level 1

    Update. Tried the suggestion from A-jai07 on 18th December to be found in thread #2613875. He links to a suggested change to AVG Firewall rules for iTunes. This is relevant to me as all my PCs run AVG Internet Security. The instructions (by AVG's Phil Halton) spell out in detail how to set rules for specific ports to suit iTunes & HomeSharing.


    So I went ahead and set up rules iTunes1 & iTunes2, exactly as he stated for the relevant firewall profile. And suddenly everything is so much better! Music successfully streaming from either PC Music Library by Ethernet thru the ATV2 to my Yamaha RX-A1010. With no constant stoppages as previously. Also, my wife's iPad2 AirPlay Mirroring is working without dropping off. Progress indeed. And I still need to upgrade it to iOS 5.1!


    But unfortunately not quite out of the woods yet! For the first time I have now had "An error occurred loading this content. Try again later" from the ATV2! And surprise, surprise... this bug is the topic of numerous threads too, including #2794045.


    I remain optimistic that perhaps a future release of iTunes/ATV software will finally address HomeSharing instability once and for all. When it works, it's excellent! I also had problems with AEX boxes, and finally gave up on them. But I'm going to give Apple the benefit of the doubt, and buy an ATV 3rd Gen to get full 1080p resolution for my HDTV. I will also retain the ATV2 for the smaller TV in my Computer Room, as it's bought and paid for. I will simply keep my fingers crossed that by the time I get my new home theatre and Sonos kit all in its final resting places that Apple will finally have addressed these annoying bugs that seem to affect a lot of their customers!

  • spma3 Level 1 Level 1

    BigN - Great to hear that you have narrowed it down to being a firewall issue and hopefully you can get the other error to go away.

  • BigN Level 1 Level 1

    OMG spma3, that was a quick reply! Anyway I was off downstairs telling SWMBO about my apparent success, and when I got back the new error had happened again! I am not going to waste any more time on this, as it is an activity trap keeping me from final installation of a lot of shiny new hardware. Need to roll up my sleeves and get on with it! Surely Apple has got to fix this?