Previous 1 2 3 4 Next 58 Replies Latest reply: Nov 21, 2015 1:51 PM by rfdsteve Go to original post
  • spma3 Level 1 Level 1

    Its gotten a lot of attention lately so I do hope they trace down why data flow is being disrupted and tighten things up.


    Thought about the "error loading this content" and it sounds like iTunes isn't able to authenticate the material you are asking to play. I got this error when even though I bought a movie through iTunes, I had issues downloading it successfully. When it finally downloaded, I could watch it on the iMac, sync it up with my iPad and iPhone and watch it there but I couldn't watch it on the ATV. I looked at the properties of the movie and the certificate of authentification looked different than the other movies that would play ok. I contacted Apple and they suggested I delete the movie and since I purchased it through iTunes, they placed the download into my account again. Downloaded it successfully the first time and it now plays over ATV. Do you get the error with all of your content?

  • BassetBoy Level 1 Level 1

    After updating the ATV2 firmware to 5.0 and iTunes to on my XP and Win 7 PCs, The ATVs and iTunes no longer saw each other for AirPlay. The ATV could get to the internet with no problem but saw no computers. I am using wired ethernet, I could ping the ATV from the PCs. After reading this thread I turned the Windows firewalls off and suddenly everything worked!  I then created an exception for port 3689 UDP in each firewall and turned the firewalls back on and everything still works.


    I believe Apple changed something i.e. TCP versus UDP and neglected to modify the uPNP code in iTunes to open the firewall to match.  Obviously, I don't care anymore if Apple fixes this. but for a company which is characterized by "it just works" this is a huge black eye. When it doesn't "just work" it is a real bear to solve.

  • markgro Level 1 Level 1

    Interesting collection of solution steps.  I have 2 Apple TVs on my network, one is an Apple TV2 and the other is an Apple TV3, and an xfinity router.  I have the same problem that everyone else is talking about, with the Apple TVs losing connectivity to home sharing.


    While I won't dispute that you seem to have gotten things working, I question changing the protocol scheme for port 3689 from TCP to UDP.  If you have any experience with network tracing/sniffing tools (Microsoft Netmon being one example), it's easy enough to sniff the traffic on your network between the Apple TV and the iTunes library host computer.  If you do this, you will see all sorts of communications from the Apple TV to the iTunes host system using a destination port of 3689.  In no case will you see communications destined for that port that uses the UDP protocol scheme.  It's all TCP.

  • bcassels12 Level 1 Level 1

    Thanks for taking the time to share all this info spma3!  I was having tons of problems trying to get all my devices to communicate and this did the trick. 

  • Pacaguy Level 1 Level 1

    SPMA3,  your posts are fantastic!


    I have found that by rebooting the xfinity router, ATV works FOR A WHILE.  Clearly, there is some interaction issue between ATV and Xfinity server.



    I have an idea.  Apple must have a lot of customers who use Comcast.


    Why doesn't somebody from Apple pick up the phone and team up with Xfinity till this works seamlessly?


    It would be good for both Comcast and Apple.

  • Mike3020 Level 1 Level 1


    I just moved from DSL to Comcast Xfinity, and I had to take their crappy wireless router in order to have phone service. 

    This router is a AOC DE58

    The port forwarding instuction you offer do not appear to match this modem choices.


    My D-link was working before Comycast showed up.  I even attempted to copy those settings to this screen without any luck.

    Screen shot 2012-06-23 at 10.29.54 AM.png

    The D-Link only needed these settings for in this case the iTunes service device which is my iMac.


    Do you have any suggestions for me ? 

  • Mike3020 Level 1 Level 1

    Updating information I provided earlier

    The Xfinity router is a SMC DE58

    Attempting to follow spma3's instructions for port forwarding for what seems like hours.


    Everytime I would put in all the ports in the port forwarding section and reset the router, all the changes I made were gone.  I repeated this a number of times, and I was expecting something possitive to happen and it... didn't.


    I called Xfinity - Comcast support, I was finally transfered to Signature Support and the call was dropped after 26 min on-hold, when I did get reconnected, I find out this is a paid support service. But as I'm a new customer with 30 days to cancel my service, I played that card. 


    This is what I learned, Xfinities wireless router may have "Port Fowarding" but they do not support this function. If it works great, if it doesn't don't call us.


    All Comcast is supporting, is "Internet Access".


    Here's my screen shot of hours of "Port Forwarding" efforts...  It only shows port 80 as open, yet when I scan for open ports it never shows up.

    Screen shot 2012-06-24 at 9.24.48 AM.png


    I could go on with all the details, but the bottom line is Comcast/Xfinity will not support your network needs using Comcasts equipment.


    Please note, I have no definitive methods to totally blame Comcasts router, but It all worked with D-Link DIR-655 wireless router and very simple port forwarding.

  • spma3 Level 1 Level 1



    Looks like you have the port forwarding set up right. If you only have one Apple TV, give it a static IP address like you did for your Mac and your port forwarding should point to the ATV address and not your Mac.


    I have been having to make changes recently to my configurations because Apple is attempting to fix these problems. One in particular is the changing the port type for Port 3689 to TCP. TCP is more secure and faster than UDP.


    Recently, I added another ATV (3rd gen) to my household and that has caused quite a few problems. Port forwarding can only be done to one IP address and in my particular case it was my ATV (2nd gen). When I would attempt to wake up and watch anything on the ATV (3rd gen), it wouldn't receive any communication because the port forwarding was to the other ATV. I would have to perform a reset (hold the menu button and push the down arrow on the remote) to get the ATV (3rd gen) to recognize my iTunes Home Sharing Library. It would then work just fine until the unit went to sleep. To temporarily fix this issue, I have changed my ATV (3rd gen) to never sleep. My ATV (2nd gen) does go to sleep and wakes just fine remaining connected to my library.

  • spma3 Level 1 Level 1



    Once you enter the port forwarding changes ( looks like we have the same router from Xfinity based upon your screen captions), don't RESET your router. Resetting will reset it to the factory settings which will remove all your changes. (I believe the terminology is correct about resetting. All we are looking for here is to reboot the router and not reset it to its original factory settings).


    Xfinity customer support is just somone with a book in front of them with questions to different scenerios. The person really doesn't know what they are talking about.


    Remember your Mac's hard drive can't go to sleep and your need to have iTunes open for Home Sharing to work. You can have your screen go to sleep but not the hard drive.


    Hopefully this helps you to get it to work.

  • spma3 Level 1 Level 1



    Thanks. Yeah there is something with Xfinity's router that does not allow multi broadcast information which Apple's servers are sending. People with Apple's Airport Express and some other router manufacturers have better luck because these devices support multicast. The method that has worked for me is using port forwarding.


    It would be great if Apple and Comcast could do that. I would just be happy if Apple could eliminate the need for any configuration changes but after a couple years now of many people having the same problems, I just don't see that happening.

  • spma3 Level 1 Level 1



    Thanks for the inquiry. All I can say is that when I originally posted that information, changing port 3689 to UDP made my configuration work. Now....since that post, I too added an ATV 3 and was having issues. I changed the port back to TCP along with some other changes and I was able to get it to work again.


    Part of the issue is Apple is attempting to make changes on their part (on their servers that do not come out as part of an ATV update) and this causes our connections to automatically not work (or in some cases TO work) one day.

  • spma3 Level 1 Level 1



    Good to hear that it helped out and you were able to get it to work.

  • Scgoan Level 1 Level 1



    I can't express enough how happy that I stumbled across this thread. Last March, I purchased the "New" iPad and AppleTv. For these last four months, I've had an issue with my iPad connecting to the AppleTv. To get AirPlay to function each time, I had to go into settings and turn off and on wifi. Then and only then would the Airplay icon appear for a few moments. This morning I was searching for the ports that the AppleTv uses and I came across this thread. I'm positive that you have helped out a lot more people than you know. I'm sure many people don't take the time to post when they find a solution that works. Thank you from me and all of those that don't post.

  • spma3 Level 1 Level 1



    I'm glad you were able to find this thread and have it work for you. Hopefully you are right that it has helped more people. There are many that continue to blame the most recent iTunes update or the Apple TV update for the reason that their Home Sharing doesn't work anymore. I continue to update away and use the product as it was intended due to port forwarding.



  • Scott Cooley Level 1 Level 1

    Any updates on this? I've been having an issue for the past couple of weeks and can't seem to get home sharing up and running with my Xfinity wireless router.