6 Replies Latest reply: Feb 20, 2013 8:34 PM by Sam_id
m0jz3s Level 1 (0 points)

hello,

 

I have a problem with downloading dmg files. If I try to download .exe files (or any other) it downloads with no problem, but with dmg files, it just comes to 99.9% and doesn't move.

 

thank you

 

n

 

/___sbsstatic___/migration-images/176/17626311-1.png


MacBook Pro, Mac OS X (10.7.3)
  • Carolyn Samit Level 10 (103,365 points)

    Hi ...

     

     

    Go to Safari > Preferences then select the General tab

     

    Select:  Open "safe" files after downloading

     

    If that box was already ticked ..

     

    Go to ~/Library/Safari

     

    Move the Downloads.plist file from the Safari folder to the Trash.

     

    Relaunch Safari.

     

    .exe files? That's a Windows executable file. Can't be opened on a Mac unless you have a Windows partition or VMware.

  • m0jz3s Level 1 (0 points)

    um.. I already tried that, but it sill dosent work.

     

    I know that .exe files are for Windows I just tried downloading something else to see if its the same for all files i try to download.

  • Carolyn Samit Level 10 (103,365 points)

    In the future, please tell us what you have tried that didn't work... saves time and efforts on your part as well as ours.

     

    Downloading an .exe file won't open regardless so it doesn't make for good "test" download.

     

    Where did you download the .dmg file that won't work?

     

    Please post the link in your reply.

     

    If it's the Team Viewer site, try contacting the developer for help here >   http://www.teamviewer.com/en/company/index.aspx

  • m0jz3s Level 1 (0 points)

    Sorry for that.

     

    The problem here is not with opening the dmg files but with downloading them.. even if I try to download a .zip files or .rar files I have no problems, just the .dmg files.

  • m0jz3s Level 1 (0 points)

    so..

     

    Yesterday I installed (clean install) Mac OS X Lion on my MacBook Pro 17-inch early 2009. I tried to download the latest update for Lion (10.7.3.) and it stopped at at 100% and didn't want to finish the download. So I went to my neighbour and downloaded the update and install it without any problems.

    Then I went to http://www.teamviewer.com/en/index.aspx and tried to download the program and again, as with the update it just stopped at 100% and didn't want to finish.

    Again I went to my neighbour and downloaded TeamViewer (on his computer - windows) and install it. Then I tried to download PS3 Media Server (https://code.google.com/p/ps3mediaserver/downloads/detail?name=pms-macosx-1.50.1 .dmg) and again it didn't work. I logged into my computer at work (through TeamViewer) and try to download the PS3 Media Server, it downloaded without any problem from the same site.

  • Sam_id Level 1 (0 points)

    Hmm.. I am having the same problem with downloading .dmg files since I bought my Mac in 2010. I did not have any speed downloader, igetter etc for removal, so something else is conflicting with the software / programme.  All these times, I have to download it through my windows laptops and then transfer to my Mac if I need to update any software or download new ones.  A solution to this would be great. Thanks