Skip navigation

Always get non-secure Jabber login warning for Google Talk

14168 Views 5 Replies Latest reply: Jul 24, 2012 2:53 PM by *Marc RSS
rjedsm Calculating status...
Currently Being Moderated
Feb 18, 2012 4:03 AM

Been using my Google Talk jabber account for years with no problem in iChat. Installed the Messages beta and now I can't connect.

 

The Google account is displayed as Offline. When I select Available I get the following message:

 

"Non-secure Jabber Login

Your name and password will be sent in a way that is not secure.  Do you still wish to connect to this server?"

 

I have tripled checked the settings and it simply won't connect. Also have tried this from several different networks. Still won't connect securely. I have NOT gone ahead and allowed non-secure connection.

 

I have gone into Messages prefs and clicked the "Use Default Settings" button on the pane for my Google Talk account. No good.

I have two-step verification turned off for the particular Google account I am using.

I have not yet tried deleting the account in Messages and re-adding.

 

Suggestions?

Messages Beta, Mac OS X (10.7.3)
  • David in LA Level 1 Level 1 (0 points)

    I was having this problem also. I went to Preferences, Accounts, Google Talk, Server Settings, and then I clicked SSL. That seems to have fixed the problem. Hope this helps

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)

    HI all,

     

    Those instructions are for iChat 3 (when they added Jabber as an option but not Google)

     

    Google do not follow the naming convention of other Jabber Servers.

    Therefore in iChat 3 the pulled the @gmail.com  (or @googlemail.com) from the User ID as the server name.

    Google as you have found use a server called "talk.google.com".

     

    Later versions of iChat and the Messages Beta allow for this server naming issue by having the Google Set up option in the Add Account pane.

     

    The port is usually port 5223 with SSL turned On (It does not work without SSL)

    It can be changed (whilst logged out) to port 443 which also works.

     

    I am finding it hard to see why something that was set up and working in iChat 6 did not make the cross over to Messages  beta correctly. (other than it is a Beta)

     

    Is it possible that this particular Google account set up was an iChat 3 one that has been migrated across computers til now ?

     

     

     

     


    8:50 PM      Sunday; March 11, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • econ-mit Level 1 Level 1 (10 points)

    Had the same issue. Oddly on one machine but not others, so this must be a glitch with older account settings as Ralph suggests.

     

    Finally, figured out a solution: under Accounts>Server Settings uncheck "Automatically find server and port" then check SSL and change Server name to talk.google.com (keep the port at 5223). Keep warn before sending password insecurely!

     

    Works fine for me now.

  • *Marc Level 1 Level 1 (10 points)

    Same issue here. Your solution worked perfectly. Thanks.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.