Previous 1 2 3 Next 30 Replies Latest reply: Aug 10, 2014 5:48 PM by cariann40
lovesickfret Level 1 (0 points)



For some reason my iPhone has synced music that will not be removed from my iPhone. These items appear greyed out on my iPhone, but do not show up in iTunes when I plug my iPhone in (For instance, Coldplay's album "Viva La Vida," appears on my iPhone greyed out, but iTunes shows that no such songs exist on my device). Similarly, some items are also greyed out in iTunes when I connect the iPhone (coincidentally, all items I bought from my account on my iPhone). If I try to delete the greyed items from my phone in iTunes, they appear to delete, but later reappear - and never leave my phone.


Image of greyed songs on iPhone:



Image of songs greyed in iTunes:

Screen Shot 2012-02-18 at 7.01.36 PM.png

These songs will not be removed from my iPhone. Even if I delete my entire library from my iPhone, these songs remain.


Conveinently, all of the songs that will not delete are items that my sister has bought on her account, and my iPhone constantly asking me for my sister's iTunes password any time I connect my iPhone to my library. Surely these issues are connected. I have deauthorized my sisters account from my computer, and have tryed every possible method of removing these songs. I don't want my iPhone to have anything to do with my sisters account - how can I make it forget her account? I have tried every way I can imagine, including removing my entire library of music from my phone.


I am relatively savvy with iTunes and the iPhone, and cannot seem to fix this by any method. Is it something to do with iCloud?

  • randers4 Level 9 (62,715 points)

    Saw a similar post recently and it was solved by signing out and back in to the Apple ID on the iPhone (Settings>Store>tap ID shown, sign out, sign back in) and resyncing with iTunes.  See  Perhaps this solution would work for you too.

  • John Fitzpatrick Level 1 (0 points)

    Found this info here, but not sure if it will help you or not.  I am facing a similar situation that I have not eradicated just yet.



    Songs purchased from multiple Apple IDs

    Songs containing DRM (Digital Rights Management) may not appear, or may appear grayed out in iCloud. This can occur if your computer is not authorized for playback of that content. Try authorizing your computer, then manually update iTunes Match.

    1. To determine what Apple ID your computer needs to be authorized for, locate and select the song in your iTunes library.
    2. Choose File > Get Info.
    3. In the Summary tab, locate the Account Name field in the right column and write it down.
    4. Click OK.
    5. Choose Store > Authorize this Computer.
    6. Type in the account name from the Summary field and its password. Click Authorize.
    7. Choose Store > Update iTunes Match.

    Check iCloud Status

    Check to see the iCloud status of your songs. Choose View > View Options and enable "iCloud Status". iCloud status will help you to determine whether or not a song was purchased from the iTunes Store, matched, uploaded, or ineligible for upload. Items may not be eligible for upload if:

    • The item was purchased outside of the United States iTunes Store.
    • Your computer is not authorized for playback for that item.
    • The music video was not purchased from the iTunes Store.

  • savage panda Level 1 (0 points)

    I'm having problems with songs I downloaded on computer and tried to transfer to phone.  The "ghost" songs I'm seeing on my iPhone have a symbol on them that's a circle with a square in the middle, looking like a stop button.  they are a duplicate for working tracks.  Is this similar to what you saw?  I'm able to click on them, but the song doesn't play.  The time stays at 0:00.


    1.  I can't swipe to delete like other tracks.

    2.  I need to go into iTunes and check the manual load section.

    3.  In some cases, the original download of the track on my laptop had an error, and created the issue on my iPhone.  However, I don't think I've had a problem with all the tracks coming up with this icon.

    4.  I've tried deleting the working tracks, syncing and then reloading...but the working tracks don't delete.


    Any ideas?

  • savage panda Level 1 (0 points)

    Here's a screenshot.


  • youarethegirl Level 1 (0 points)

    My iphone did the exact same thing, and I tried almost everything I could think of to fix it, except one other thing- and it was so simple too.


    1. Go to the itunes app on your iphone

    2. Go the "More" tab

    3. Go to "Downloads"

    4. Delete them there



  • savage panda Level 1 (0 points)

    Thanks. Unfortunately, I don't have anything showing up in Downloads. Any other suggestions? This is frustrating!

  • youarethegirl Level 1 (0 points)

    Oh wow, I don't know then. I had bought music on iTunes from my computer and synced it to my iPhone, just like you did. And I was able to delete it from the downloads tab on my iTunes app.


    Sorry :(

  • James1098 Level 1 (0 points)

    I got them to come off of mine by turning off ICloud,  Resetting my Iphone and Resyncing it restoring it with the Backup off my computer.  Then Synced Music using sync only selected songs and videos.  I only have the ones I purchased on my Iphone now.  It works.

  • 919 Wines Level 1 (0 points)

    I found that by un-selecting the track in iTune Library on the computer, then synching, the problem was bizarrely fixed on the iPhone. Strange, but true.

  • Peter_Smith Level 1 (65 points)

    Yes! This solved the problem for me.


    In my specific case, I had both a song as a regular non-grayed out playable entry, and as a grayed out non-playable entry. I also use iTunes Match.


    Now, after unchecking my problem is solved!

  • 919 Wines Level 1 (0 points)

    In addition to my post above:

    If there are two copies of a song in the iTunes library, select only the non-MP3 version. If there is only one copy and one is an MP3 it transfers OK.

    So maybe there is a coding problem when you ask the song to be converted into a compressed version and it encounters an MP3 version already existing.

    I have successfully converted AIFF, AAC and WAV formats ok, it's just duplicated MP3s giving the problem.

  • evela2006 Level 1 (0 points)

    Hi lovesickfret. Here is the answer.


    I think you will need to acces your sisters account (and her PC) again

  • NissiO.M Level 1 (0 points)

    I had this problem early on with the "greyed out" songs in a certain playlists, and when I disabled iTunes Match in the music settings, and then re-enabled it everything was refreshed in the "greyed out" songs disappeared.

  • MrAndrade Level 1 (0 points)

    Ok this is what i did, and worked like a charm:


    On iPhone go to settings

    then music

    put itunes match ON

    show all music ON

    check the songs on Music app

    back to settings

    show all music OFF

    itunes match OFF

    back to music app


    no more ghost songs... at leats it worked for me, i hope it's of some help to you too

Previous 1 2 3 Next