9 Replies Latest reply: Jun 21, 2012 3:01 PM by batsmil
abmedic Level 1 Level 1 (0 points)

Hello all.  I'm having difficulties accessing files stored on a Synology DS1511+ NAS.  Problem description is below:

 

BACKGROUND:

I have a late 2009 27-inch iMac, and an early 2010 MacMini, both running Snow Leopard.  For years I've been using a D-Link DNS-323 NAS to stream movies and TV Shows over PowerLine Adapters (200 mbps adapters) to both computers, as well as to a Windows laptop.  Recently I decided to upgrade to a Synology DS1511+ 5-bay NAS.  I've populated four of the drive bays with Western Digital 2TB hard drives, and set up a Synology Hybrid RAID array.  I'm in the rather lengthy process of copying close to 2TB worth of data files (photos, music, .avi, .mkv, .m4v, etc.) from the DNS-323 to the Synology DS1511+.  Incidentally, I'm using Ultracopier to assist with copying this huge volume of data, as the Mac copy utility wasn't adequate (Ultracopier is a reasonable facsimile to the Windows program Teracopy). 

 

THE PROBLEM:

I'm mounting the Synology DS1511+ volumes on the iMac and MacMini using AFP, and I'm able to access and read the folders on the Synology drive mostly without a problem (I've copied about 1.5TB so far).  However, after copying movie files to the Synology DS1511+, I'm unable to access certain files using my MacMini or my iMac.  The files show up in the Finder window, but certain files are "grayed out" and I'm unable to copy them back to the iMac/MacMini.  For example, one movie file I wanted to copy back to the iMac so I could convert it to be played on an iPod.  But the particular movie file was "grayed out" and I was unable to copy it back to the iMac.

 

The error message reads "One or more items can't be copied to "Desktop" because you don't have permission to read them.  Do you want to copy the items you are allowed to read?"  But when I click "Get Info" under "Sharing & Permissions" it reads "You have custom access" and then says "everyone" has "Read & Write" privileges.

 

I went into the Synology NAS tools and verified that the volume has full read & write permission for all users & groups (thus far, there is only one user - "admin" and no groups...).

 

I am able to copy the exact same file(s) without any problem using my Windows 7 Laptop, with the Synology Volumes mounted under Windows Explorer.  For the same example I described above, when I couldn't copy the file from the Synology DS1511 to my iMac, I was able to copy that exact same file from the Synology DS1511 to my Win7 laptop, and then I used the Win7 laptop to convert the file for play on an iPod.  It's only on the Mac machines (iMac and MacMini) that I experience the problem of not being able to copy certain files from Synology NAS to the iMac/MacMini desktop.  It's not all of the files - only specific files have the issue, and I can't see any particular pattern.

 

I've tried repairing permissions on the iMac and MacMini, ensuring that files are authorized under the Synology File Manger system to be accessible (read & write) by all users, and I've restarted all systems.  My Win7 laptop has no problem copying the files in question.  I am able to copy TO the Synology NAS from the iMac or MacMini without a problem, and for specific files on the Synology NAS I have no problem copying them from NAS to iMac/MacMini.  If I use the web-browser based log-in for the Synology NAS, I'm able to download the files from the server to my iMac/MacMini desktop without difficulty, but it's obviously more convenient to use the Finder to do this.

 

Any suggestions or advice are greatly appreciated.  Thank you in advance!


iMac (27-inch Late 2009), Mac OS X (10.6.8), Synology DS1511+ NAS
  • SuperUltramanCosmos Level 1 Level 1 (0 points)

    Hello, Abmedic,

     

    I am on the same boat with you. I have recently purchased DS1511+ and am in the process of archiving data, I have kept on a dozen or so external hard drives.

     

    While most other directories copy onto DS1511+ share folder fine, only my iTunes directory fails to copy with error message saying, ".. you don't have permission to ..", similar to what you described.

     

    My question to you is, how are you copying your itunes contents?  Are you copy/pasting in file browser (I am using Win7 as a main computer to access DS1511+)? Are you using the DSM from within web browser? or Are you using iTunes copy capability to populate the library into the network storage (DS1511+) ?

     

    This has been about a week of searching for a solution for me, and not being able to use the NAS the way I want is getting frustrating.  I would like to keep up with what you may find out. If I discover a working solution, I will pot my findings here for you.

     

    Good luck

  • abmedic Level 1 Level 1 (0 points)

    No solution to my particular problem - other than I've slowly been re-copying the files in question (i.e. the files that play fine through Plex, and that I can copy at will using my Win 7 laptop, but that the iMac and MacMini can't copy, although downloading them to either Mac via the Synology web interface works fine).

     

    To address your question -- I haven't tried the iTunes feature yet - my plan is actually to use MediaRover to centralize my iTunes library, although I've not done it yet.

     

    Probably not the main answer to your question, but I've been using UltraCopier to copy my video files to the Synology DS1511.  Ultracopier works like the Windows-only program Teracopy and worked flawlessly to transfer over 1TB of video files from a D-Link DNS-323 NAS to the Synology.  It wasn't fast, but it got the job done.  I suspect that if your goal was just to copy the iTunes media files from your Mac to the Synology NAS, that Ultracopier would be a great tool.  I'm not sure of the process with specific respect to the iTunes server feature of the NAS.

     

    So bottom line - I haven't used the iTunes copy capability, and don't plan to, unless the MediaRover method fails.  And I also haven't found a solution to my posted issue of inability to copy certain files from the NAS to my Mac (iMac or MacMini) desktops due to faulty permissions.  Sorry that's probably not more helpful.  Good luck to you as well!

  • richardbranson Level 1 Level 1 (0 points)

    Same here but with a DS411.

    My slow and crappy solution was to use filestation to "download" the said files to my mac,delete the ones off the server and then recopy across. The 'download" file will have the correct permissions.

    Wish i had a better solution

  • abmedic Level 1 Level 1 (0 points)

    Yep.  That's what I had to do.  I used the DSM software to delete the files from the DS1511, then I recopied them using Ultracopier (freeware) back to the DS1511.  The newly copied versions didn't have the permissions issues, and I was then able to copy them back to the Mac machines (my iMac and my MacMini) without a problem.  In my particular case, all I can figure out is that my region had a few power outages while the data transfer was occurring (it was 2TB total of data to be transferred from the DNS-323 NAS to the Synology DS1511 -- took a few weeks) - any of the files that were partially transferred seemed to have the issue (I obviously had to go back and complete the copy process to get those files on the new server).  Any files that were copied and not interrupted by a power outage didn't have the issue.

     

    Bottom line - the tedious method of delting the files in question from the DS1511, and then recopying them back to the DS1511 solved the issue.  Even if I didn't do that though, I was able to successfully "download" the files with permissions issues from the DS1511 to the iMac/MacMini using the Filestation DSM software and web interface, which would have been another workaround.

     

    To follow-up on another Synology DS1511 question raised in this thread -- I'm also using MediaRover without an issue, and so far it's working great.  The built-in iTunes server on the DS1511 worked fine, but it didn't seem to have all of the syncing functionality that MediaRover offers.  I have all of my iTunes music and playlists copied to the DS1511, and then all computers in the house have MediaRover installed.  All computers (MacMini, iMac, Win7 Laptop, WinXP laptop) are syncing with the music folder on the DS1511 (managed by MediaRover).  If I make a playlist change or create a new playlist on any computer, it is synced and shows up immediately on the other computers, with an appropriate name so you know which computer created the playlist (i.e. if I use iTunes on the Win7 laptop to create a new playist, the playlist will automatically sync with the other computers, but will show up as [Win7laptop]"name of playlist" to avoid confusion if playlists have the same name, but were created by different computers).  Really a great solution that I can't believe is free.

     

    And, to throw out additional info on an unasked question -- I'm using the DS1511 photo server and audio servers (the Apps are free on the iOS app store) and they seem to be working great, but only on my local LAN so far.  To get remote photo and iTunes music access I'm using Plex Media Server, and the Plex iOS app which has worked flawlessly, to not only access the videos on my DS1511, but also to have my entire photo library and iTunes music library available anywhere, over WiFi or 3G (or the new ridiculously so-called "4G").  I can stream my entire iTunes music library to my iPhone anywhere, and I can view my entire photo library anywhere.  The Plex iOS app isn't free, but it's cheap, and the media server software is free.  Anyway, thanks to all for contributing some DS1511 and Mac knowledge.  Cheers!

  • richardbranson Level 1 Level 1 (0 points)

    Sorted it for me. I just now downloaded File multi Tool 5 from the app store and used it to remove the creator and type codes.

     

    Probelm solved. Shame it isnt cheap !

  • abmedic Level 1 Level 1 (0 points)

    Just downloaded File Multi Tool 5 (heck, for the photo date correction capability alone it's worth a few bucks).  Did you just drag the files directly from your Synology Diskstation into FMT5 and process to "Remove creator and/or type code"? 

  • abmedic Level 1 Level 1 (0 points)

    Follow-up to above - I downloaded File Multi Tool 5.  Opened my Synology DS1511 in Mac Finder - highlighted and dragged the files in question (the ones that won't allow copying back to the Mac desktop) into FMT5 - ran the operation "Remove creator and/or type code" and then closed finder, reopened Synology in Finder.  Changes didn't appear to have taken effect.  Then I ran "Force the Finder to update its information on the file(s)" in FMT5 to see if maybe that would do the trick.  Nope.  Files still won't copy back to the Mac desktop.

     

    Any suggestions on how you got it to work for you?  Thanks in advance!

  • richardbranson Level 1 Level 1 (0 points)

    It may be that it didn't work for you because you have a different problem to me. I pretty much did as you did. Just dragged them across and selected remove creator and  type, perform changes and bingo.You have to exit the folder and then go back to it before you see that the files are no longer greyed out.

    Have you tried using telnet commands and changing permissions (chmod eg. to 777) or ownership (chown) ?

     

    Also see https://discussions.apple.com/message/17211599#17211599 for another cause

  • batsmil Level 1 Level 1 (0 points)

    Hi,

    Simply browse the folder with a Windows computer, right click the greyed out file, then remove the Archive attribute in the properties of the file.

    That's all