7 Replies Latest reply: Feb 9, 2013 1:35 PM by PeterBreis0807
jimhaynes Level 1 Level 1 (10 points)

I am using Page '09 version 4.1.  Spell check is not finding misspellings.  I have checked, Check Spelling as you Type and have tried Edit->Spelling->Spelling... and it still miss words like meeti, which should be meeting, or develope, which should be develop.  I am worried that these misspellings may have been learned some how.  If so how do I correct or delete any words I added/leaned to the dictionary?  I also notice that Safari is not checking spelling as I type.  In order to check what I am writing here I must go to Edit->Spelling & Grammer->Check Document Now.  Pages does not have this option to Check Document now or it is not working for me.


iMac, Mac OS X (10.7), MacBook Air, IPad v1, Apple TV v2
  • fruhulda Level 6 Level 6 (15,120 points)

    Most of the time Spell check can't give the right suggestion if more than one character is wrong, missing or to many. I find that spell check can see it might be a wrongly spelled word though. If it can't see it a a wrongly spelled word it is a problem. Better tell apple when you find word like that but make sure you tell them which language you find the problem in. There are several versions of english you know. I wold use this page http://www.apple.com/feedback/macosx.html as Spell checking is a system feature and not a specific Pages or Safari feature.

  • jimhaynes Level 1 Level 1 (10 points)

    Upon further investigation I find that the problem is with a template I created.  Spell check is not working as I described if I use this template, but if I create a new document it works correctly in Pages it works correctly.

  • fruhulda Level 6 Level 6 (15,120 points)

    What do you mean? does it give you the suggestion meeting for the wrongly meeti? It doesn't on my computer.

  • jimhaynes Level 1 Level 1 (10 points)

    No it does not give a suggested correction, the window where this would normally appear is competely blank in all fields.  I went back and created 3 new templates from scratch.  Spell Check works correctly in these new templates.  This may just remain a mystry for ever.

  • Jerrold Green1 Level 7 Level 7 (29,925 points)

    Jim,

     

    Select a section of text that doesn't behave "properly" and go to Text Inspector, More tab, Language and see what language you have chosen for that text block. I would guess that it is set to "none".

     

    Jerry

  • bobo99 Level 1 Level 1 (0 points)

    I have the same issue. I cannot get spell check to work no matter what I do. The language selection is set to NONE and will not change to any other language - in this case ENGLISH. When I leave the tab and go to the page, it jumps back to NONE.

  • PeterBreis0807 Level 7 Level 7 (32,860 points)

    Probably because you are clicking in some other text.

     

    The language only applies to selected text.

     

    This paragraph can be English (and bold).

     

    Diese Texte verleicht Deutsch ist (and italic).

     

    This text could be None (no language, and thus not spell checked, also no bold nor italic).

     

    Setting it for one does not change it for the others anymore than changing the font in one changes the rest.

     

    Just like fonts, color and any other format, if you copy and paste or drag in text from elsewhere, such as the Internet, you are bringing in yet another set of formatting, including whether it has a different language, or none.

     

    Peter