3 Replies Latest reply: Dec 24, 2012 11:43 AM by amhey
sawyem Level 1 (0 points)

This seems to be a fairly common problem but I've yet to see a solution. I'm trying to get my iCloud me.com email address added to Outlook 2010 on my Windows 7 PC. I've tried adding the account manually to Outlook 2010 using the IMAP server details Apple have published here. I've also tried installing the iCloud tool on my PC. Nothing works. Outlook cannot connect to the mail servers. I've tried a couple of other mail clients as well without any success.


Has anyone been able to find a solution to this?

iCloud, iOS 5
  • Neurorad Level 1 (55 points)

    Same problem, cannot connect to my iCloud email with Outlook 2010 on a PC running WIndows 8.  Looked for several days for an answer but nothing seems to work.  iCloud control panel, every combo of SSL.TLS, redoing my iCloud password so that it is "strong".


    Any suggestions?

  • sawyem Level 1 (0 points)

    In the end I was able to solve this by changing my Apple ID password.

  • amhey Level 1 (0 points)

    I changed the password and it didn't work.  As a last resort in Outlook I made a new .pst file by going to File|New|Outlook File. I then went into the File|Data File Management and made the new .pst file my default file. I then opened the iCloud client and it showed that the Mail, Calendar, Contacts etc check box was unchecked. I checked it and it downloaded the Contacts and Calendar.

    It still had the wrong email server names. I then went into the email accounts on Outlook and deleted the Apple email account. You could change the names of the servers - mine started p08.imap.... when they should be just imap....  If you change the names of the servers by deleting everything before the word "imap" then you can login.  Your login name is NAME if your email is NAME@me.com or NAME@icloud.com. It is NOT NAME@icloud.com or whatever else you use to login to iCloud.