10 Replies Latest reply: Aug 21, 2012 2:59 PM by jwaldron-lu
mboe Level 1 Level 1 (0 points)

Hi,

 

I installed XCode 4.3 and every time I start it it crashes after two seconds or so. I removed and reinstalled it several times but the problem remains. Any hints?

Process:         Xcode [22053]

Path:            /Applications/Xcode.app/Contents/MacOS/Xcode

Identifier:      com.apple.dt.Xcode

Version:         4.3 (1175)

Build Info:      IDEApplication-1175000000000000~14

App Item ID:     497799835

App External ID: 6076348

Code Type:       X86-64 (Native)

Parent Process:  launchd [384]

 

 

Date/Time:       2012-02-21 12:51:14.782 +0100

OS Version:      Mac OS X 10.7.3 (11D50)

Report Version:  9

 

 

Interval Since Last Report:          6985 sec

Crashes Since Last Report:           9

Per-App Interval Since Last Report:  203 sec

Per-App Crashes Since Last Report:   1

Anonymous UUID:                      0C4AE0C2-6CCE-4FC1-B7C1-9CD9B766A477

 

 

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

 

 

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000002018

 

 

VM Regions Near 0x2018:

-->

    __TEXT                 0000000102a95000-0000000102a96000 [    4K] r-x/rwx SM=COW  /Applications/Xcode.app/Contents/MacOS/Xcode

 

 

Application Specific Information:

ProductBuildVersion: 4E109

objc[22053]: garbage collection is ON

 

 

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

0   com.apple.CoreFoundation                0x00007fff9682be28 __CFCopyFormattingDescription + 312

1   com.apple.CoreFoundation                0x00007fff96827073 __CFStringAppendFormatCore + 11379

2   com.apple.CoreFoundation                0x00007fff9682c113 CFStringCreateWithFormat + 211

3   com.apple.security                      0x00007fff94e105c1 copyDERThingContentDescription + 168

4   com.apple.security                      0x00007fff94e10682 copyDERThingDescription + 70

5   com.apple.security                      0x00007fff94e1100d appendGeneralNameContentProperty + 173

6   com.apple.security                      0x00007fff94e11250 appendGeneralNamesContent + 68

7   com.apple.security                      0x00007fff94e112be appendGeneralNames + 53

8   com.apple.security                      0x00007fff94e11dfd SecCertificateCopyProperties + 1383

9   com.apple.security                      0x00007fff94e0e7c3 Security::KeychainCore::CertificateValues::copyFieldValues(__CFArray const*, __CFError**) + 1263

10  com.apple.security                      0x00007fff94ddb88f SecCertificateCopyValues + 44

11  com.apple.dt.DVTFoundation              0x0000000102b8b9ae +[DVTCertificateUtilities certificateKindForCertificate:] + 62

12  com.apple.DTDeviceKitBase               0x0000000108d2255d -[DTDKDeveloperProfile displayCertificates] + 426

13  com.apple.dt.IDE.IDEiPhoneSupport          0x000000010b41de56 0x10b411000 + 52822

14  com.apple.dt.IDE.IDEiPhoneSupport          0x000000010b41f123 0x10b411000 + 57635

15  com.apple.dt.IDE.IDEiPhoneSupport          0x000000010b41c55b 0x10b411000 + 46427

16  com.apple.dt.IDE.IDEiPhoneSupport          0x000000010b41c5cd 0x10b411000 + 46541

17  com.apple.dt.DVTKit                     0x0000000102dab21d -[DVTControllerContentView _viewDidInstall] + 415

18  com.apple.dt.DVTKit                     0x0000000102daaa8d -[DVTControllerContentView viewDidMoveToWindow] + 78

19  com.apple.AppKit                        0x00007fff93f8177d -[NSView _setWindow:] + 2618

20  com.apple.AppKit                        0x00007fff93f7f999 -[NSView addSubview:] + 405

21  com.apple.dt.IDE.IDEInterfaceBuilderCocoaIntegration          0x0000000106e8e37c -[NSView(IBAppKitViewIntegration) ibSwizzledNSViewDebug_addSubview:] + 49

22  com.apple.dt.DVTKit                     0x0000000102e7253e __42-[DVTReplacementView _setupViewController]_block_invoke_0 + 164

23  com.apple.dt.DVTFoundation              0x0000000102b19368 DVTInvokeWithFailureHintObject + 59

24  com.apple.dt.DVTKit                     0x0000000102d9cd0f -[DVTReplacementView _setupViewController] + 249

25  com.apple.dt.DVTKit                     0x0000000102d9cbd5 -[DVTReplacementView installedViewController] + 138

26  com.apple.dt.IDEKit                     0x00000001035b2bf1 -[IDEOrganizerWindowController showWindow:] + 35

27  com.apple.dt.IDE.IDEiPhoneSupport          0x000000010b43369f 0x10b411000 + 140959

28  com.apple.CoreFoundation                0x00007fff968b375d -[NSObject performSelector:withObject:] + 61

29  com.apple.DTDeviceKitBase               0x0000000108d17726 __DTDK_dispatch_sync_block_invoke_0 + 19

30  libdispatch.dylib                       0x00007fff967678ba _dispatch_call_block_and_release + 18

31  libdispatch.dylib                       0x00007fff96768beb _dispatch_barrier_sync_f_slow_invoke + 80

32  libdispatch.dylib                       0x00007fff9676972a _dispatch_main_queue_callback_4CF + 308

33  com.apple.CoreFoundation                0x00007fff9685906c __CFRunLoopRun + 1724

34  com.apple.CoreFoundation                0x00007fff96858676 CFRunLoopRunSpecific + 230

35  com.apple.HIToolbox                     0x00007fff9151d31f RunCurrentEventLoopInMode + 277

36  com.apple.HIToolbox                     0x00007fff915245c9 ReceiveNextEventCommon + 355

37  com.apple.HIToolbox                     0x00007fff91524456 BlockUntilNextEventMatchingListInMode + 62

38  com.apple.AppKit                        0x00007fff93e6df5d _DPSNextEvent + 659

39  com.apple.AppKit                        0x00007fff93e6d861 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135

40  com.apple.AppKit                        0x00007fff93e6a19d -[NSApplication run] + 470

41  com.apple.AppKit                        0x00007fff940e8b88 NSApplicationMain + 867

42  com.apple.dt.Xcode                      0x0000000102a95eec 0x102a95000 + 3820

  • mboe Level 1 Level 1 (0 points)

    extra information: I could isolate the issue. After removing all the caches and settings the crash occurs reproducable if I click on the "Devices" button in the organizer window (regardsless whether a device is connected or not).

  • mboe Level 1 Level 1 (0 points)

    Hmm... XCode crashes anyway after some seconds even if I don't click on the "Devices" button. The funny thing is that I can start the app without any problems on the same machine using another user. I removed all the caches and com.apple.dt.XCode folder for my user but this doesn't help.

  • gerflo Level 1 Level 1 (0 points)

    I had the same issue with 4.3, removing all the plists from preferences helped me out...

     

    Best - Gerald

  • mboe Level 1 Level 1 (0 points)

    Which files exactly?

     

    FYI: XCode Build Version 4.3 (4E71d) (this is the one for iOS5.1) works fine.

  • gerflo Level 1 Level 1 (0 points)
    I deleted those:

     

    com.apple.dt.Xcode.LSSharedFileList.plist
    com.apple.dt.Xcode.LSSharedFileList.plist.lockfile
    com.apple.dt.Xcode.plist
    com.apple.dt.Xcode.plist.lockfile
    com.apple.Xcode.plist
    com.apple.Xcode.plist.lockfile

     

    Now it runs after startup, but still getting crashes after a while ;-(

     

    I use 4E109 and have to stick on it, because I have to publish to the App Store the next days ...
  • mboe Level 1 Level 1 (0 points)

    Hi,

     

    See https://devforums.apple.com/thread/141685?tstart=0

     

    I removed my personal certs (which was not necessary and some invalid certificates from the keychain and now it is working again.

  • GrandPixel Level 1 Level 1 (0 points)

    I am new to using a mac, and my xcode 4.3 is crashing also. It satrts with a blank window that says "no selection' at the top and "no editor" in the middle. The menu at the top of the screen is unusable, it does not respond. Eventually I get an "Internal Error" and can choose to continue or crash xcode.

     

    ASSERTION FAILURE in /SourceCache/IDEFoundation/IDEFoundation-943/Framework/Classes/Model/Containers /IDEWorkspace.m:348

    Details:  Assertion failed: self.valid

    Object:   <IDEWorkspace: 0x4017ce640>

    Method:   -_registerFileReferenceForSourceControlStatusUpdate:

    Thread:   <NSThread: 0x40010a260>{name = (null), num = 1}

    Hints:   None

    Backtrace:

      0  0x000000010970f366 -[IDEAssertionHandler handleFailureInMethod:object:fileName:lineNumber:messageFormat:arguments:] (in IDEKit)

      1  0x0000000108d861a4 _DVTAssertionFailureHandler (in DVTFoundation)

      2  0x0000000109305a06 -[IDEWorkspace _registerFileReferenceForSourceControlStatusUpdate:] (in IDEFoundation)

      3  0x000000010929498a -[IDEFileReference _setContainer:] (in IDEFoundation)

      4  0x0000000109293c94 -[IDEContainerItem _setSuperitem:] (in IDEFoundation)

      5  0x0000000109294841 -[IDEGroup _setSubitems:] (in IDEFoundation)

      6  0x000000010929bcea -[IDEFolder _updateSubitemsWithFileNames:] (in IDEFoundation)

      7  0x0000000109304f5c __block_global_1 (in IDEFoundation)

      8  0x00007fff835648ba _dispatch_call_block_and_release (in libdispatch.dylib)

      9  0x00007fff8356672a _dispatch_main_queue_callback_4CF (in libdispatch.dylib)

    10  0x00007fff867d406c __CFRunLoopRun (in CoreFoundation)

    11  0x00007fff867d3676 CFRunLoopRunSpecific (in CoreFoundation)

    12  0x00007fff8c5b731f RunCurrentEventLoopInMode (in HIToolbox)

    13  0x00007fff8c5be5c9 ReceiveNextEventCommon (in HIToolbox)

    14  0x00007fff8c5be456 BlockUntilNextEventMatchingListInMode (in HIToolbox)

    15  0x00007fff8cc7ff5d _DPSNextEvent (in AppKit)

    16  0x00007fff8cc7f861 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] (in AppKit)

    17  0x00007fff8cc7c19d -[NSApplication run] (in AppKit)

    18  0x00007fff8cefab88 NSApplicationMain (in AppKit)

    19  0x0000000108d14eec (in Xcode)

    20  0x0000000000000002

  • Peter Kevin Reeves Level 1 Level 1 (0 points)

    I solved the problem. I don't know if its the best solution, but after five days I'm happy to have Xcode working again.

     

     

    I solved the problem by doing two things. Resetting my Keychain under Lion and revoking my existing provisioning profiles.

     

     

    So first, reset your Keychain under Lion (http://support.apple.com/kb/TS1544). This will make the Organizer launch without crashing.

     

     

    Unfortunately, now you can't deploy your software because you killed all the certs in the keychain. So now you need to revoke all your developer certs (developer.apple.com/membercenter) and delete the provisioning profiles from your Organizer. Then tell the Organizer to refresh.

     

     

    It will restore all your sick profiles, but will also create at least one healthy one.

     

     

    The new version of Xcode tries to be helpful, and wants to handle all your cert needs for you. So bring up an Xcode project, and set code signing to the new provisioning profile. Compile, and everything will work again.

     

     

    As I said, may not be the best solution, but deleting old certs from the Keychain and extra prefs files did nothing to help me. If all else fails, try this recipe and it will probably help.

  • julienvs Level 1 Level 1 (0 points)

    Thank you so much!

    This solved it for me!

  • jwaldron-lu Level 1 Level 1 (0 points)

    I was having the same problem.  I had a couple of invalid certs in my login keychain which, after they were removed, solved the problem.  I found that I could export the certs that I had by right-clicking on the cert in keychain access and saving them to my desktop one by one.  I then deleted the cert that I had backed up and started Xcode each time.  If Xcode still failed then I knew that wasn't the cert causing the problem.  I could then restore the cert that I had backed up by clicking on the cert on my desktop.  It was long and tedious but eventually I removed one of the certs and Xcode started. 

     

    You may have more than one cert that is causing the problem so you may need to export and delete a group of them at a time just to narrow down the bad ones.

     

    Best of luck!