Previous 1 2 Next 19 Replies Latest reply: Jan 30, 2016 12:43 PM by maximus5328
maximus5328 Level 1 Level 1

When Mail in Lion detects duplicate messages in a mailbox, it groups them together and shows the link in the header "x Duplicates", where x is the number of duplicate messages found. When that link is clicked the duplicate messages show in the mailbox separately. But I'd like Mail to stop grouping them together to begin with.

Running OS X 10.7.3 and Mail 5.1

duplicates issue.jpg


Mail, Mac OS X (10.7.3)
Solved by Tom Francais on Apr 30, 2012 10:54 AM Solved

To disable automatic grouping of duplicate messages, quit Mail then run this command in Terminal:

 

     defaults write com.apple.mail AlwaysShowDuplicates -bool true

 

To revert to the default setting, run this command:

 

     defaults write com.apple.mail AlwaysShowDuplicates -bool false

 

or simply delete the setting altogether with this command:

 

     defaults delete com.apple.mail AlwaysShowDuplicates

 

If you want to see how Mail behaves with this setting enabled, but without modifying your preference file, start Mail from Terminal with this command:

 

     /Applications/Mail.app/Contents/MacOS/Mail -AlwaysShowDuplicates YES

 

 

I learned of Mail's modifiability (is that a word?) from here:

     http://hints.macworld.com/article.php?story=2004101603285984

and here:

     http://erikslab.com/2007/07/16/os-x-mailapp-logging/

 

 

I found the AlwaysShowDuplicates option by looking for interesting words similar to 'duplicates' in the Mail executable like this:

 

          strings /Applications/Mail.app/Contents/MacOS/Mail | grep -i duplicat

  • Jason_ayad Level 1 Level 1

    I have the same issue too.

     

    It seems that some emails have the same email message-id's therefore the duplicate.

     

    Any help would be greatly appreciated

  • Glenn Leblanc Level 6 Level 6

    Select the mailbox and in the menu under the View, uncheck Organize Messages by Conversations. You can also customize the toolbar in Mail to add the icon for Conversations (to show or not to show).

     

    Screen Shot 2012-02-29 at 6.25.18 PM.png

  • maximus5328 Level 1 Level 1

    This question has nothing to do with the Conversation View. Duplicated messages (or rather messages with the identical Message-Id header) will still be grouped together regardless of the "Organize by Conversation" setting.

  • Glenn Leblanc Level 6 Level 6

    OK. I see what you meant. The only duplicates I get is when I copy myself on an email. But I can see where it could be unwanted where someone who copies messages to other folders may have lots of them.

     

    That's a feature of Mail and I don't know of a way to turn that off. That may be good feature request to send in to Apple as a future add on.

     

    Possibly there may be a terminal command to turn that off. But I don't know it. If so, maybe someone will post it here.

  • Jason_ayad Level 1 Level 1

    I spoke with Apple support today and I referred them to this thread. Hopefully they can look into it and come back to us, because it it very frustrating.

     

    The problem i have is our clients keep re-suing the same email and sending it back to us, via reply or forward. Its annoying because i cant tell my clients how to do there work.

     

    Looking forward to a solution.

  • Glenn Leblanc Level 6 Level 6

    I see nobody has posted another solution yet. We'll see what their reply to you will be.

     

    You can also send some feedback to Apple:

    http://www.apple.com/feedback/macosx.html

  • Jason_ayad Level 1 Level 1

    I was wondering if anybody was able to find a solution for this?

  • Kevin Strong Level 1 Level 1

    Having the same problem.  3 emails from the same sender, to the same recipients, but at different times on the same day, and with different Subjects and content, were grouped together as Duplicates.  The only reason I knew they were 3 different emails, is I had first downloaded them on my iPhone, where they do show up as 3 different messages.  This is a serious bug in my opinion: the emails were from an important prospective client for my startup company, each with important content, and had it not been for the fact that I was away for the weekend without my Mac, and first downloaded them on my iPhone, I would never have known that the emails were all different.  Since I do now know they are not duplicates, I can click on the "2 Duplicates" link at the top of the one email that shows up in my Inbox, and see the other 2.  But don't want this to happen again (and I'm guessing it has probably happened before and I simply didn't know).  Have searched around Apple's support and elsewhere but not found any solution.

  • Jason_ayad Level 1 Level 1

    I am still waiting to hear for a fix, or even a work around, this is seriously hampering my businesss, as i also run a CRM (Daylite) which runs off the back off Lion Mail, and as mail thinks these emails are duplicates, so does my CRM.

     

    I hope this can be fixed ASAP!

  • Tom Francais Level 1 Level 1

    To disable automatic grouping of duplicate messages, quit Mail then run this command in Terminal:

     

         defaults write com.apple.mail AlwaysShowDuplicates -bool true

     

    To revert to the default setting, run this command:

     

         defaults write com.apple.mail AlwaysShowDuplicates -bool false

     

    or simply delete the setting altogether with this command:

     

         defaults delete com.apple.mail AlwaysShowDuplicates

     

    If you want to see how Mail behaves with this setting enabled, but without modifying your preference file, start Mail from Terminal with this command:

     

         /Applications/Mail.app/Contents/MacOS/Mail -AlwaysShowDuplicates YES

     

     

    I learned of Mail's modifiability (is that a word?) from here:

         http://hints.macworld.com/article.php?story=2004101603285984

    and here:

         http://erikslab.com/2007/07/16/os-x-mailapp-logging/

     

     

    I found the AlwaysShowDuplicates option by looking for interesting words similar to 'duplicates' in the Mail executable like this:

     

              strings /Applications/Mail.app/Contents/MacOS/Mail | grep -i duplicat

  • maximus5328 Level 1 Level 1

    You have solved it. Thank you for taking time to look for the answer and respond.

  • Kevin Strong Level 1 Level 1

    This does the trick and separates out the emails!  Thanks very much Tom for finding the answer to this. 

     

    Of course, Apple should still really fix the bug they have of false detection of duplicates, but I don't to worry about that now.

  • Jason_ayad Level 1 Level 1

    This solution does help, however it does not solve the the fact that mail still thinks these emails are duplicates.

     

    I am still having the drama that although now I can see all the emails, mail still thinks they are duplicates, so if I mark one of these emails as a flag, all the other emails get flagged too, cause mail thinks its the same email. When a new email comes in that mail thinks is a duplicate, some of my other email messages that mail thinks are duplicates get marked unread as well.

     

    Like I was saying before this is really causing me a lot of drama, because I also run a CRM which uses mail and as mail thinks some messages are duplicates, so does my CRM.

     

    I  really hope this can be sorted urgently

  • maximus5328 Level 1 Level 1

    My Mail behaves normally. I can mark one of the duplicate emails as flagged and the other duplicates do not get flagged.

Previous 1 2 Next