Previous 1 2 Next 27 Replies Latest reply: Feb 26, 2012 2:42 PM by Ralph Johns (UK)
bartbociaga Level 1 Level 1 (0 points)

Is it any way to do to send message from my MacBook to my girlfriend's iPhone as a SMS (iMessage), becouse I sent message from MacBook as an email. Its not very good.

 

Thanks!


MacBook, Mac OS X (10.7.2)
  • christianfrombrazil Level 1 Level 1 (0 points)

    Ok, not as SMS but as iMessage it is!!!

     

    1º - Check her iPhone (for 3GS, 4 and 4S models only) and see if it is updated to IOS 5.01 and if her iMessage it's working;

    2º - To send iMessages from your Macbook Pro, just enter: +(country code)(area code)mobile number, like this = +55 61 99999999. Explaining +55 (country code for Brazil), 61(area code for Brasilia) and 99999999(mobile number example).

     

    I hope it helped!

     

    Message was edited by: christianfrombrazil

  • bartbociaga Level 1 Level 1 (0 points)

    I'm doing eberything as like you want. And iMessage doesn't work. Have you got any other idea?

  • christianfrombrazil Level 1 Level 1 (0 points)

    Sorry man, I don't have any other ideas...

     

    Do you own an iPhone or iPad to test against her iPhone, to know if iMessage is working bettwen them???

     

    Perhaps you could call Apple Support or go into an Apple Authorized Shop.

     

    Because you know, i've done this here in Brazil, I've called to Apple Support and they gave me this hint to enter +5561mobile number, oh remember to cut off the zeros from Country Code and Area Code!!!

     

    No new ideas!!! Sorry!!

  • christianfrombrazil Level 1 Level 1 (0 points)

    This one i've taked from Gino!!!

     

    "Gino Cerullo Toronto, ON

     

     

    That's your problem right there. Send the messages to the Apple ID they have set up in Messages app on the iPhone.

     

    If they don't have an Apple ID associated with the Messages app on the iPhone they need to do that.

     

    On the iPhone they need to go to, Settings > Messages > Receive At and add thier Apple ID in the top field if it is not already there and also under 'You can be reached for messages at:

     

    Message was edited by: christianfrombrazil

  • bartbociaga Level 1 Level 1 (0 points)

    I have iPhone and my girlfriend has an iPhone and iMessage works between this two devices. I have no idea why iMessage on my Mac doesnt work. My Apple ID should be registered on iCloud.com?

  • bartbociaga Level 1 Level 1 (0 points)

    So, if I sent message by iMessage it has been sent like an email and also I dont see there answers, I'm able to see the answers only on iPhone.

    Bad.

  • christianfrombrazil Level 1 Level 1 (0 points)

    Bro look,

     

          If you sent messages for your girlfriend to her iPhone from your Mac you must have sent those messages to her mobile number, not to her mail adress, so, IS NOT SMS AND IS NOT E-MAIL IT IS iMESSAGE. Those messages if you don't see the answer in your Mac, probably the problem is a configuration on the iPhones.

     

          Please, do like Gino explain in the link below:

     

    https://discussions.apple.com/message/17615999#17615999

     

    SORRY, NO MORE IDEAS....

  • bartbociaga Level 1 Level 1 (0 points)

    I do exactly as like you said. I can withour any problems sent iMessage from iPhone to iPhone, but when I sent iMessage from Mac she resive it like an email, but I set a phone number on Mac.

     

    And yes, I tried to do like Gino explain but it doesnt work. I also tried with DNS.

    What do you mean the problem is a configuration on the iPhone? What should I do?

     

    Thanks!

  • christianfrombrazil Level 1 Level 1 (0 points)

    My last idea...

     

         Pick up your iPhone > Go to preferences > Go Messages:

                            iMessage - it must be set on (blue color) >

                            Lecture receives - indiferent, set it on(blue color) or off (grey/white color) >

                            Send as SMS- Set it on(blue color);

     

                            NOW WHAT IT'S REALLY IMPORTANT RECEIVE IN.....2 ADRESS > check it end enter preferences for it!

     

                            ID Apple: Your apple ID must be there, it is your e-mail adress set in Apple to be your apple ID >

     

    Your contacts for messages:

                             Mobile number (from your iPhone) must be: +(Country area)(Area Code)(mobile number). >

                            E-Mail - Must be the same from your Apple ID >

                            Add another e-mail - Leave it blank (for now) - Do not add another e-mail.

     

                            Caller ID

                            Caller ID > First, must be your mobile number there > +(Country Code)(Area Code)(mobile number).>

                                             Second your Apple ID > (your e-mail seted as your apple ID);

     

    Back to iMessage - Check the buttom up to get back. > Back to Messages - check the buttom up to get back > Messages.

                             SMS/MMS

                             Messages MMS> Set it on(blue color);

                             Show subject - it's up to you > Set it on(blue color) or leave it off(grey/white color);

                              Caracter Counter - it's up to you > Set in on (blue color) or leave it off(grey/white color);

     

    If this don't resolve the issue we go set your Message in your MBP!!!

     

    Go, do and let me know!!!!

  • Ralph Johns (UK) Level 9 Level 9 (69,315 points)

    Hi,

     

    Pic.

    Messages pane
    Uploaded with Skitch!

     

    Has the Contacts (Address Book) card for your girlfriend got her Phone Number on it  ?

    If  the name that gets put in the "To" space turns Blue then you can iMessage them  (their Phone Number or Apple ID in the "To" List (CLICK and hold to see that persons Alternative contacts) will have a little blue speech bubble).

     

     

     

     

     


    10:32 PM      Saturday; February 25, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • bartbociaga Level 1 Level 1 (0 points)

    I have exactly as you want. I've got this set up since I rememeber. Still doesn't work. What should I do on my Mac? Should I use iCloud?

     

     

    @Ralph Johns (UK): I understand you but I know how to write message from iMessage. My only problem is that they come like an email. My girlfriend resived it on her Email account, no mobile number.

  • Ralph Johns (UK) Level 9 Level 9 (69,315 points)

    Hi,

     

    I would then ask - is that email her Apple ID and is it set to be the Name/ID to accept things in iMessage on the phone ?

    (I would check for typos first before saying yes)

     

     


    11:00 PM      Saturday; February 25, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • christianfrombrazil Level 1 Level 1 (0 points)

    Thanks Ralf,

     

    Let's us help him, 'cause this is freaking me out!!!

  • christianfrombrazil Level 1 Level 1 (0 points)

    bartbociaga,

     

         Hey bro, did really checked your girlfriend iPhones configurations??? Anyway check it again. About iCloud mine is set on, but I can't figure it out how this may intefere on Messages bettwen Mac x iPhone or iPad...

     

    Message configuration for any Mac!

     

    Go MESSAGE > preferences.

     

         Accounts - the first is the iMessage Account, it must be set with your Apple ID.

                           The box where it is: activate this account must be checked;

                            Above where is wrote Your contact for Messages: must be the e-mail from your Apple ID;

     

    If you got everything right, them I'm not usefull no more!!!

Previous 1 2 Next