Previous 1 2 3 4 Next 46 Replies Latest reply: Nov 8, 2013 12:02 AM by Reforger Go to original post
  • vinnyob Level 1 (0 points)

    I downloaded the WiFi update a couple of weeks ago even though my problem was not WiFi but plugged in ethernet and my problem seems to have been resolved!  I have not lost my connection coming out of sleep since I did that update.  Thank you!

  • susanammons32 Level 1 (0 points)



    I am having this problem, but the download is for 10.7.3 only ... I now have 10.7.4 ... suggestions? ... thanks!



    This solved my questionRe: iMac OSX Lion loses internet connection (ethernet) waking up from sleep


    Mar 1, 2012 7:25 PM (in response to vinnyob)


    You mentioned your system is up-to-date, did you download and install:


  • rkaufmann87 Level 9 (53,540 points)

    susanammons32 wrote:




    I am having this problem, but the download is for 10.7.3 only ... I now have 10.7.4 ... suggestions? ... thanks!



    Re: iMac OSX Lion loses internet connection (ethernet) waking up from sleep


    Mar 1, 2012 7:25 PM (in response to vinnyob)


    You mentioned your system is up-to-date, did you download and install:


    Run Software update and see if you system needs the update. If it doesn't then you probably already have the update. Let us know what happens after trying to update.

  • susanammons32 Level 1 (0 points)

    I am currently running 10.7.4 ... the link you recommed installing is for 10.7.3 only ... when I try, it gives me that error message ... can i revert back & if so, will the fix remain when i update back to 10.7.4?

  • rkaufmann87 Level 9 (53,540 points)

    I found this yesterday....WI-FI / Secure Websites it may pertain to your situation.

  • loïcfernandezcastrillon Level 1 (80 points)

    I hope you'll be happy, but I may have found the solution. At least it worked for me during the last couple of days.


    When I use Back to my Mac from my Mac or any other VNC software on my iPad or iPhone, sometimes my iMac at home doesn't want to wake up, and it tells me that my iMac isn't available for the moment. As you noticed, after a few hours of sleep, the iMac dissapears from network and you cannot access it whether you're home or away.


    Here is the solution: When I know that I'll need to access my iMac for a reason or another, I go to Safari on my other Mac, or any other device (iPad, iPhone, etc) with iCloud enabled. Then I go to any webpage, for instance. Once there, I simply add this page to my reading list. Then I remove it (or keep it if I was surfing on a great blog or whatever).


    After 2 to 3 min, I can access my iMac, I think that the fact to add a page to my reading list, wakes up the iMac to sync it and thanks to that, the iMac is reachable. I tried to add notes, reminders, etc but it doesn't work. The reading list thing seems to be the only turnaround until Apple fix this iMac's sleeping issue.


    I tried this solution during an entire week while I wasn't home. Each morning I tried to access my iMac but it didn't work. I tried again and again... nothing. And as soon as I added a page to my reading list, the iMac appears like magic.


    Let me know if it works for you!

  • Ronaldo1965 Level 1 (0 points)

    Like earlier mentioned no fix has been found. I have reported a workaround.


    sudo ifconfig en0 down

    sleep 10

    sudo ifconfig en0 up


    This works.


    One thing to mention also is I deinstalled Little Snitch because I suspected that it was related, but also that does not make a difference.


    I also changed cabling to cat6 cable. But nothing changed.


    I must be a driver/filter issue. Because when using a manual configured IP address, the ip address is still on it, but I can't ping anything in the network and I can't be pinged. The ifconfig en0 up will reinitialize the adapter and then everything works again.

  • krafa Level 1 (0 points)

    I don't know but this issue seem to be very strange. Well, my problem is not when my iMac (late 2009) running 10.8.2 is waking from sleep but rather when I have to reboot for one reason or another. Have had this problem since the summer but can't say for sure the problem started after upgrading to Mountain Lion but it's been a problem for the last couple of months at least.


    Anyway, for some reason the iMac is not able to obtain an IP address via DHCP from my Time Capsule when my MBP/iPhone/iPad have no issues whatsoever. For the iMac the problem is there both for wired ethernet and wifi, the fomer taking a while before assigning a link-local address (self-assigned IP of 169.254.x.y) when the wifi connection almost instantly resorts to that (shorter timeouts perhaps). Well actually the behavior seems quite random as sometimes it looks like I have an IP address but the iMac still can't talk to the TC and in the extent getting out to the Internet. I've tried multiple things such as assigning the IP address completely manually or using DHCP but with a manual address. Once in a while it seems like the problem solves itself or at least I can't relate it to any of the changes I've made. However, it feels the problem has been getting worse and today I was struggling for hours after a reboot to get back online. After spending some time reading these posts I tried the suggestion from Ronaldo1965 taking down the interface and bringing it up again with ifconfig. However, that didn't work for me but it got me playing around with some of the other lower level networking stuff. In particular I was looking at the ARP table and what entries it contained. ARP is used to tie a particular IP address to the MAC or physical address of the ethernet/wifi interface. I don't know but listing the ARP table (arp -a) showed some strange entries as far as I could tell so I tried to empty the ARP table (sudo arp -d -i en0 -a) and voila my iMac managed to get an IP address via DHCP instantly and my connection was back. This could have been coincidence but I was able to reproduce it as the problem was back after another reboot. Also after emptying the ARP table and successfully getting an IP for some reason I was not getting the DNS settings I usually get automatically from my ISP. That's less of a concern though as once you've got connectivity you can configure DNS manually.


    I don't know but it feels there is some serious issue in the networking subsystem and below. Since it only affects the iMac my bet is also a device driver issue or an interworking/lower level configuration issue between the same and the networking subsystem. Nevertheless, I didn't try the tips behind the link provided by rkaufmann87 above but the latter part of #3 in that article sounds interesting and something to look at - tomorrow...

  • loïcfernandezcastrillon Level 1 (80 points)

    Did you purshase a new device such as Apple TV, or iPhone, or maybe one device from your girlfriend/friend etc, check if you have a new device always connected, maybe your DHCP gives the same IP to this device and to your iMac.

  • loïcfernandezcastrillon Level 1 (80 points)

    I've checked Computer/Library/Preferences/SystemConfiguration


    There is a file called "preferences.plist"

    Into it I found:














































    Do you think we could solve the problem by changing some of the values?

  • krafa Level 1 (0 points)



    Well, those look like configurations for PPP (Point to Point Protocol) and I'm not using PPP to connect to the network. Basically my home network looks like the following. I have a broadband (fiber modem) operating in bridged mode (I think) to which my Time Capsule is connected over wired ethernet. The TC (7.6.1) runs a DHCP server handing out NATed IP addresses to all the devices on the local network. Apart from my iMac (10.8.2)  all other devices use WiFi to connect to the network. I have a PS3, a Wii, a Win7 laptop, an iPhone (iOS 6.0.1) and an iPad2 (iOS 6.0.1), a wireless HP printer, an MBP 13" (10.8.2) and a quite old MBP 15" running 10.5.8.


    After a reboot no other devices than the iMac and the MBP 13" (both running 10.8.2) have an issue in getting an IP address both over wired ethernet and over WiFi. Neither of the devices have an issue waking from sleep only cold starts cause the issues I'm having...


    In other words there are 2 common things here, both devices are running 10.8.2 as well as using the TC for Time Machine backups and as a file server.


    So the TC may actually be the culprit here but I don't understand why that would be the case. I mean it is an IP problem not an AFP (file server protocol) problem albeit I'm getting error messages that the devices fail to connect to the file server. But that's just logical because there is no IP connectivity in the first place...


    Nevertheless, these 2 devices will eventually 'recover' and finally get an IP address, which is good, but it can take ages. So it may be (some possibly corrupted) configuration issue or then there is some SW issue either in 10.8.x and/or in the TC. In the latter case I can only hope Apple will fix this but in the former case I just don't know what to look for...


    Anyway, thanks for your suggestion!

  • loïcfernandezcastrillon Level 1 (80 points)

    I'll try that anyway, if the problem comes back!

  • loïcfernandezcastrillon Level 1 (80 points)

    And what about: pmset -g networkoversleep 1

    By default it's 0

  • Reforger Level 1 (0 points)

    OK I think I have this fixed - been stable so far today on my Mac Pro wired connection and comes back fine after a sleep/wake!


    Problem seems to lie in the automatic location setting in the network settings, so here's what I did...


    1. Network settings - Location - Edit Locations

    2. Add a new location .. "Home" for example

    3. With home selected, click the cogwheel below the network services and choose "Set Service Order"

    4. Reorder the services so your preferred connection type is at the top

    5. After that, select each service in turn (assuming you have a few - like Bluetooth PAN etc)

    6. Make the services you are not using inactive

    7. Apply


    Please post if this works for you - it's been dragging on far too long and needs sorting out by Apple but if this is a good workaround for people then it will do for now.