8 Replies Latest reply: Feb 23, 2012 6:42 PM by Matthew Knice
cosmichobo Level 3 (515 points)



I've just bought a 400/800 firewire cable to connect my G5 PowerMac and 2010 Macbook Pro 13".  (Yes, I realised after purchase, the G5 has FW800... so I could have gone for a 800/800 cable... doh me).


I tried connecting the 2 machines using Target Disk Mode first - both ways - but neither would see the other as a FW disk.


I then tried networking them using the Networks pref, but again, they could not see each other.


I have never used the MacBook Pro's FW800 port... though I do know the G5's 400 ports both work.  Thinking maybe it was the MBP, I dug out an iBook SE, and connected the 400 end into it, and the 800 end in first the MBP, then the G5.  No good either - except -


When I opened System Profiler on the G5, with the iBook in TDM, it errored, saying it could not confirm if any devices were attached... Suggesting it could see SOMETHING... but not properly... 


Does this sound like it's all the cable's fault... Or is there some inherent problem with firewire between 400/800?






PowerMac 2004 dual 1.8GHz, Mac OS X (10.5.8), 1.25GHz RAM, 2x 1TB WD Green Drives, Stock Vid Card
  • Matthew Knice Level 1 (70 points)

    Ok so Ive been thinking about your question and how to approach this problem...have you tried different cables? Maybe the cable is faulty. If different or known good cables prove faulty...then unfortunately it sounds to me like the Port....it wouldnt surprise me because Ive seen several G4s that the Ethernet port just goes rancid. Just randomly stops working...my eMac had that issue...maybe had something to do with overclocking it...but let me tell you, it worked fine even 1 year later after the OC. Then randomly one day chose not to work. I dont know. But then my G4 MDD showed the same symptom...(before I did the insane overclock btw) it just wasnt working...so just installed AirPort in both and circumvented the problem. =) But I burned up the CPU board. Its toast. So now I got a DP 1.33GHz chip in it. Working again. Just left the clock speeds alone. lol


    Btw.....havent I seen you before? The eMac forums perhaps? And we have the same Power Mac G5 models right? Yours was the one that looks like it went through a garbage disposal (mustve been a MASSIVE one to fit a PMG5! lol!) Just wondering. If so then a warm welcome back!!!

  • cosmichobo Level 3 (515 points)

    G'day Matthew,


    Yep, I've got the G5 that looks like it was dropped... then dragged behind a car...  


    Also used to hang out on the eMac forum, particularly 2006-7 or so when the badcaps was big news...


    On Topic - I am guessing it is the 400/800 firewire cable I bought, as I've tried using it between 3 different computers... (Unless the G5's FW400 is working, and FW800 is not... as well as the MBP's FW800 not working - none of these ports have been tested before, as I don't own any FW800 devices)  I bought the cable off ebay... Think I'll have to email the seller and see if they'll send me another one...


    On the topic of my G5... I'm about ready to part it out... except I don't have any options for replacements as yet... It appears to only work at 1/2 capacity... following swapping one of the CPUs.  Will have a play around shortly with the 4 processors I have available and see if I can fix it.



  • BDAqua Level 10 (121,630 points)

    as I don't own any FW800 devices

    Do you have any FW400 devices to check your FW800 ports with that cable?


    Have you tried connecting the FW cable after one is in t mode?

  • cosmichobo Level 3 (515 points)

    *face palm*


    I thought of video cameras... (no - they are 4pin)  nothing else...  Til you mentioned "devices" - yes, an external hard drive - M9 Pod firewire/USB - currently connected to the G5 via USB.


    I just tried the 400/800 cable on it between both the G5 and MacBook Pro.  It wouldn't "turn on" for the G5 at all, and did spin up for the MBP, but didn't mount... (the drive wont normally spin up if it is not connected to a computer)


    Think I'll email the seller and have a chat...


    Thanks for your help, guys!  As it's not just a "simple plug n play" with firewire (networking and target disk), I wasn't sure if there was some obscurity causing the problem)





  • BDAqua Level 10 (121,630 points)

    Cable does seem it might be the problem!

  • Matthew Knice Level 1 (70 points)

    BDAqua wrote:


    Cable does seem it might be the problem!

    Thats the culprit I had in mind the entire time just wanted to pinpoint the issue by process of elimination first. And just another reason I dont use eBay... -_-

  • BDAqua Level 10 (121,630 points)

    Yeah, I sometimes have an idea off the bat but generally do some fishing first myself!

  • Matthew Knice Level 1 (70 points)

    Yeah thats the way to do it! (like they always say...if it aint broke dont fix it! So make sure that the bad part is actually bad before you go out and replace something that doesnt get you anywhere...I hate it when that happens...its a bugger)