11 Replies Latest reply: Apr 8, 2012 5:15 AM by ronaldfromdresden
ronaldfromdresden Level 1 (40 points)

Hello -


I just discovered that Teamviewer in Version 6 and also in Beta 7 does not work anymore. Re-install did not work.

Version 6 :  it starts but the application can only be killed

Version 7 : The application does not start anymore. The shown error report is sent to Teamviewer.com but i doubt there will be an answer since I am using that private.

Maybe someone knows or has a hint/comment. Would be very helpful.


Mac OS X Lion, Mac OS X (10.7)
  • sig Level 8 (35,785 points)

    This is where you need to ask:


  • Haagse Harry Level 1 (10 points)

    Teamviewer 7 beta works fine under 10.7.3. I only had an issue with Teamviewer 6 because the other party was using a newer version than mine.


    So I don't think that the issue is with Teamviewer or Lion. Have you checked the install log files on your Mac? You might find some hint there.

  • ronaldfromdresden Level 1 (40 points)

    Hello, thanks for comments. I removed again and installed it. The installation finished without any error. But the first start of Teamviewer7 failed with :

    Process:         TeamViewer [494]

    Path:            /Applications/TeamViewer 7/TeamViewer.app/Contents/MacOS/TeamViewer

    Identifier:      com.teamviewer.TeamViewer

    Version:         7.0.10810 (1)

    Code Type:       X86 (Native)

    Parent Process:  launchd [286]



    Date/Time:       2012-02-24 09:07:16.181 +0800

    OS Version:      Mac OS X 10.7.3 (11D50)

    Report Version:  9



    Interval Since Last Report:          186708 sec

    Crashes Since Last Report:           23

    Per-App Interval Since Last Report:  898 sec

    Per-App Crashes Since Last Report:   1

    Anonymous UUID:                      7E590C65-876A-462C-836E-1FC526F881A0



    Crashed Thread:  3



    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000022dcca0c

    The thread3, mentioned as crashed thread, does not tell me so much. However, I have sent it to Teamviewer.com but I am afraid, there won't be an answer.


  • Haagse Harry Level 1 (10 points)

    The exception type looked familiar, when googling it together with 'teamviewer' I've found the following interesting post: https://discussions.apple.com/thread/3532096?start=0&tstart=0

  • ronaldfromdresden Level 1 (40 points)

    Dear Harry - thanks a lot for googling that and which I not found :-(


    I was trying to open the error log file from there but it was not available. I cannot see in my log files such a correlation and the mentioned program I do not have. I also cannot remember to have installed after the Lion Upgrade other system programs. And before, it was definitly working.


    Okay, meanwhile I have tried the different things

    - SMC and NV Reset

    - booting in Safe Mode <-- here it is also crashing


    After reboot in normal mode, the same crashing behavior. I also repaired permission and rebuild the DYLD cache thru ONYX. Everything does not help at all.

    The only thing what has changed is the error message, now it looks something the Font and Carbon, before it was something different, the GeForceGLDriver.


    Crashed Thread:  3



    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000029d9068c



    VM Regions Near 0x29d9068c:

        mapped file            000000000c8bd000-000000000cb86000 [ 2852K] rw-/rwx SM=COW  /System/Library/Fonts/Helvetica.dfont


        __TEXT                 0000000064b00000-0000000064b07000 [   28K] r-x/rwx SM=COW  /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Print.framewo rk/Versions/A/Print

  • Haagse Harry Level 1 (10 points)

    hm, what bothers me more now is that booting in safe mode crashes. Also with exception codes pointing to different modules I would start to think that there is some issue at OS level.


    I'm hesitant to recommend a clean install here, but unless someone else has a better idea that's what I would consider.

  • ronaldfromdresden Level 1 (40 points)

    SOLVED :


    It looks a little bit trivial :-) I just started the Teamviewer on my MBP without attached second screen and voila, it works.

    Thanks for your digging too and apologize that it does not came to my mind earlier.



  • Haagse Harry Level 1 (10 points)

    That's good to know! Thanks!


    Btw, did you pass this on to TeamViewer support as this sounds like a defect?

  • ronaldfromdresden Level 1 (40 points)

    Hello Harry - yes, because i had also a request from them to send different log files. the other thing also, i do not want to waste their time.

    Again, thanks a lot for your replies.


  • miltersen Level 1 (0 points)

    I don't understand the solution "without attached second screen" I have only one screen and still it won't open. Is there something I am missing?

  • ronaldfromdresden Level 1 (40 points)

    Hi - what i mean is, that i had connected a second screen to the MBP. Then it was crashing. Without attached secondary screen, it works fine. Do you have crash reported in the Console?