Previous 1 2 3 Next 38 Replies Latest reply: Jan 15, 2015 3:02 PM by jodilord Go to original post Branched to a new discussion.
  • tonygil Level 1 Level 1 (0 points)

    exactly what part of  "i tried repairing permissions with disk utility, with no success (as all other proposed solutions here did NOT work either)" did NOT become clear to you?  why are you repeating a suggestion (couple of, actually) that i have already informed that was tried and DID NOT WORK?


    i have tried repairing permissions, copying library to a  folder with RW permissions, iPhoto Library Manager does not access library either (because of permissions), i am using the macs main admin account and have even opened permissions as wide as they get for specific folders (and superfolders, too, of course).  i have deleted and recreated preferences files for iPhoto (which at least let me reopen iPhoto now). 


    BTW: following apple's recommendation, this is a clean reinstall (after formatting disk) because the machine i bought (a macbook) was diagnosed by apple as having a faulty factory system install (which apple proposed to fix - for 400 bucks).  the time machine backup was done last night and the restore from time machine, this morning.

  • Terence Devlin Level 10 Level 10 (135,515 points)
    exactly what part of  "i tried repairing permissions with disk utility, with no success



    I have examined my suggestions thoroughly and cannot see where I suggest that you repair permissions with Disk Utility? Let me look again... No, sorry I cannot see where I suggested to you that you do that. It's not in Option 1 and it's not in Option 2 either. I can only wonder if this is related to your frustrations with fixing your Macs.


    As for "... all other proposed solutions here did NOT work either", well if you're too lazy to actually bother to list the things you've tried (or now I wonder, should that be mis-tried) how can I be sure what - if anything - you've (mis-)tried.


    Here's a tip: Repairing permissions with Disk Utility has no impact on an iPhoto Library. DU works on System Files only. 


    You have a nice day now.

  • tonygil Level 1 Level 1 (0 points)

    if anyone has had this issue and has solved the problem with a recipe that has NOT yet been posted on this thread, i would greatly appreciate a headsup (as i am sure, would many other users facing similar difficulties).


    <Edited by Host>

  • LarryHN Level 9 Level 9 (72,975 points)

    Insults and personal attacks are totally uncessary - just because you do not understand is no reason to attack those trying to help you



  • tonygil Level 1 Level 1 (0 points)

    LarryHN, i imagine that you HAVE read the thread history and have seen that i was completely trolled by LD (who tried NEVER to help, starting out directly with insults to my effectiveness).  having said that, i agree that a faceoff with a poweruser bully will get me nowhere and will only take up precious time from users looking for help with an annoying issue.


    BUT, that is not why i am here.  i have solved the problem deriving from the series of permissions bugs in sLow leopard.


    no amount of permission repairing or resetting will solve the problem.  apparently, because i reinstalled OSX from scratch (reformatting disk first), the Time Machine backup belongs to a defunct user.  therefore, even though the username and password are the same, the file that i extract DIRECTLY from TM will be always read-only (i could go via terminal and try some chmod'ifications, but...).  therefore, the issue must be tackled with a different approach:


    1. open iPhoto
    2. open FILE

    3. choose FIND BACKUPS (translated from Portuguese)
    4. select your timeMachine backup and find the specific image/date you want

    5. browse to the iPhoto library you want to import

    6. create a new folder in Documents (where permissions will not be an issue)
    7. after iPhoto backup has been restored to this folder, go to FILE > IMPORT


    voila.  worked for me, i hope that this helps the many others who run into the same problem after reformatting and reinstalling OSX leopard (regular or sLow, both seem to act up).


    "e pur si muove": i understand perfectly well, LD's recipe was just wrong, dude!

  • Paul Phillips5 Level 1 Level 1 (0 points)

    Hi, This just happened to me too - don't know what cuased it or why it happened  - though today there was a software update to do with raw image stuff which must effect iphoto or something. Any way the answer is below from Courtesy of The Otter. Well done mate. Simple. Fast. Effective.


    I’ve got the solution to this locking problem, and man, you guys are going to kick yourselves.

    First, make sure iPhoto is closed.

    Second, find your iPhoto Library in the Finder. (Unless you’ve moved it, it should be in your Pictures folder, which is itself in your User folder.)

    Once you’ve found your iPhoto Library, right-click (control-click, two-finger–click, etc.) it and select “Show Package Contents” from the contextual menu. HOLD the ctrl key and click the iPhoto Library icon to show the extended options.

    Method 1 This worked for me first time. I just selected the .data file as belwo and pressed delete icon in finder top menu.

    Drag to the Trash and empty it.

    Method 2

    If cannot be moved to the trash (which is likely):

    Create a new folder within the iPhoto Library. (Call it whatever you like.)

    Drag into that new folder.

    Once you’ve used either of these methods, you may close the iPhoto Library window and relaunch iPhoto. You’ll probably get a message that iPhoto is rebuilding the thumbnail cache (which will probably take a while), but that’s a small price to pay for recovering all your prized photos.

    Good luck!



  • jaznjj Level 1 Level 1 (0 points)

    Update:  After wrestling with problems my Mac for two weeks after its heart transplant I ended up taking it back in.  Along the way, various causes were proposed by the Apple people:  a corrupt OS, a display problem etc. Some of the many problems were sorted on the benchtop in the shop - but not all - and it had to be left with the techies again.  At one stage the blame seems to have fallen on the Seagate software - but whether it was the internal or external Seagate HD was not specified and the problem was just noted as "software" - so it could also have been something in the Lion OS they reinstalled.  The good news - so far everything appears to be working as it should.  J

  • Old Toad Level 10 Level 10 (131,400 points)
    exactly what part of  "i tried repairing permissions with disk utility, with no success


    If you've worked with Macs as long as you've said you would know that Disk Utility only works on system files and not user files which the iPhoto Library package is as it's in your home folder.


    The following is from: About Disk Utility's Repair Disk Permissions feature


    Does Disk Utility check permissions on all files?

    Files that aren't installed as part of an Apple-originated installer package are not listed in a receipt and therefore are not checked. For example, if you install an application using a non-Apple installer application, or by copying it from a disk image, network volume, or other disk instead of installing it via Installer, a receipt file isn't created. This is expected. Some applications are designed to be installed in one of those ways.



  • redmacman Level 1 Level 1 (0 points)

    What kind of malignant ******** is this error message??  Seriously, I was just minding my own business, surfing the web with Safari while iPhoto was open, and then POW!!  Fatal Error.  *** Apple?  Seriously...

  • matthewfromfarnham Level 1 Level 1 (0 points)

    I had this problem after moving my iPhoto lib to a sparse disk image (volume with ownership ignored).

    This was so the lib could be shared with other users on the same Mac - as per apple support advice.

    Paulo's solution worked for me!


  • Senoraschultz Level 1 Level 1 (0 points)

    Restarting worked for me, thank god!

  • srdtf Level 1 Level 1 (0 points)

    Thanks, Paul Phillips5!


    I had the same problem (The iPhoto Library is locked, on a locked disk, or you do not have permission to make changes to it), and I thought it had to with my iPhoto albums on NFS mounted NAS. My first reaction was that it is yet another bug on Mavericks, but I have to say it was as simple as deleting the lock file. This is no biggie at all. I am happy I didn't go re-farming my library (a non-option in my book).

  • Terence Devlin Level 10 Level 10 (135,515 points)

    and I thought it had to with my iPhoto albums on NFS mounted NAS.


    That's exactly the cause and it will cause more damage over time too.


    iPhoto needs to have the Library sitting on disk formatted Mac OS Extended (Journaled). Users with the Library sitting on disks otherwise formatted regularly report issues including, but not limited to, importing, exporting, saving edits and sharing the photos.


    See this article



    for more. Note also the comment:


    “Additionally, storing the iPhoto library on a network rather than locally on your computer can also lead to poor performance or data loss.”

  • srdtf Level 1 Level 1 (0 points)

    I should clarify that my NAS is NFS exports from an Ubuntu server in which I formatted my NAS disk using ext3, not FAT32. Ext3, you will recall, is journalled, but of course, not a Mac OS Extended FS. The KB article you reference only points to issues on FAT32, though.


    In the end, I do expect this to work with Linux, for all the "Apple is a type of Unix" banter I keep hearing here and elsewhere. If it doesn't, I consider that a bug, not FAD. The good news is that it does work.

  • Terence Devlin Level 10 Level 10 (135,515 points)

    You know, whatever. You have your Library on a disk that's the wrong format over a network connection - that's two things Apple say not to do as they will lead to problems. And there are enough posts on this forum over the years to suggest that Apple know what they are talking about. Some folks run these set ups for years with no issues. Until one day there is a problem, a real problem with actual dataloss.


    But it's your data to do what you as you please. I would caution you that what you consider a bug - or not - isn't really relevant and might not be much consolation when you suffer dataloss.