Previous 1 2 3 Next 31 Replies Latest reply: Feb 26, 2012 8:46 AM by noondaywitch
happyluck1 Level 1 Level 1 (0 points)

I use a macbookpro and an old user has given me his old IMac G3..trying to get it up and running for a friend who has not got a computer. I have started it up and it is running OS 9. I want to put Tiger on it as i have the install disk. Unfortunately when i tried to eject the disk it says that:

 

'The startup disk cannot be removed from the desktop ,because it contains the active system software'.

 

In the special menu the eject apple E menu choice is also greyed out.

 

I checked the support site on Apple for old G3's but it suggests there is a eject button..this imac came from 2000 and has no such button.

 

Also i have seen the option 'Erase disk' in the special menu. I wonder if I erased that then installed my Tiger disk whether that would work and then let me eject the startup disk too.

  • Niel Level 10 Level 10 (274,605 points)

    That's referring to the hard disk, not the disk in the DVD drive(if any). If there's a CD or DVD icon on the desktop, drag that to the Trash. If not, insert the Mac OS X 10.4 DVD.

     

    (64329)

  • noondaywitch Level 6 Level 6 (8,130 points)

    If the G3 has a CD tray, it won't read a DVD at all, and the highest OS it can run is 10.3.9 (Panther). To open the tray when empty, push it in slightly with a finger and it should pop open so can pull it out to put the CD in.

     

    If it's a slot loader, you don't open it, you just feed the CD or DVD into the slot and it will be 'eaten' by the drive.

    In either case, to remove it

    a) press the ⏏ button on the keyboard (top right)

    or

    b) Drag the disc icon on the desktop to the Trash - the Trash will turn into the eject symbol (⏏)

    or

    c) press ⌘ and E together

    or

    d) ctrl-click on the disc icon and choose 'eject' from the menu

     

    If it's a slot loader, 350MHz or slower processer can only run Panther, 400MHz or faster can run Tiger 10.4.11 and they should have a DVD ROM drive at least.

  • happyluck1 Level 1 Level 1 (0 points)

    It's a slot loader and 400Mhz. So hopefully will run Tiger, however, I still can't eject whatever is in there. There is a iMac Install disk icon on the desktop but when i drag it to the trash it says:

     

    'The startup disk cannot be removed from the desktop ,because it contains the active system software'.

     

    And i tried command E, which doesn't work. Also I tried to use the Special menu but the command E on there is greyed out. And also the keyboard does not have an eject button..also tried the ctrl-click option which doesn;t work either...So any suggestions a,b,c,and d don't work...what to do?

  • happyluck1 Level 1 Level 1 (0 points)

    ps thanks fo ryour help thus far :-)

  • Niel Level 10 Level 10 (274,605 points)

    Choose Restart from the Special menu and press the mouse button immediately after hearing the chime. If that doesn't work, press the Option, Command, O, and F keys, and run the following:

     

    eject cd

    mac-boot

     

    (64355)

  • noondaywitch Level 6 Level 6 (8,130 points)

    This sounds like there's no operating system on the HD or the HD is damaged in some way, causing the computer to boot from the disc.

    To see if that's the case, open Disk First Aid and see what's listed.

     

    Ref loading Tiger - you need to make sure the iMac has had firmware update 4.1.9 applied, and that can only be done from OS 9.1 or above (not OS X).

     

    If the HD is shown in the Disk First Aid window, there should be a Macintosh HD volume listed. If there isn't, then you'll need to use DFA to partition the HD and format it. (I think that model uses HFS+, but some early ones used HFS, so I'm not sure without further checking - but if HFS+ is an option, it's the one you should use).

     

    You'll then need to run the installer from that disc before you can restart and eject it.

  • noondaywitch Level 6 Level 6 (8,130 points)

    You can download a ,pdf manual from here

     

    If you don't have an eject key, you may not have the original keyboard -

     

    iMac G3 ext kboard.png

  • Popularfox Level 1 Level 1 (0 points)

    I think if you erase the disk it might eject it. But I think you will no longer be able to download Tiger on a Mac so becarefull

  • happyluck1 Level 1 Level 1 (0 points)

    In DFA, the volumes listed are: Internal RAM disk and the iMac Install CD,ATAPI DVD-ROM,bus 2,(write Protected)

     

    Also first i couldn't find the DFA so i typed it in the help center and a message came up that said ' A search file coulf not be created because the startup disk is locked'

     

    maybe i need to get a code from the previous owner???

  • happyluck1 Level 1 Level 1 (0 points)

    If i click on the Internal RAM disk i get the options: 'verify' or 'repair'

  • happyluck1 Level 1 Level 1 (0 points)

    It  says in the paperwork that came with the iMac that it has 13GB plus 128MB....

     

    When the iMac Install CD window loads up it says directly underneath, 11items 134.6MB available...

     

    I guess that means there must be a lot of stuff on the hard drive?

     

     

     

    Also i thought maybe i should try to install the OS 9 from the install disk and then maybe i could eject it after. I clicked through till i got to a page that said , select destination....unserneath it says ' A destination volume can't be found. To continue the installation process, mount a valid volume for software installation.

     

    Underneath i have two choices, either 'Options' or 'Go back'.

     

    Clicking options i get ..Perform clean installation, then cancel or OK.

  • happyluck1 Level 1 Level 1 (0 points)

    The keyboard in the picture shown is not the same keyboard i have. I have only the main block of keys plus a four wide block with numerical keypad and math buttons

  • happyluck1 Level 1 Level 1 (0 points)

    Opened the Apple system profiler.In applications,non apple programs are as follows:

     

     

    Name,version,memory size,file size

    Address book Export 1.0 850K 430K

    Address book shortcut, not av. 200K 31K

    AFP! Engage! 2.0.1,2.0.1 1MB 903K

    Appleworks 5.0.4 updater 5.5.2 1.97MB 588K

    ATM 4.5.2 installer 1.0f7 2MB 2.35MB

    Bugdom (OEM) 1.0.1 6.83MB 441K

    Dropstuff 5.1.2 512k 168k

    Eric's Solitare Sample 1.0.2 1.46MB 630k

    FAXstf installer 6.0.1 1MB 2.34 MB

    Install Appleworks UK 5.5.2 2MB 14.15MB

    Install iDO script sheduler 5.5.2 1MB 672K

    Internet Explorer 4.5, 4.5 7.90MB 3MB

    LogDoor PPC 2.2, 2.2 2MB 651K

    Make configuration sample, Not av. 200K 21K

    Make Sets Not av. 200k 21k

    Messenger Inbox shortcut, Not av. 200k 31k

    Microsoft iNternet first run 6.0 1.56 MB 4.47MB

    MultiMail conduit 1_2 demo 3.6 1000k 283k

    Nanosaur 1.16 installer 2.0 512k 15.46MB

    Navigator Shortcut, Not avaiable, 200k 31k

    Netscape communicator 4.6.1 11.90MB 10.39MB

    Netscape Import 1.0.2f2 1MB 346K

    OSA menu installer 5.0 1.95MB 199K

    Outlook express 4.5 3.90MB 2.60MB

    Palm conect install tool, Not av. 200k 21k

    Palm connect PRC/PDB typer not av. 200k 21k

    Palm Desktop Installer 6.0 4.39MB 6.72MB

    Powerbook palm assistant, Not av. 200k 31k

    Reader installer 4.0 4MB 4MB

    Register stuffit Expander 1.0 100k 31k

    Remove shareway IP 3.0 Not av. 200k 10k

    Scripts Installer not av. not av. 200k 10k

    Shareway IP personal  3.0.1 750k 168k

    Shareway IP personal Backgr 3.0.1 759k 136k

    Shockwave download 7.0f1 1.95MB 168k

    Stuffit Expander 5.1.4 512k 1MB

    Switch active network set, Not Av.200k 10k

    Switch Apple talk on/off, Not Av.200k 10k

    Upgrade to shareway IP 3.0, Not av. 200k 10k

    User Profile Manager 1.1 512k 21k

  • noondaywitch Level 6 Level 6 (8,130 points)

    happyluck1 wrote:

     

    In DFA, the volumes listed are: Internal RAM disk and the iMac Install CD,ATAPI DVD-ROM,bus 2,(write Protected)

     

    That sounds ominous - no entry for a "13GB WD WDX etc.…" or something similar (not necessarily WD, but a HD manufacturer"s name or abbreviation)?

     

    If that line's not present, you may not have a Hard Drive fitted at all.

Previous 1 2 3 Next