9 Replies Latest reply: Nov 26, 2012 7:45 PM by leesnoopyt
sandrafrompoughkeepsie Level 1 (0 points)

I upgraded from 10.5 to 10.6.8 so that I could use a newer version of pages.  But now I can'tprint anything becase when I try the printer dialogue box says that the printer is "offline"  How can I fix this?


MacBook Pro, Mac OS X (10.6.6)
  • sandrafrompoughkeepsie Level 1 (0 points)

    Hust want to make a correction to my last post.  I have 10.6.3 not 10.6 .8

  • steve626 Level 4 (1,485 points)

    First, you should update to 10.6.8, most easily accomplished by running software update. There are some printer drivers included in some of those updates.

     

    Next, you didn't indicate what model your Canon printer is. That would help in troubleshooting.

     

    Third -- have you power cycled your printer? Also, some of those dialogues showing "printer offline" provide a button to "take online." Is there a button or option for that in your dialogue?

     

    Fourth -- I have a Canon printer (MG8120 model) and after upgrading one of our iMacs to 10.6.8 I had to reinstall the original Canon printer software and drivers from the CD's that came with it. Then it worked fine.

  • babowa Level 7 (29,950 points)

    Another idea is to open the Print Pane in System Preferences. Make sure the printer is turned on and plugged in. Then click the '-' to delete the printer (if it is listed there); after that click the '+' to add a printer. If the computer recognizes it, it may just work and/or it may show you a window that you need to install software - click ok. I just went through this when I upgraded Lion.

  • sandrafrompoughkeepsie Level 1 (0 points)

    Thank you for responding.  It is a MX 310 series

    No take online button...  unfortunately!

    Powered up: the printer is on.  No dialogue boxes suggesting I need to do something.

     

    Haven't tried to reinstll drivers.

     

    thanks

  • R C-R Level 6 (17,400 points)

    I suggest you try Steve626's advice & update to 10.6.8. Your MX 310 series printer is on the list of supported printers & by updating to the latest Snow Leopard version, you should get the latest drivers for it.

  • sandrafrompoughkeepsie Level 1 (0 points)

    Thank you, too,  for taking the time to reply.

    I did go to the printer pane: didn'thelp.

     

    I am willing to uninstall and reinstall the CD driver.  I have not ever uninstalled someting like this [yes, I am a novice...]

    Could you walk me through this?  I went to applications and found many thingslisted under "Canon utilities" but not how to uninstall this.

     

    Thanks.

  • sandrafrompoughkeepsie Level 1 (0 points)

    I did run software updates and got a bunch of things {safari, firmware, security, airport...} but nothing about the printer.....?

  • R C-R Level 6 (17,400 points)

    Did you update to 10.6.8? If so, run Software Update again to see if it finds anything else -- some updates can only be applied if others are already in place.

     

    Also review http://support.apple.com/kb/HT3771, including the troubleshooting steps section, to make sure you have tried all it suggests.

  • leesnoopyt Level 1 (0 points)

    This simple step solved my problem!  THANK YOU!!!