1 Reply Latest reply: Feb 24, 2012 2:39 PM by rkaufmann87
cdr12 Level 1 Level 1 (0 points)

I am trying to print coupons from the target.com website. I am told that I 'need the latest Java (TM) Runtime Environment...Would you like to update..?' Software update tells me that my software is up-to-date. I have been able to print coupons before. Can anyone help? Thanks.


iMac (20-inch Early 2009), Mac OS X (10.7.2)