13 Replies Latest reply: Apr 19, 2014 2:57 PM by U24
jasdril Level 1 (0 points)

I haven't been using Soundtrack Pro 3 for a while, and now when I needed to use it, it wouldn't even start.


All I get is a dock icon and the startup window for a very short moment, quicker than a blink of an eye. No error message or anything. It just doesn't open. Before it has worked fine and my system should run it perfectly.


Booting the computer or logging out or reinstalling SP didn't help.


I'm having and iMac with Intel Core i7 and Snow Leopard 10.6.8.

Soundtrack Pro, Mac OS X (10.6.8)
  • Studio X Level 7 (27,030 points)

    Hard to really tell what's going on.


    One of the first things to do when any of the Final Cut Studio Apps goes wonky is to use Digital Rebellion's Final Cut Preference Manager to delete the apps preferences.


    It is a free download.



  • jasdril Level 1 (0 points)

    Okay I tried that, and it did not solve the problem.

    But well, I think I can see the dock icon for TWO eye blinks now.

  • Gary Sumlak Level 3 (615 points)

    Delete the STP preferences manually.


    Go to ~/Library/Preferences/ and delete com.apple.soundtrackpro.plist


    Empty the trash.  And just for good measure, shut down (not a restart) the Mac, wait the count of 10, then start the Mac up again.  Now try launching STP.


    Let us know what happens.



  • jasdril Level 1 (0 points)

    Manually deleting didn't help either, but I hadn't have tried really shutting down. That helped and now it seems to works perfectly. Thank you very much!


    What it changes to shut down instead of restarting? I thought it was basically the same.

  • Gary Sumlak Level 3 (615 points)

    There are a number of system cache and temporary files that do not get completely purged until you turn off the Mac.  During a restart, power is still supplied to all the hardware components (RAM, HDD, Graphics cards... etc), so problem files can still hang around, or harware compoments (which can also cause problems) are still powered up and not reset by a restart.


    For example - A customer called complaing that the fans in his mac were running full speed and would not stop.  I told him to shut down the mac, but he only restarted it, and the fans stayed at full speed.  I told him he needed to actually shut down/power off the mac, wait a couple seconds, then start up the mac.  That fixed the fan problem, and he was happy.


    There are also those rare occations when even shutting down the mac does not reset components, as even with the mac shut down, there is still power to the system.  In that case, the Mac has to be physically unplugged from the power outlet, and left to sit unplugged for several seconds.


    Another. let techy way to delete/reset your prreferences is to use a great free utility from Digital Rebelliion:

    Preference Manager

    Preference Manager allows you to manage preference files for Final Cut Studio, Final Cut Express, Final Cut Pro X, Avid Media Composer and Adobe Premiere Pro for Mac.

    Preference files store information about user preferences, window layouts, toolbar placements and launch settings. Sometimes these can become corrupted, causing problems. Preference Manager allows you to trash corrupted preferences and keep backups of working preference files in order to quickly restore your settings.


    PM will allow to specify only the STP files or the entire Final Cut Studio or just delete a single file at the application level.


    Glad you got things working..

  • Studio X Level 7 (27,030 points)

    Hmmm, sounds familier ...


    Hard to really tell what's going on.


    One of the first things to do when any of the Final Cut Studio Apps goes wonky is to use Digital Rebellion's Final Cut Preference Manager to delete the apps preferences.


    It is a free download.



  • Gary Sumlak Level 3 (615 points)

    Good advise always bears repeating 


    Actually, I did not clue in we were talking about the same utility as PM is not just Final Cut, but addresses many apps... I thought you may have been referring to FCSRemover, which duplicates the same functions, and adds many more, but is specific to the Final Cut Studio apps, and not the Adobe apps that PM includes.  PM is a bit lighter weight than FCSRemover, which is why I referred to PM


    Anyway, sorry. Did not mean to usurp.

  • Studio X Level 7 (27,030 points)



    Just curious.



  • Gary Sumlak Level 3 (615 points)

    The "Final Cut" part.   "Preference Manager" is just "Preference Manager".  Since FCSRemover also removes preferences, I thought you got the name mixed up, which is the case, but I made the wrong interpretation.


    Didn't mean to upset you or take credit from where it was due.  Names get screwed up all the time, and this was one of those times.


    Again, please accept my appologies.

  • Studio X Level 7 (27,030 points)



    I realize my post came across too directly.


    One way I address the issue of repeating information already given in a thread is to reference the previous posts. For example: "As Gary S noted, you really need to framitz the defib and then stick the needle in your eye. However, if that doesn't work, try throwing your computer out of the nearest window - as long as it is at least 20 meters above the ground you should be good to go."


    This does two things - 1. it keeps the OP focused on proven solutions and 2. it builds community between those who labor for nothing in the Apple salt mine.





  • jonshuler Level 1 (0 points)

    Thanks jasdril for posting your fix, not everyone does.


    This seems to be a problem/solution throughout the FCP Suite family. I've had to do it for Motion and FCP.  I though, "Surely, that's not the problem here!  It's some some glitch with FCPX or Lion!"  Clearly, I've been talking to too many PP converts.



  • sebal Level 1 (0 points)

    holy cow! this really worked for me too! i guess "turning it on and off again" does make a difference!

  • U24 Level 1 (10 points)



    Works fine!