7 Replies Latest reply: Feb 26, 2012 6:16 PM by Old Toad
ribeirotm Level 1 Level 1 (0 points)

I only see a black screen... and I can't see the photos in the slideshow either...


iPhoto '11, Mac OS X (10.7.3)
  • 1. Re: Why won't slideshow work anymore?
    Old Toad Level 10 Level 10 (115,690 points)

    Try doulble clicking on the thumbnail of one of those photos in the Photos mode to bring up the full sized version.  What do you see?  If it's this:

    iP11missingoriginal.PNG

    then it's an indication that iPhoto has broken the link/file path to the original file. If it's a blank, black screen it could be a file persmiision issue.  In either case if you have the space available on your hard drive and don't aready have a backup copy of the library make a temporary, backup copy (select the library and type Command+D) and apply the two fixes below in order as needed:

     

    Fix #1

     

    Launch iPhoto with the Command+Option keys held down and rebuild the library.

     

     

    Select the options identified in the screenshot

     

    Fix #2

     

    Using iPhoto Library Manager  to Rebuild Your iPhoto Library

     

      1. Download iPhoto Library Manager and launch.
      2. Click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.
      3. Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu option
      4. In the next  window name the new library and select the location you want it to be placed.
      5. Click on the Create button.

     

    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments but not books, calendars or slideshows. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.


     

     

    OT

  • 2. Re: Why won't slideshow work anymore?
    ribeirotm Level 1 Level 1 (0 points)

    I see the original photo. I think the link is ok... Another clue?

  • 3. Re: Why won't slideshow work anymore?
    Old Toad Level 10 Level 10 (115,690 points)

    Still try the two fixes as necessary.  Make or have a backup of the library before doing so.

  • 4. Re: Why won't slideshow work anymore?
    ribeirotm Level 1 Level 1 (0 points)

    Done. I've created a new library with the albums which I needed for the slideshow and also rebuilt it again with both fixes. Still, no slideshow. Other options?

  • 5. Re: Why won't slideshow work anymore?
    Old Toad Level 10 Level 10 (115,690 points)

    So the new library didn't work either.  In that case a reinstall of iPhoto is indicated. To do so you'll have to delete the current application and all files with "iPhoto" in the file name with either a .PKG or .BOM extension that reside in the HD/Library/Receipts folder and from the /var/db/receipts/  folder,

     

    Click to view full size

    Then install iPhoto from the disk it came on originally.

  • 6. Re: Why won't slideshow work anymore?
    ribeirotm Level 1 Level 1 (0 points)

    I still get a black screen and that's all... I deleted the application from the apps folder, all the files with "iphoto" in it in both folders (I hope I didn't miss some... used spotlight with "iphoto" in that folders to be sure to grab them all...) I installed iPhoto from the disk, ran the upgrade from the site to 9.2.1. Nothing changed. Black screen.

     

    Thanks for your help... What next?

  • 7. Re: Why won't slideshow work anymore?
    Old Toad Level 10 Level 10 (115,690 points)

    I'm sure you're getting tired of these dead ends but try the following:

     

    A -  make a temporary, backup copy (if you don't already have a backup copy) of the library and do the following:

     

    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your

         User/Home()/Library/ Preferences folder.

     

    2 - delete iPhoto's cache file, Cache.db, that is located in your

         User/Home()/Library/Caches/com.apple.iPhoto folder. 

     

    Click to view full size

     

    3 - launch iPhoto and try again.

     

    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.

     

    If still no success continue with:

     

    B - log into another user account on your Mac and see if you can get a slideshow with those photos to display as they should.  If you can then there is something in your current user account that's causing the problem. 

     

    If the slideshow in the other account works as expected it could be a preference file other the iPhoto preference file in your current account that's causing the problem. In that case here's how to check that out:

     

    Trouble Shooting Preferences

     

    1 - close all applications. 

    2 - open your Library folder, Home/Library, and drag the Preferences folder to the Desktop. A new Preference folder will be immediately created in the Library.

    NOTE: if dragging the Preference folder to the desktop only copies the folder then after the copy has been completed go back and drag the contents of the Preferences folder from the Library to the Trash in the dock. You will be asked to enter your Admin password. Then reboot and try again.

    3 - run the application again and determine if the problems is fixed. 

    4 - If the problem is fixed:

     

    A - open the working Preferences folder (HD/Users/your_name/Library/Preferences).

    B - Open the Preferences  folder on the Desktop, select all of the contents and drag them into the working Preferences folder.

    C - When the Copy window pops up check the "Apply to All" check box and then click on the Don't Replace or Skip button.

     

     

    5 - If the problem is NOT fixed, drag the contents of the Preference folder on the Desktop into the Preference of the Library folder are  replace the new one that was created by clicking on Replace.