Skip navigation

Drafts multiple copies of message in Mail Drafts

25282 Views 50 Replies Latest reply: Dec 11, 2013 4:13 AM by ColinDW RSS
  • amityweb Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 30, 2012 1:13 PM (in response to lschaaf)

    I get this issue but I use multiple computers so need to store drafts on the server so I can access saved emails anywhere.

     

    Edit... actually think I might create a new IMAP folder for Saved emails, then I CAN save Drafts on the Mac.

  • DanTorrey Calculating status...
    Currently Being Moderated
    Jul 3, 2013 1:16 PM (in response to John P.)

    Thanks alot! This info helps!

  • Little Birds Nest Calculating status...

    since updating to osx maverick. the mac email keeps saving the drafts on the server. even when i uncheck the "save drafts on server" and then save the changes. after a few seconds find its been checked again without me doing anything. i dont know whats going on with it. any help?

  • Atcold Level 1 Level 1 (0 points)

    Yeah, same problem. Any solution so far?

  • gmneary13 Level 1 Level 1 (0 points)

    Same problem here.  Any changes I make to options are not being saved.  Very frustrating as the "save drafts on server" option is checked and all of my email is getting saved in drafts.  Need an answer ASAP!

  • alowin Level 1 Level 1 (10 points)

    Same problem here. May have begun earlier, but this issue became serious when I upgraded to Mavericks two weeks back - many copies of a draft em are being created. When the em is Sent these saved drafts show up in Trash. I inspected the drafts and saw that they seem to have been captured every fraction of a minute as I prepared my email; the drafts are not identical but rather show the sequential progress as I prep'd the em .

     

    Trying to get rid of this, I go to Mail Prefs > Accts > Mailbox Behaviors  and UNcheck 'Store draft messages on the server'  then confirm Save Changes. BUT ... the UNcheck doesn't stick. The checked box returns.

     

    Any suggestions? TXS

  • gmneary13 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 17, 2013 9:15 PM (in response to alowin)

    I fixed it by going to google and AOL and changing the mailbox behaviors there.  I googled it and kept reading until I came across the solution with changing the mailbox behaviors from my google account.  It worked perfectly and I haven't had the problem since.  Sorry, but I don't exactly remember the steps.  But it is fixed now.

  • Atcold Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 18, 2013 8:26 AM (in response to gmneary13)

    Are you kidding me??? “I've solved it and I'm writing here that... I don't remember how I did it???” Is it a joke???

  • alowin Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 18, 2013 12:38 PM (in response to gmneary13)

    Agree w/ Atcold. gmneary13 reply not helpful. Pls advise if you can where to adjust my gmail.com acct settings  (not my Apple Mail prefs) to fix Mailbox Behaviors. (Again, the issue here is that my Apple Mail client is NOT saving my unchecking 'Store draft messages on the server')  Thank you.

  • Atcold Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 18, 2013 12:46 PM (in response to alowin)

    @alowin, are you on OS X 10.7 or something else? I'm on 10.9 but I guess this is a common problem across multiple OS versions.

  • alowin Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 18, 2013 12:54 PM (in response to Atcold)

    Txs for ur note, Atcold. Running latest v of 10.9 Mavericks; local client is Apple Mail. This issue (many sequential drafts of an em I am preparing piling up in Trash after em is sent) may have been mildly present with 10.8 but is far more serious w/ 10.9 .  Searched my gmail website > settings but could not find where to adjust Mailbox Behaviors.

  • Atcold Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 18, 2013 12:59 PM (in response to alowin)

    Well, then, since we are in

    Mac OS X v10.7 Lion > Discussions

    we'd better open a new issue report on the correct section if we'd like someone to actually help us.

     

    I believe you won't find anything in our Gmail settings because this is Apple's fault and the way they manage the drafts. Furthermore, if I want to disable the synchronisation of the drafts and Mail doesn't allow me to do so, well, this is their bug, and only them can fix it, since they have the source code.

     

    Regards

  • gmneary13 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 18, 2013 1:12 PM (in response to Atcold)

    I did find it in gmail settings and I had to change it the IMAP settings.  After I did that it worked. and I haven't had the problem since.  Go to GMAIL imap settings and change the setting.  I had to go to LABELS and UNCHECK the DRAFTS "show in imap" and it worked -- this did the trick.  I found the solution again that I did the first time.  IT WORKED.

  • Glenn Leblanc Level 5 Level 5 (5,895 points)
    Currently Being Moderated
    Nov 18, 2013 1:15 PM (in response to Atcold)

    For the issue of syncing drafts to the server, I don't know of any fix for that. It is an issue of Mail and GMail syncing at the same time as you are sending an email. It saves a copy to draft and gets put on the server even though you sent the message. This is a known issue and has been so for several years. I doubt seriously that gmneary13 actually fixed the problem. I believe it just hasn't reoccured yet or he disabled storing drafts on the server.

     

    Mail does allow you to disable draft syncronisation. It is not storing draft messages on the server. Open Mail's preferences, select Accounts tab, select the account in question in the sidebar, and choose the Mailbox Behavior's tab. Uncheck store drafts on the server. This will discontinue having draft messages created when you don't actually save a draft.

    The imap draft mailbox will be placed back under the gmail account in the sidebar and a local draft mailbox will be created for that account under the main mailboxes when needed. If you truly wish to start a message on one device and finish it on another, save the draft first, then select the draft and move or copy it to the imap draft folder. Then you will be able to access it on other devices via the same imap folder.

     

    It would be nice if Apple would fix it, but they haven't. It's seems to be an issue on computers and not iOS devices. Everyone just need to send feedback to Apple's feedback site about this issue. Apparantly there hasn't been enough complaints about it for them to do anything about it yet.

     

    BTW: This is not specific to gmail. This also occurs with iCloud accounts. Probably with any IMAP account.


  • gmneary13 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 18, 2013 1:15 PM (in response to Atcold)

    Last problem is that as everyone else, when I change my macmail settings they don't save....haven't come across the solution yet.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.