Previous 1 2 3 4 Next 54 Replies Latest reply: Apr 22, 2015 1:13 PM by BlueHeron30 Go to original post
  • gmneary13 Level 1 Level 1 (0 points)

    I actually did fix the problem.  You go to GMAIL settings go to LABELS and UNCHECK the SHOW ON IMAP - I wouldn't have stated I fixed the problem if I didn't fix the problem.  It was driving me crazy.  So as far as GMAIL goes and saving the drafts (this was the only place I was having the issue since I use GOOGLE for sending mail).  If you use other web based mail on your MAC for mail it may or may not work.  I have no idea this solution worked for me on my macbook with respect to sending mail since I use google for my mail.

  • gmneary13 Level 1 Level 1 (0 points)

    As far as MACMAIL not saving settings I don't know.  I haven't came across that solution yet. 

  • Atcold Level 1 Level 1 (0 points)

    Since this problem has started to p**s me o*f, I fixed it myself.

    Here's the solution: https://discussions.apple.com/message/23536259#23536259

    Then, you can re-enable the “Show in IMAP” box thing.

  • Glenn Leblanc Level 6 Level 6 (8,690 points)

    Well you did the same thing as going into Mail's preferences and choosing not storing drafts on the server. That doesn't fix the problem for people who want the settings to store drafts on the server automatically from their computer in Apple Mail so it would automatically be available on all devices. Having that checked creates drafts of messages that are being sent and not really saved as drafts.

  • Atcold Level 1 Level 1 (0 points)

    Well, I believe you write an email in 1 minute (since you send 100 emails a day, on average).

    If it's something more long and important you can always use the browser interface... My problem was that I was unable to uncheck that checkbox. Now I'm fine.

     

    P.S. Sorry, I thought you were writing to me. Anyway, what I wrote keeps being fine.

  • Glenn Leblanc Level 6 Level 6 (8,690 points)

    If your settings aren't being saved when changed:

    Quit Mail

    Go to the Finder menu, select GO, then Go To Folder, and paste this:

    ~/Library/Preferences/com.apple.mail.plist

     

    That should open a Finder window to that file in your Home Library folder. Move that file to the trash and start Mail. You will have to recreate your settings. See if you can save your settings now. If you can't and have problems with Mail, you can quit Mail, open the trash and right click on that file. Select put back and and replace the newly created file.

  • gmneary13 Level 1 Level 1 (0 points)

    NO I DIDN'T I went to GOOGLE and settings and then to LABELS and then UNCHECK "SHOW IN IMAP".  That is not the same thing as making the changes in MACMAIL.

  • Glenn Leblanc Level 6 Level 6 (8,690 points)

    Don't think it had anything to do with the length of the message or the time used to create it. It was happening if you sent the message at the same time your computer was actually syncing with the imap site. That's when the draft was being created. If Mail was idle and not syncing to the imap account, then no draft was created when you sent the message.

    So it depended on how often mail was set to check. If you have it set to check every minute or automatically, then chances were good you would get a draft when you sent an email even though you never saved as a draft. The longer the period you had set to check for mail, the better chance of not having the unwanted draft created.

     

    Since you got the box unchecked to store drafts on the server, you shouldn't have a problem with it anymore.

  • Glenn Leblanc Level 6 Level 6 (8,690 points)

    Well then what is the Mailbox Behavior for storing drafts on the server set to in Mail? Is it checked or unchecked?

  • gmneary13 Level 1 Level 1 (0 points)

    On MACMAIL I have store drafts on server is unchecked.  So I am not sure what would happen if I checked it...

  • gmneary13 Level 1 Level 1 (0 points)

    I don't know if I am no longer saving drafts anywhere...since I actually don't understand what is happening I just followed the instructions.

  • Glenn Leblanc Level 6 Level 6 (8,690 points)

    The reason it is unchecked is because of what you did at the GMail site by choosing not to show the Draft mailbox in IMAP. Not showing it in IMAP means that the mailbox is not available to outside devices (storing on server). At least that's what I think.

    If you check that box in Mail to store drafts on the server, then you will have the same problem of drafts being created on occasion when you send messages. The IMAP draft mailbox should once again show in IMAP at the GMAIL website and reappear in Mail. You can check it and verify that. I don't have gmail anymore, so I can't verify it myself.

    When the problem reoccurs, just go back to there and uncheck the box.

  • Glenn Leblanc Level 6 Level 6 (8,690 points)

    In addition:

    You can leave the Label setting at the gmail website to show it in IMAP. Have the setting unchecked in Mail to store drafts on the server.

     

    That way, the imap draft mailbox will be available in the sidebar under the google account listed there instead of under the main draft mailbox section. A local draft folder will be created when needed under the main draft mailbox. You won't have the problem of drafts being created when you didn't actually create one and still have the option to save a draft on the server manually as I said before. If you don't have multiple devices, then you don't need to worry about that anyway.

  • gmneary13 Level 1 Level 1 (0 points)

    The problem with this is that MACMAIL will not save the settings if you uncheck it there.  That is the solution we are all looking for right now.  Ever since updating to the new operating system this problem has been occurring.

  • alowin Level 1 Level 1 (10 points)

    Txs Atcold. Have posted the following under OSX 10.9 Mavericks

     

    Multiple (!!) em drafts being saved in Trash. (OS-X 10.9 Mavericks + Apple Mail v 7.0 (for a gmail mail acct). The saved drafts are sequential snapshots of the em contents during drafting. I believe they are supposed to delete when the em is Sent.

     

    Usual fix NG:  Mail Prefs > Accts > Mailbox Behaviors, Uncheck box for 'Store draft msgs on server,'  Save Changes. BUT - After a few seconds 'Store' box is again checked.

     

    Your suggestions? TXS