Previous 1 2 3 4 Next 57 Replies Latest reply: Apr 5, 2016 5:35 AM by 750 H2C Go to original post
  • gmneary13 Level 1 Level 1

    IF you are using GOOGLE as your mail client I had to go to GOOGLE go to mail settings - go to labels - look at drafts folder - and uncheck the "SHOW IN IMAP" all the way on the right side of settings.  That worked for me.

  • Glenn Leblanc Level 6 Level 6

    Well saving settings is not the problem everyone is having here. But I did post a solution for you to try to fix that problem of not being able to save settings. If that doesn't work for you, then create a new discussion for that. There are plenty of people out there who might have other solutions beside the one I gave to you.


    As to the new OS, I assume you are referring to Lion since you are in the Lion forum. Not that the problem is much different in ML or Mavericks.

  • alowin Level 1 Level 1

    Running Mavericks

    Have now posted same issue under OS X 10.9

    Txs for ur em

  • Glenn Leblanc Level 6 Level 6

    gmneary13 & alowin


    If your settings aren't being saved when changed:

    Quit Mail

    Go to the Finder menu, select GO, then Go To Folder, and paste this:



    That should open a Finder window to that file in your Home Library folder. Move that file to the trash and start Mail. You will have to recreate your settings. See if you can save your settings now. If you can't and have problems with Mail, you can quit Mail, open the trash and right click on that file. Select put back and and replace the newly created file.


    If you are using ML or Mavericks that file may be in a different location. It would probably be in your Home Library in the Containers/Mail folder, or maybe even in both locations. If they are in both, delete from both places.


    In Mavericks also check here:


  • gmneary13 Level 1 Level 1

    I thin it is Maverick I am now on.

  • ColinDW Level 1 Level 1

    The crash issue does not seem to be fixed as a yet, so as a (rather tedious) workaround I have been copying the original draft to another folder, then moving back to drafts.

  • pittershawn Level 1 Level 1

    This has been happening to me for a while now. However, I am using POP, so there is no selection to uncheck in this case, given that it's not IMAP. Any thoughts? Also, no, I am not on Google, Yahoo, or any other free email company. It's my own domain name email addresses.

  • Acey Mac Level 1 Level 1

    Same problem - my most recent sent message would keep reappearing in Drafts, no matter how many times I deleted it. Then the next sent message would take its place. One undead phantom message always remained, flagged as unread - very irritating.


    I prefer to save drafts to the server, so I didn't uncheck that preference. Instead, here's a simple trick. While composing a message, click on the Drafts folder. Be sure the Drafts folder is displayed before hitting Send. Then, as the message whooshes away, the Drafts version disappears. Bye-bye phantom drafts. 

  • SoamesH Level 1 Level 1



    I have noticed this behavior on all versions of OS X. I know this thread is old, but I thought that I would post my thoughts.


    I dramatically slowed down the multiple Draft message dups. by by making two changes in mail prefs. First, I changed the (under General tab) "Check for new messages" to a longer period. I am now using 5 Min instead of Automatic or 1 Min. Then (under Accounts, Advanced tab) deselected on all my IMAP accounts the "Use IDLE command if the server supports it" setting.


    I almost never get a string of draft emails now. Hope this helps.



  • BlueHeron30 Level 1 Level 1

    I know you posted this years ago, but I just tried your suggestion and it worked.  I had checked save draft for both my email provider and for Mail; by unchecking save drafts with the email provider but keeping save drafts to server with Mail, I'm back to "normal" - one draft is saved and it gets updated and saved by Mail without tens of duplicates.

  • 750 H2C Level 1 Level 1
    Mac OS X

    Yesterday I suddenly got the same problem, but maybe with an angle to it. For me, Mail keeps saving drafts all the time, once a minute or so, but only when Mail is the active app and not only when I'm composing messages. When I'm in Mail, reading messages, I get a growing number of empty drafts in my Drafts box. If I'm composing, I get non-empty drafts. The draft list keeps growing very quickly.

    I just scrapped the Mail prefs, let's see if it works. Looking good so far.

    Edit: Nope, didn't help. New drafts keep popping up.

  • 750 H2C Level 1 Level 1
    Mac OS X

    But now it seems to have stopped. Very strange. Is there some kind of delay on trashing prefs?

  • 750 H2C Level 1 Level 1
    Mac OS X

    Didn't help. Also, removing the entire Mail account and rebuilding it from scratch didn't help.


    I've tried talking to my ISP but they're not very keen on accepting any kind of responsibility. According to them, this is entirely my problem.

Previous 1 2 3 4 Next